summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-07-19 09:00:14 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-07-19 09:00:14 +0000
commit44d357e772fdcf2f30ca5f2651acb87a4e2c127b (patch)
treec4d19dd69677a2f9bcd5bd4a143ff99551db1930 /net-p2p
parentVersion bump (diff)
downloadgentoo-2-44d357e772fdcf2f30ca5f2651acb87a4e2c127b.tar.gz
gentoo-2-44d357e772fdcf2f30ca5f2651acb87a4e2c127b.tar.bz2
gentoo-2-44d357e772fdcf2f30ca5f2651acb87a4e2c127b.zip
Version bump
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog8
-rw-r--r--net-p2p/qbittorrent/files/digest-qbittorrent-1.0.0_beta13
-rw-r--r--net-p2p/qbittorrent/qbittorrent-1.0.0_beta1.ebuild46
3 files changed, 56 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 6d5b83f11de9..d90c8108fd89 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.9 2007/06/08 10:21:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.10 2007/07/19 09:00:14 armin76 Exp $
+
+*qbittorrent-1.0.0_beta1 (19 Jul 2007)
+
+ 19 Jul 2007; Raúl Porcel <armin76@gentoo.org>
+ +qbittorrent-1.0.0_beta1.ebuild:
+ Version bump
08 Jun 2007; Raúl Porcel <armin76@gentoo.org> -qbittorrent-0.8.0.ebuild,
-qbittorrent-0.9.2.ebuild, qbittorrent-0.9.3.ebuild:
diff --git a/net-p2p/qbittorrent/files/digest-qbittorrent-1.0.0_beta1 b/net-p2p/qbittorrent/files/digest-qbittorrent-1.0.0_beta1
new file mode 100644
index 000000000000..1c19f2b18fb0
--- /dev/null
+++ b/net-p2p/qbittorrent/files/digest-qbittorrent-1.0.0_beta1
@@ -0,0 +1,3 @@
+MD5 8b1ba67f2c32e014315928e013da2256 qbittorrent-1.0.0beta1.tar.gz 1059140
+RMD160 5cfc6d8e06671adf1a5d82f7abd6cec4deb13f61 qbittorrent-1.0.0beta1.tar.gz 1059140
+SHA256 67f7799cf52626595b5aaa350b98eb38eecabcdc190c8086c632402ec2db3545 qbittorrent-1.0.0beta1.tar.gz 1059140
diff --git a/net-p2p/qbittorrent/qbittorrent-1.0.0_beta1.ebuild b/net-p2p/qbittorrent/qbittorrent-1.0.0_beta1.ebuild
new file mode 100644
index 000000000000..dd6d3db94b39
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-1.0.0_beta1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-1.0.0_beta1.ebuild,v 1.1 2007/07/19 09:00:14 armin76 Exp $
+
+inherit eutils qt4
+
+MY_P="${P/_/}"
+
+DESCRIPTION="BitTorrent client in C++ and Qt."
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-libs/rb_libtorrent-0.13_pre1049
+ $(qt4_min_version 4.2)
+ >=dev-lang/python-2.3
+ dev-libs/boost
+ net-misc/curl"
+
+pkg_setup() {
+ # We need boost built with threads
+ if ! has_version ">=dev-libs/boost-1.34_pre20061214" && \
+ ! built_with_use "dev-libs/boost" threads; then
+ eerror "${PN} needs dev-libs/boost built with threads USE flag"
+ die "dev-libs/boost is built without threads USE flag"
+ fi
+}
+
+src_compile() {
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr \
+ --with-libtorrent-inc=/usr/include \
+ --with-libtorrent-lib=/usr/lib \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc AUTHORS Changelog NEWS README TODO
+}