summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-05 06:43:55 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-05 06:43:55 +0000
commit47bfda3b6b978cdb40177332f83d733c528646b3 (patch)
tree171f578a6fb1900644e2614e30d01422127fba31 /net-p2p
parentAdding bugfix patches recommended by upstream. (diff)
downloadgentoo-2-47bfda3b6b978cdb40177332f83d733c528646b3.tar.gz
gentoo-2-47bfda3b6b978cdb40177332f83d733c528646b3.tar.bz2
gentoo-2-47bfda3b6b978cdb40177332f83d733c528646b3.zip
Adding bugfix patch recommended by upstream.
(Portage version: 2.1.5.3)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/ChangeLog9
-rw-r--r--net-p2p/rtorrent/files/rtorrent-0.8.2-fix_start_stop_filter.patch19
-rw-r--r--net-p2p/rtorrent/metadata.xml14
-rw-r--r--net-p2p/rtorrent/rtorrent-0.8.0.ebuild57
-rw-r--r--net-p2p/rtorrent/rtorrent-0.8.2-r2.ebuild (renamed from net-p2p/rtorrent/rtorrent-0.8.2.ebuild)3
5 files changed, 39 insertions, 63 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index e3e3b4136dc9..eabbcefca6df 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.108 2008/05/27 16:59:02 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.109 2008/06/05 06:43:54 loki_val Exp $
+
+*rtorrent-0.8.2-r2 (05 Jun 2008)
+
+ 05 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/rtorrent-0.8.2-fix_start_stop_filter.patch, metadata.xml,
+ -rtorrent-0.8.0.ebuild, -rtorrent-0.8.2.ebuild, +rtorrent-0.8.2-r2.ebuild:
+ Adding bugfix patch recommended by upstream.
*rtorrent-0.8.2 (27 May 2008)
diff --git a/net-p2p/rtorrent/files/rtorrent-0.8.2-fix_start_stop_filter.patch b/net-p2p/rtorrent/files/rtorrent-0.8.2-fix_start_stop_filter.patch
new file mode 100644
index 000000000000..2f9267821104
--- /dev/null
+++ b/net-p2p/rtorrent/files/rtorrent-0.8.2-fix_start_stop_filter.patch
@@ -0,0 +1,19 @@
+Index: rtorrent/src/main.cc
+===================================================================
+--- rtorrent/src/main.cc (revision 1060)
++++ rtorrent/src/main.cc (working copy)
+@@ -187,12 +187,12 @@
+ "view_filter = active,false=\n"
+
+ "view_add = started\n"
+- "view_filter = started,false=\n"
++ "view_filter = started,d.get_state=\n"
+ "view.event_added = started,scheduler.simple.added=\n"
+ "view.event_removed = started,scheduler.simple.removed=\n"
+
+ "view_add = stopped\n"
+- "view_filter = stopped,false=\n"
++ "view_filter = stopped,not=$d.get_state=\n"
+
+ "view_add = complete\n"
+ "view_filter = complete,d.get_complete=\n"
diff --git a/net-p2p/rtorrent/metadata.xml b/net-p2p/rtorrent/metadata.xml
index 369cd103a159..43c12b95722f 100644
--- a/net-p2p/rtorrent/metadata.xml
+++ b/net-p2p/rtorrent/metadata.xml
@@ -3,11 +3,17 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>drizzt@gentoo.org</email>
- <name>Timothy Redaelli</name>
- <description>Secondary Maintainer</description>
+ <email>loki_val@gentoo.org</email>
+ <name>Peter Alfredsen</name>
+ <description>I've changed too much to avoid adding myself</description>
+</maintainer>
+<maintainer>
+ <email>drizzt@gentoo.org</email>
+ <name>Timothy Redaelli</name>
+ <description>Secondary Maintainer</description>
</maintainer>
<longdescription lang="en">
-Console BitTorrent client using ncurses based on libtorrent written in C++.
+ Console BitTorrent client using ncurses based on libtorrent written in C++.
</longdescription>
+
</pkgmetadata>
diff --git a/net-p2p/rtorrent/rtorrent-0.8.0.ebuild b/net-p2p/rtorrent/rtorrent-0.8.0.ebuild
deleted file mode 100644
index 7ac0527fd3ef..000000000000
--- a/net-p2p/rtorrent/rtorrent-0.8.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.0.ebuild,v 1.2 2008/04/21 15:08:51 flameeyes Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="BitTorrent Client using libtorrent"
-HOMEPAGE="http://libtorrent.rakshasa.no/"
-SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug ipv6 xmlrpc"
-
-RDEPEND=">=net-libs/libtorrent-0.12.${PV##*.}
- >=dev-libs/libsigc++-2.0
- >=net-misc/curl-7.15
- sys-libs/ncurses
- xmlrpc? ( dev-libs/xmlrpc-c )"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}+gcc-4.3.patch"
-}
-
-src_compile() {
- replace-flags -Os -O2
- append-flags -fno-strict-aliasing
-
- if [[ $(tc-arch) = "x86" ]]; then
- filter-flags -fomit-frame-pointer -fforce-addr
- fi
-
- econf \
- $(use_enable debug) \
- $(use_enable ipv6) \
- $(use_with xmlrpc xmlrpc-c) \
- --disable-dependency-tracking \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-pkg_postinst() {
- elog "rtorrent now supports a configuration file."
- elog "A sample configuration file for rtorrent is can be found"
- elog "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS README TODO doc/rtorrent.rc
-}
diff --git a/net-p2p/rtorrent/rtorrent-0.8.2.ebuild b/net-p2p/rtorrent/rtorrent-0.8.2-r2.ebuild
index 629a75b7d194..9b8f7549db40 100644
--- a/net-p2p/rtorrent/rtorrent-0.8.2.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.8.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.2.ebuild,v 1.1 2008/05/27 16:59:02 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.2-r2.ebuild,v 1.1 2008/06/05 06:43:55 loki_val Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -23,6 +23,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-0.8.0+gcc-4.3.patch
+ epatch "${FILESDIR}"/${P}-fix_start_stop_filter.patch
}
src_compile() {