summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-09-20 11:57:37 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-09-20 11:57:37 +0000
commit5fbf74684c52458cb413dc1d69071bd34e615864 (patch)
tree5b9d6669d8c214b42e15b7118cd5c92a1a9aba02 /net-p2p
parentAdjust blocker to correct version of mesa. (diff)
downloadgentoo-2-5fbf74684c52458cb413dc1d69071bd34e615864.tar.gz
gentoo-2-5fbf74684c52458cb413dc1d69071bd34e615864.tar.bz2
gentoo-2-5fbf74684c52458cb413dc1d69071bd34e615864.zip
Stable on ppc. Remove older. Wrt bug#428338.
(Portage version: 2.2.0_alpha128/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/ChangeLog6
-rw-r--r--net-p2p/ktorrent/ktorrent-4.2.0.ebuild102
-rw-r--r--net-p2p/ktorrent/ktorrent-4.2.1.ebuild4
3 files changed, 7 insertions, 105 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index 07cc2e4dc73e..e0bd4aed7e63 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.185 2012/09/04 22:16:56 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.186 2012/09/20 11:57:37 scarabeus Exp $
+
+ 20 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org> -ktorrent-4.2.0.ebuild,
+ ktorrent-4.2.1.ebuild:
+ Stable on ppc. Remove older. Wrt bug#428338.
*ktorrent-4.3.0 (04 Sep 2012)
diff --git a/net-p2p/ktorrent/ktorrent-4.2.0.ebuild b/net-p2p/ktorrent/ktorrent-4.2.0.ebuild
deleted file mode 100644
index af3c6b11f8d9..000000000000
--- a/net-p2p/ktorrent/ktorrent-4.2.0.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-4.2.0.ebuild,v 1.4 2012/07/11 01:04:30 xmw Exp $
-
-EAPI=4
-
-KDE_SCM="git"
-KDE_MINIMAL="4.5"
-LIBKT_VERSION_MIN="${PV}"
-LIBKT_VERSION_MAX="99999999"
-if [[ ${PV} != 9999* ]]; then
- inherit versionator
- # upstream likes to skip that _ in beta releases
- MY_PV="${PV/_/}"
- LIBKT_VERSION_MIN=$(($(get_major_version)-3)).$(get_version_component_range 2-3 ${PV})
- LIBKT_VERSION_MAX=$(($(get_major_version)-3)).$(($(get_version_component_range 2)+1))
- MY_P="${PN}-${MY_PV}"
- KDE_HANDBOOK="optional"
- KDE_DOC_DIRS="doc"
-
- KDE_LINGUAS="ar ast be bg ca ca@valencia cs da de el en_GB eo es et eu
- fi fr ga gl hi hne hr hu is it ja km lt lv mai ms nb nds nl nn oc
- pl pt pt_BR ro ru se si sk sl sr sr@ijekavian sr@ijekavianlatin
- sr@latin sv tr uk zh_CN zh_TW"
- SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.bz2"
- S="${WORKDIR}"/"${MY_P}"
-
- KEYWORDS="amd64 ppc ~ppc64 x86"
-else
- LIBKT_VERSION_MIN="${PV}"
- LIBKT_VERSION_MAX="99999999"
- KEYWORDS=""
-fi
-
-inherit kde4-base
-
-DESCRIPTION="A BitTorrent program for KDE."
-HOMEPAGE="http://ktorrent.org/"
-
-LICENSE="GPL-2"
-SLOT="4"
-IUSE="+bwscheduler debug +downloadorder +infowidget +ipfilter +kross +logviewer
-+magnetgenerator +mediaplayer plasma rss +scanfolder +search +shutdown +stats
-+upnp webinterface +zeroconf"
-
-COMMONDEPEND="
- <net-libs/libktorrent-${LIBKT_VERSION_MAX}
- >=net-libs/libktorrent-${LIBKT_VERSION_MIN}
- infowidget? ( dev-libs/geoip )
- mediaplayer? ( >=media-libs/taglib-1.5 )
- plasma? ( $(add_kdebase_dep libtaskmanager) )
- rss? ( $(add_kdebase_dep kdepimlibs) )
- shutdown? (
- $(add_kdebase_dep libkworkspace)
- $(add_kdebase_dep solid)
- )
-"
-DEPEND="${COMMONDEPEND}
- dev-libs/boost
- sys-devel/gettext
-"
-RDEPEND="${COMMONDEPEND}
- ipfilter? (
- app-arch/bzip2
- app-arch/unzip
- $(add_kdebase_dep kdebase-kioslaves)
- )
- kross? ( $(add_kdebase_dep krosspython) )
-"
-
-src_prepare() {
- if ! use plasma; then
- sed -i \
- -e "s:add_subdirectory(plasma):#nada:g" \
- CMakeLists.txt || die "Failed to make plasmoid optional"
- fi
-
- kde4-base_src_prepare
-}
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_enable bwscheduler BWSCHEDULER_PLUGIN)
- $(cmake-utils_use_enable downloadorder DOWNLOADORDER_PLUGIN)
- $(cmake-utils_use_enable infowidget INFOWIDGET_PLUGIN)
- $(cmake-utils_use_with infowidget SYSTEM_GEOIP)
- $(cmake-utils_use_enable ipfilter IPFILTER_PLUGIN)
- $(cmake-utils_use_enable kross SCRIPTING_PLUGIN)
- $(cmake-utils_use_enable logviewer LOGVIEWER_PLUGIN)
- $(cmake-utils_use_enable magnetgenerator MAGNETGENERATOR_PLUGIN)
- $(cmake-utils_use_enable mediaplayer MEDIAPLAYER_PLUGIN)
- $(cmake-utils_use_enable rss SYNDICATION_PLUGIN)
- $(cmake-utils_use_enable scanfolder SCANFOLDER_PLUGIN)
- $(cmake-utils_use_enable search SEARCH_PLUGIN)
- $(cmake-utils_use_enable shutdown SHUTDOWN_PLUGIN)
- $(cmake-utils_use_enable stats STATS_PLUGIN)
- $(cmake-utils_use_enable upnp UPNP_PLUGIN)
- $(cmake-utils_use_enable webinterface WEBINTERFACE_PLUGIN)
- $(cmake-utils_use_enable zeroconf ZEROCONF_PLUGIN)
- )
- kde4-base_src_configure
-}
diff --git a/net-p2p/ktorrent/ktorrent-4.2.1.ebuild b/net-p2p/ktorrent/ktorrent-4.2.1.ebuild
index d19705f829b3..9bc0366c5f12 100644
--- a/net-p2p/ktorrent/ktorrent-4.2.1.ebuild
+++ b/net-p2p/ktorrent/ktorrent-4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-4.2.1.ebuild,v 1.3 2012/08/05 20:57:11 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-4.2.1.ebuild,v 1.4 2012/09/20 11:57:37 scarabeus Exp $
EAPI=4
@@ -25,7 +25,7 @@ if [[ ${PV} != 9999* ]]; then
SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.bz2"
S="${WORKDIR}"/"${MY_P}"
- KEYWORDS="amd64 ~ppc ~ppc64 x86"
+ KEYWORDS="amd64 ppc ~ppc64 x86"
else
LIBKT_VERSION_MIN="${PV}"
LIBKT_VERSION_MAX="99999999"