summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-01-13 06:29:19 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-01-13 06:29:19 +0000
commit65b174826e60aaee40a758e16a38190818603f70 (patch)
treedf4c5bc6d7d65d236f3aff7a9f4efb10d22d33ab /net-p2p
parentsocketpool supports py3, added to PYTHON_COMPAT in rev bump (diff)
downloadgentoo-2-65b174826e60aaee40a758e16a38190818603f70.tar.gz
gentoo-2-65b174826e60aaee40a758e16a38190818603f70.tar.bz2
gentoo-2-65b174826e60aaee40a758e16a38190818603f70.zip
Version bump wrt #451492 by jospezial. Remove custom KDE magnet service file because upstream -qt.desktop file gained magnet support through MimeType. Drop rest of unsupported 9999 code
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission/ChangeLog11
-rw-r--r--net-p2p/transmission/transmission-2.76.ebuild139
2 files changed, 148 insertions, 2 deletions
diff --git a/net-p2p/transmission/ChangeLog b/net-p2p/transmission/ChangeLog
index fbd3fa1e590f..9bc67c90d087 100644
--- a/net-p2p/transmission/ChangeLog
+++ b/net-p2p/transmission/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/transmission
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.221 2012/12/18 05:05:31 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.222 2013/01/13 06:29:19 ssuominen Exp $
+
+*transmission-2.76 (13 Jan 2013)
+
+ 13 Jan 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +transmission-2.76.ebuild:
+ Version bump wrt #451492 by jospezial. Remove custom KDE magnet service file
+ because upstream -qt.desktop file gained magnet support through MimeType.
*transmission-2.75 (18 Dec 2012)
diff --git a/net-p2p/transmission/transmission-2.76.ebuild b/net-p2p/transmission/transmission-2.76.ebuild
new file mode 100644
index 000000000000..10dc5beb65de
--- /dev/null
+++ b/net-p2p/transmission/transmission-2.76.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-2.76.ebuild,v 1.1 2013/01/13 06:29:19 ssuominen Exp $
+
+EAPI=5
+inherit autotools eutils fdo-mime gnome2-utils qt4-r2 user
+
+DESCRIPTION="A Fast, Easy and Free BitTorrent client"
+HOMEPAGE="http://www.transmissionbt.com/"
+SRC_URI="http://download.transmissionbt.com/${PN}/files/${P}.tar.xz"
+
+LICENSE="GPL-2 MIT"
+SLOT=0
+IUSE="ayatana gtk lightweight qt4 xfs"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux"
+
+RDEPEND="
+ >=dev-libs/libevent-2.0.10
+ dev-libs/openssl:0
+ net-libs/libnatpmp
+ >=net-libs/miniupnpc-1.6.20120509
+ >=net-misc/curl-7.16.3[ssl]
+ sys-libs/zlib
+ gtk? (
+ >=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.28
+ >=x11-libs/gtk+-3.4:3
+ ayatana? ( >=dev-libs/libappindicator-0.4.90:3 )
+ )
+ qt4? (
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4[dbus]
+ )"
+
+DEPEND="${RDEPEND}
+ >=dev-libs/glib-2
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/os-headers
+ virtual/pkgconfig
+ xfs? ( sys-fs/xfsprogs )"
+
+REQUIRED_USE="ayatana? ( gtk )"
+
+DOCS="AUTHORS NEWS qt/README.txt"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_prepare() {
+ sed -i -e '/CFLAGS/s:-ggdb3::' configure.ac
+ use ayatana || sed -i -e '/^LIBAPPINDICATOR_MINIMUM/s:=.*:=9999:' configure.ac
+
+ # http://trac.transmissionbt.com/ticket/4324
+ sed -i -e 's|noinst\(_PROGRAMS = $(TESTS)\)|check\1|' lib${PN}/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ export ac_cv_header_xfs_xfs_h=$(usex xfs)
+
+ econf \
+ --enable-external-natpmp \
+ $(use_enable lightweight) \
+ $(use_with gtk)
+
+ if use qt4; then
+ pushd qt >/dev/null
+ eqmake4 qtr.pro
+ popd >/dev/null
+ fi
+}
+
+src_compile() {
+ emake
+
+ if use qt4; then
+ pushd qt >/dev/null
+ emake
+ lrelease translations/*.ts
+ popd >/dev/null
+ fi
+}
+
+src_install() {
+ default
+
+ rm -f "${ED}"/usr/share/${PN}/web/LICENSE
+
+ newinitd "${FILESDIR}"/${PN}-daemon.initd.8 ${PN}-daemon
+ newconfd "${FILESDIR}"/${PN}-daemon.confd.3 ${PN}-daemon
+
+ keepdir /var/{${PN}/{config,downloads},log/${PN}}
+ fowners -R ${PN}:${PN} /var/{${PN}/{,config,downloads},log/${PN}}
+
+ if use qt4; then
+ pushd qt >/dev/null
+ emake INSTALL_ROOT="${ED}"/usr install
+
+ domenu ${PN}-qt.desktop
+
+ local res
+ for res in 16 22 24 32 48; do
+ newicon -s ${res} icons/hicolor_apps_${res}x${res}_${PN}.png ${PN}-qt.png
+ done
+
+ insinto /usr/share/qt4/translations
+ doins translations/*.qm
+ popd >/dev/null
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+
+ elog "If you use ${PN}-daemon, please, set 'rpc-username' and"
+ elog "'rpc-password' (in plain text, ${PN}-daemon will hash it on"
+ elog "start) in settings.json file located at /var/${PN}/config or"
+ elog "any other appropriate config directory."
+ elog
+ elog "Since µTP is enabled by default, ${PN} needs large kernel buffers for"
+ elog "the UDP socket. You can append following lines into /etc/sysctl.conf:"
+ elog " net.core.rmem_max = 4194304"
+ elog " net.core.wmem_max = 1048576"
+ elog "and run sysctl -p"
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}