summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-04-06 20:05:36 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-04-06 20:05:36 +0000
commit6e975fcac51ba33850543cc4e4697bcff39fde06 (patch)
treefe8c0f113778402cd561172566274b7246f2d6e2 /net-p2p
parentAdded a build-fix patch for hppa. (Manifest recommit) (diff)
downloadgentoo-2-6e975fcac51ba33850543cc4e4697bcff39fde06.tar.gz
gentoo-2-6e975fcac51ba33850543cc4e4697bcff39fde06.tar.bz2
gentoo-2-6e975fcac51ba33850543cc4e4697bcff39fde06.zip
Version bumped.
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bittorrent/ChangeLog7
-rw-r--r--net-p2p/bittorrent/Manifest8
-rw-r--r--net-p2p/bittorrent/bittorrent-3.4.2.ebuild61
-rw-r--r--net-p2p/bittorrent/files/digest-bittorrent-3.4.21
4 files changed, 73 insertions, 4 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index 447dac5b229b..adf9935e219d 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.26 2004/03/15 00:34:40 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.27 2004/04/06 20:05:36 mholzer Exp $
+
+*bittorrent-3.4.2 (06 Apr 2004)
+
+ 06 Apr 2004; Martin Holzer <mholzer@gentoo.org> bittorrent-3.4.2.ebuild:
+ Version bumped.
14 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org>
bittorrent-3.3.0.ebuild, bittorrent-3.4.1.ebuild, bittorrent-3.4.1a.ebuild:
diff --git a/net-p2p/bittorrent/Manifest b/net-p2p/bittorrent/Manifest
index 69f64583b5e0..b141188f73a2 100644
--- a/net-p2p/bittorrent/Manifest
+++ b/net-p2p/bittorrent/Manifest
@@ -1,8 +1,10 @@
-MD5 bb9989353627f50e2397b3a46cd51147 bittorrent-3.4.1a.ebuild 1731
+MD5 a6761370b1fc73c9f6ca81b51ff6f101 bittorrent-3.4.2.ebuild 1730
MD5 7e78978592c2e840132fe9e2534e2df7 bittorrent-3.4.1.ebuild 1730
MD5 d8e721ca464d54e1519530cd0699c159 bittorrent-3.3.0.ebuild 1718
-MD5 b087b650b17676cc0319ac93cf810a30 ChangeLog 4185
MD5 71c4638c9c88af75b58e5f5cb54fe008 metadata.xml 159
-MD5 041cb026a6f1c38c3ceef68e3a3001de files/digest-bittorrent-3.4.1a 66
+MD5 b087b650b17676cc0319ac93cf810a30 ChangeLog 4185
+MD5 bb9989353627f50e2397b3a46cd51147 bittorrent-3.4.1a.ebuild 1731
MD5 5552dfd01545331cd268d47a8a18165e files/digest-bittorrent-3.3.0 66
+MD5 13f6b888eed806a8d4ce9cea22a7bacc files/digest-bittorrent-3.4.2 65
+MD5 041cb026a6f1c38c3ceef68e3a3001de files/digest-bittorrent-3.4.1a 66
MD5 55203bedc153a58daef48bc35451abd6 files/digest-bittorrent-3.4.1 65
diff --git a/net-p2p/bittorrent/bittorrent-3.4.2.ebuild b/net-p2p/bittorrent/bittorrent-3.4.2.ebuild
new file mode 100644
index 000000000000..c7a628fce973
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-3.4.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-3.4.2.ebuild,v 1.1 2004/04/06 20:05:36 mholzer Exp $
+
+inherit distutils
+
+MY_P="${P/bittorrent/BitTorrent}"
+MY_P="${MY_P/\.0/}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="BitTorrent is a tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://bitconjurer.org/BitTorrent"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+RESTRICT="nomirror"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~amd64"
+
+IUSE="X"
+
+RDEPEND="X? ( >=dev-python/wxPython-2.2 )
+ >=dev-lang/python-2.1
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ >=sys-apps/sed-4.0.5"
+PROVIDE="virtual/bittorrent"
+
+DOCS="credits.txt"
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ rm ${D}/usr/bin/*gui.py
+ fi
+ dohtml redirdonate.html
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ fi
+}
+
+pkg_postinst() {
+ einfo "unofficial feature additions. If you would like statistics, please"
+ einfo "install net-p2p/bittorrent-stats."
+}
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-3.4.2 b/net-p2p/bittorrent/files/digest-bittorrent-3.4.2
new file mode 100644
index 000000000000..3ea4d81b56f2
--- /dev/null
+++ b/net-p2p/bittorrent/files/digest-bittorrent-3.4.2
@@ -0,0 +1 @@
+MD5 6ad4e128ddc82f8ebef6fbef59872f0d BitTorrent-3.4.2.zip 244989