summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-08 16:03:39 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-08 16:03:39 +0000
commita1dc2171aef7c9d9291d8ec2a41dd4b42c7095dd (patch)
tree3ed4e2f894499a2ed785c3414e40f31ff274283e /net-p2p
parentBump LeechCraft to 0.5.85, thanks to 0xd34df00d (diff)
downloadgentoo-2-a1dc2171aef7c9d9291d8ec2a41dd4b42c7095dd.tar.gz
gentoo-2-a1dc2171aef7c9d9291d8ec2a41dd4b42c7095dd.tar.bz2
gentoo-2-a1dc2171aef7c9d9291d8ec2a41dd4b42c7095dd.zip
Bump LeechCraft to 0.5.85, thanks to 0xd34df00d
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/leechcraft-eiskaltdcpp/ChangeLog8
-rw-r--r--net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.5.85.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/net-p2p/leechcraft-eiskaltdcpp/ChangeLog b/net-p2p/leechcraft-eiskaltdcpp/ChangeLog
index 57d75621ac63..79d136e6d9e8 100644
--- a/net-p2p/leechcraft-eiskaltdcpp/ChangeLog
+++ b/net-p2p/leechcraft-eiskaltdcpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/leechcraft-eiskaltdcpp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-eiskaltdcpp/ChangeLog,v 1.14 2012/08/13 14:13:42 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-eiskaltdcpp/ChangeLog,v 1.15 2012/10/08 16:03:39 pinkbyte Exp $
+
+*leechcraft-eiskaltdcpp-0.5.85 (08 Oct 2012)
+
+ 08 Oct 2012; Sergey Popov <pinkbyte@gentoo.org>
+ +leechcraft-eiskaltdcpp-0.5.85.ebuild:
+ Bump LeechCraft to 0.5.85, thanks to 0xd34df00d
*leechcraft-eiskaltdcpp-0.5.80 (13 Aug 2012)
diff --git a/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.5.85.ebuild b/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.5.85.ebuild
new file mode 100644
index 000000000000..5f1bcc186c57
--- /dev/null
+++ b/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.5.85.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/leechcraft-eiskaltdcpp/leechcraft-eiskaltdcpp-0.5.85.ebuild,v 1.1 2012/10/08 16:03:39 pinkbyte Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="EiskaltDC++ ported to LeechCraft."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +emoticons examples javascript lua pcre spell sqlite upnp"
+
+RDEPEND="~net-misc/leechcraft-core-${PV}
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/openssl-0.9.8
+ virtual/libiconv
+ sys-devel/gettext
+ lua? ( >=dev-lang/lua-5.1 )
+ upnp? ( net-libs/miniupnpc )
+ javascript? (
+ x11-libs/qt-script:4
+ x11-libs/qtscriptgenerator
+ )
+ spell? ( app-text/aspell )
+ sqlite? ( x11-libs/qt-sql:4[sqlite] )
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ virtual/leechcraft-task-show
+ !!net-p2p/eiskaltdcpp"
+DEPEND="~net-misc/leechcraft-core-${PV}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ "$(cmake-utils_use lua LUA_SCRIPT)"
+ "$(cmake-utils_use lua WITH_LUASCRIPTS)"
+ "$(cmake-utils_use javascript USE_JS)"
+ "$(cmake-utils_use spell USE_ASPELL)"
+ "$(cmake-utils_use sqlite USE_QT_SQLITE)"
+ "$(cmake-utils_use upnp USE_MINIUPNP)"
+ -DLOCAL_MINIUPNP="0"
+ "$(cmake-utils_use emoticons WITH_EMOTICONS)"
+ "$(cmake-utils_use examples WITH_EXAMPLES)"
+ "$(cmake-utils_use pcre PERL_REGEX)"
+ )
+
+ cmake-utils_src_configure
+}