summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-06-27 09:20:19 +0000
committerPeter Volkov <pva@gentoo.org>2011-06-27 09:20:19 +0000
commita5baae2456e2797e9a9606555355657cf2005ced (patch)
tree51afa229c972ce9f24e65cc16b2cc1dec53026f0 /net-p2p
parentBump required autoconf version to 2.65 (bug 372461). (diff)
downloadgentoo-2-a5baae2456e2797e9a9606555355657cf2005ced.tar.gz
gentoo-2-a5baae2456e2797e9a9606555355657cf2005ced.tar.bz2
gentoo-2-a5baae2456e2797e9a9606555355657cf2005ced.zip
Version bump: de translation, readline daemon is not available any more, for xmlrpc >=xmlrpc-c-1.19 (currently not in tree) is required. Thank Nikoli for this job.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/eiskaltdcpp/ChangeLog10
-rw-r--r--net-p2p/eiskaltdcpp/eiskaltdcpp-2.2.3.ebuild108
-rw-r--r--net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild8
-rw-r--r--net-p2p/eiskaltdcpp/metadata.xml1
4 files changed, 120 insertions, 7 deletions
diff --git a/net-p2p/eiskaltdcpp/ChangeLog b/net-p2p/eiskaltdcpp/ChangeLog
index dc2d1c06d71f..9bbfd4dc4a75 100644
--- a/net-p2p/eiskaltdcpp/ChangeLog
+++ b/net-p2p/eiskaltdcpp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/eiskaltdcpp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/eiskaltdcpp/ChangeLog,v 1.29 2011/05/25 07:22:54 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/eiskaltdcpp/ChangeLog,v 1.30 2011/06/27 09:20:19 pva Exp $
+
+*eiskaltdcpp-2.2.3 (27 Jun 2011)
+
+ 27 Jun 2011; Peter Volkov <pva@gentoo.org> +eiskaltdcpp-2.2.3.ebuild,
+ eiskaltdcpp-9999.ebuild, metadata.xml:
+ Version bump: de translation, readline daemon is not available any more, for
+ xmlrpc >=xmlrpc-c-1.19 (currently not in tree) is required. Thank Nikoli for
+ this job.
25 May 2011; Peter Volkov <pva@gentoo.org> -eiskaltdcpp-2.1.1.ebuild:
Drop old.
diff --git a/net-p2p/eiskaltdcpp/eiskaltdcpp-2.2.3.ebuild b/net-p2p/eiskaltdcpp/eiskaltdcpp-2.2.3.ebuild
new file mode 100644
index 000000000000..cf784aa82911
--- /dev/null
+++ b/net-p2p/eiskaltdcpp/eiskaltdcpp-2.2.3.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/eiskaltdcpp/eiskaltdcpp-2.2.3.ebuild,v 1.1 2011/06/27 09:20:19 pva Exp $
+
+EAPI="4"
+
+LANGS="be bg cs de en es fr hu pl ru sk sr uk"
+
+[[ ${PV} = *9999* ]] && VCS_ECLASS="git" || VCS_ECLASS=""
+inherit cmake-utils ${VCS_ECLASS}
+
+DESCRIPTION="Qt4 based client for DirectConnect and ADC protocols, based on DC++ library"
+HOMEPAGE="http://eiskaltdc.googlecode.com/"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+IUSE="daemon dbus +emoticons examples -gnome -gtk idn -javascript libnotify lua +minimal pcre +qt4 sound spell sqlite upnp"
+for x in ${LANGS}; do
+ IUSE="${IUSE} linguas_${x}"
+done
+
+REQUIRED_USE="
+ emoticons? ( || ( gtk qt4 ) )
+ dbus? ( qt4 )
+ gnome? ( gtk )
+ javascript? ( qt4 )
+ libnotify? ( gtk )
+ spell? ( qt4 )
+ sound? ( || ( gtk qt4 ) )
+ sqlite? ( qt4 )
+"
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="http://${PN/pp/}.googlecode.com/files/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+else
+ EGIT_REPO_URI="git://github.com/negativ/${PN}.git"
+ KEYWORDS=""
+fi
+
+RDEPEND="
+ app-arch/bzip2
+ >=dev-libs/openssl-0.9.8
+ sys-devel/gettext
+ sys-libs/zlib
+ virtual/libiconv
+ idn? ( net-dns/libidn )
+ lua? ( >=dev-lang/lua-5.1 )
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ upnp? ( net-libs/miniupnpc )
+ gtk? (
+ x11-libs/pango
+ >=x11-libs/gtk+-2.10:2
+ >=dev-libs/glib-2.10:2
+ >=gnome-base/libglade-2.4:2.0
+ x11-themes/hicolor-icon-theme
+ gnome? ( gnome-base/libgnome )
+ libnotify? ( >=x11-libs/libnotify-0.4.1 )
+ )
+ qt4? (
+ >=x11-libs/qt-gui-4.4.0:4[dbus?]
+ javascript? (
+ x11-libs/qt-script
+ x11-libs/qtscriptgenerator
+ )
+ spell? ( app-text/aspell )
+ sqlite? ( x11-libs/qt-sql:4[sqlite] )
+ )
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.34.1
+ dev-util/pkgconfig
+"
+DOCS="AUTHORS ChangeLog.txt"
+
+src_configure() {
+ # linguas
+ local langs x
+ for x in ${LANGS}; do
+ use linguas_${x} && langs+=" ${x}"
+ done
+
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ -Dlinguas="${langs}"
+ -DLOCAL_MINIUPNP=OFF
+ "$(cmake-utils_use daemon NO_UI_DAEMON)"
+ "$(cmake-utils_use dbus DBUS_NOTIFY)"
+ "$(cmake-utils_use emoticons WITH_EMOTICONS)"
+ "$(cmake-utils_use examples WITH_EXAMPLES)"
+ "$(cmake-utils_use gnome USE_LIBGNOME2)"
+ "$(cmake-utils_use gtk USE_GTK)"
+ "$(cmake-utils_use idn USE_IDNA)"
+ "$(cmake-utils_use javascript USE_JS)"
+ "$(cmake-utils_use libnotify USE_LIBNOTIFY)"
+ "$(cmake-utils_use lua LUA_SCRIPT)"
+ "$(cmake-utils_use lua WITH_LUASCRIPTS)"
+ "$(cmake-utils_use !minimal WITH_DEV_FILES)"
+ "$(cmake-utils_use pcre PERL_REGEX)"
+ "$(cmake-utils_use qt4 USE_QT)"
+ "$(cmake-utils_use sound WITH_SOUNDS)"
+ "$(cmake-utils_use spell USE_ASPELL)"
+ "$(cmake-utils_use sqlite USE_QT_SQLITE)"
+ "$(cmake-utils_use upnp USE_MINIUPNP)"
+ -DXMLRPC_DAEMON=OFF
+ )
+ cmake-utils_src_configure
+}
diff --git a/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild b/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
index 678e2ceed872..b11f437aa5e2 100644
--- a/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
+++ b/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild,v 1.21 2011/04/29 19:58:45 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/eiskaltdcpp/eiskaltdcpp-9999.ebuild,v 1.22 2011/06/27 09:20:19 pva Exp $
EAPI="4"
-LANGS="be bg cs en es fr hu pl ru sk sr uk"
+LANGS="be bg cs de en es fr hu pl ru sk sr uk"
[[ ${PV} = *9999* ]] && VCS_ECLASS="git" || VCS_ECLASS=""
inherit cmake-utils ${VCS_ECLASS}
@@ -14,7 +14,7 @@ HOMEPAGE="http://eiskaltdc.googlecode.com/"
LICENSE="GPL-2 GPL-3"
SLOT="0"
-IUSE="cli daemon dbus +emoticons examples -gnome -gtk idn -javascript libnotify lua +minimal pcre +qt4 sound spell sqlite upnp"
+IUSE="daemon dbus +emoticons examples -gnome -gtk idn -javascript libnotify lua +minimal pcre +qt4 sound spell sqlite upnp"
for x in ${LANGS}; do
IUSE="${IUSE} linguas_${x}"
done
@@ -44,7 +44,6 @@ RDEPEND="
sys-devel/gettext
sys-libs/zlib
virtual/libiconv
- cli? ( sys-libs/readline )
idn? ( net-dns/libidn )
lua? ( >=dev-lang/lua-5.1 )
pcre? ( >=dev-libs/libpcre-4.2 )
@@ -85,7 +84,6 @@ src_configure() {
-DLIB_INSTALL_DIR="$(get_libdir)"
-Dlinguas="${langs}"
-DLOCAL_MINIUPNP=OFF
- "$(cmake-utils_use cli CLI_DAEMON)"
"$(cmake-utils_use daemon NO_UI_DAEMON)"
"$(cmake-utils_use dbus DBUS_NOTIFY)"
"$(cmake-utils_use emoticons WITH_EMOTICONS)"
diff --git a/net-p2p/eiskaltdcpp/metadata.xml b/net-p2p/eiskaltdcpp/metadata.xml
index 01d96416c914..67860a11c297 100644
--- a/net-p2p/eiskaltdcpp/metadata.xml
+++ b/net-p2p/eiskaltdcpp/metadata.xml
@@ -21,7 +21,6 @@
<flag name="daemon">Enable eiskaltdcpp-daemon without any UI</flag>
<flag name="emoticons">Install emoticon packs</flag>
<flag name="minimal">Don't install headers</flag>
- <flag name="sounds">Install sound files</flag>
<flag name="upnp">Forward ports using UPnP</flag>
</use>
</pkgmetadata>