summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-03-28 10:52:45 +0000
committerAlex Alexander <wired@gentoo.org>2011-03-28 10:52:45 +0000
commita83eb3a0fcbceb0a78148bb0ec1484897dca2098 (patch)
tree726593e739b647ead39b6b2ac3638c2f9cbf228d /net-p2p
parentmailwrapper USE flag is gone. Remove if use mailwrapper..fi construct from e... (diff)
downloadgentoo-2-a83eb3a0fcbceb0a78148bb0ec1484897dca2098.tar.gz
gentoo-2-a83eb3a0fcbceb0a78148bb0ec1484897dca2098.tar.bz2
gentoo-2-a83eb3a0fcbceb0a78148bb0ec1484897dca2098.zip
fixed bug #358271
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/ChangeLog10
-rw-r--r--net-p2p/rtorrent/files/rtorrent-0.8.6-ncurses.patch16
-rw-r--r--net-p2p/rtorrent/rtorrent-0.8.6-r2.ebuild60
3 files changed, 84 insertions, 2 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index d0b7ce381d97..8055f5dfea11 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/rtorrent
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.156 2010/08/18 04:39:57 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.157 2011/03/28 10:52:45 wired Exp $
+
+*rtorrent-0.8.6-r2 (28 Mar 2011)
+
+ 28 Mar 2011; Alex Alexander <wired@gentoo.org> +rtorrent-0.8.6-r2.ebuild,
+ +files/rtorrent-0.8.6-ncurses.patch:
+ fixed bug #358271
18 Aug 2010; Jeroen Roovers <jer@gentoo.org> rtorrent-0.8.6-r1.ebuild:
Stable for HPPA (bug #311143).
diff --git a/net-p2p/rtorrent/files/rtorrent-0.8.6-ncurses.patch b/net-p2p/rtorrent/files/rtorrent-0.8.6-ncurses.patch
new file mode 100644
index 000000000000..0dabca3c88b8
--- /dev/null
+++ b/net-p2p/rtorrent/files/rtorrent-0.8.6-ncurses.patch
@@ -0,0 +1,16 @@
+rtorrent segfaults with latest ncurses (5.8).
+this patch fixes the issue.
+
+https://bugs.gentoo.org/show_bug.cgi?id=358271
+https://bugzilla.redhat.com/show_bug.cgi?id=682454
+http://libtorrent.rakshasa.no/ticket/2518
+--- src/display/canvas.h
++++ src/display/canvas.h
+@@ -48,7 +48,7 @@ class Canvas {
+ public:
+ typedef std::vector<Attributes> attributes_list;
+
+- Canvas(int x = 0, int y = 0, int width = 0, int height = 0) :
++ Canvas(int x = 0, int y = 0, int width = 1, int height = 1) :
+ m_window(newwin(height, width, y, x)) {}
+ ~Canvas() { delwin(m_window); }
diff --git a/net-p2p/rtorrent/rtorrent-0.8.6-r2.ebuild b/net-p2p/rtorrent/rtorrent-0.8.6-r2.ebuild
new file mode 100644
index 000000000000..f49560280b7d
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.8.6-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.6-r2.ebuild,v 1.1 2011/03/28 10:52:45 wired Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="daemon debug ipv6 xmlrpc"
+
+COMMON_DEPEND=">=net-libs/libtorrent-0.12.${PV##*.}
+ >=dev-libs/libsigc++-2.2.2:2
+ >=net-misc/curl-7.19.1
+ sys-libs/ncurses
+ xmlrpc? ( dev-libs/xmlrpc-c )"
+RDEPEND="${COMMON_DEPEND}
+ daemon? ( app-misc/screen )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-canvas-fix.patch
+
+ # bug #358271
+ epatch "${FILESDIR}"/${P}-ncurses.patch
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_with xmlrpc xmlrpc-c)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+
+ if use daemon; then
+ newinitd "${FILESDIR}/rtorrentd.init" rtorrentd || die "newinitd failed"
+ newconfd "${FILESDIR}/rtorrentd.conf" rtorrentd || die "newconfd failed"
+ fi
+}
+
+pkg_postinst() {
+ elog "rtorrent colors patch"
+ elog "Set colors using the options below in .rtorrent.rc:"
+ elog "Options: done_fg_color, done_bg_color, active_fg_color, active_bg_color"
+ elog "Colors: 0 = black, 1 = red, 2 = green, 3 = yellow, 4 = blue,"
+ elog "5 = magenta, 6 = cyan and 7 = white"
+ elog "Example: done_fg_color = 1"
+}