summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-12-06 20:02:50 +0000
committerJon Hood <squinky86@gentoo.org>2004-12-06 20:02:50 +0000
commitbc8777ba0661268cbaf635387443068ef9e26786 (patch)
treecf85487bae4a614c4377a338e61a70918efcd907 /net-p2p
parentInitial import of net-analyzer/ethstatus, a ncurses based utility to display ... (diff)
downloadgentoo-2-bc8777ba0661268cbaf635387443068ef9e26786.tar.gz
gentoo-2-bc8777ba0661268cbaf635387443068ef9e26786.tar.bz2
gentoo-2-bc8777ba0661268cbaf635387443068ef9e26786.zip
version bump
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gift-openft/ChangeLog7
-rw-r--r--net-p2p/gift-openft/Manifest6
-rw-r--r--net-p2p/gift-openft/files/digest-gift-openft-0.2.1.51
-rw-r--r--net-p2p/gift-openft/gift-openft-0.2.1.5.ebuild51
4 files changed, 62 insertions, 3 deletions
diff --git a/net-p2p/gift-openft/ChangeLog b/net-p2p/gift-openft/ChangeLog
index 2dcf988b51bd..f91feb4c5267 100644
--- a/net-p2p/gift-openft/ChangeLog
+++ b/net-p2p/gift-openft/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/gift-openft
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-openft/ChangeLog,v 1.23 2004/09/18 22:18:22 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-openft/ChangeLog,v 1.24 2004/12/06 20:02:50 squinky86 Exp $
+
+*gift-openft-0.2.1.5 (06 Dec 2004)
+
+ 06 Dec 2004; Jon Hood <squinky86@gentoo.org> +gift-openft-0.2.1.5.ebuild:
+ Version bump.
18 Sep 2004; Jason Wever <weeve@gentoo.org> gift-openft-0.2.1.4.ebuild:
Stable on sparc.
diff --git a/net-p2p/gift-openft/Manifest b/net-p2p/gift-openft/Manifest
index c05e17d6f027..db0e63e77dba 100644
--- a/net-p2p/gift-openft/Manifest
+++ b/net-p2p/gift-openft/Manifest
@@ -1,6 +1,8 @@
-MD5 7ba65161a20cfcfd7dc1e6b78c84645b ChangeLog 3294
MD5 5d4b2f0f8efaaff7ebbcb77bc1258334 gift-openft-0.2.1.3.ebuild 1198
-MD5 875f23093b78af2d864a7a7ba464f126 metadata.xml 223
+MD5 595c2ca5129c5eee41c1e94b14aeed0b gift-openft-0.2.1.5.ebuild 1453
MD5 c6e7dce1e4ecb29988417c4552baec67 gift-openft-0.2.1.4.ebuild 1451
+MD5 7ba65161a20cfcfd7dc1e6b78c84645b ChangeLog 3294
+MD5 875f23093b78af2d864a7a7ba464f126 metadata.xml 223
MD5 79751211679f0e879c97aa37a46d9d68 files/digest-gift-openft-0.2.1.3 72
MD5 4df11e57302a8164df847367820d27ba files/digest-gift-openft-0.2.1.4 72
+MD5 a532a22ed98ca8c5bf70897e09951045 files/digest-gift-openft-0.2.1.5 72
diff --git a/net-p2p/gift-openft/files/digest-gift-openft-0.2.1.5 b/net-p2p/gift-openft/files/digest-gift-openft-0.2.1.5
new file mode 100644
index 000000000000..dffc0dabea3b
--- /dev/null
+++ b/net-p2p/gift-openft/files/digest-gift-openft-0.2.1.5
@@ -0,0 +1 @@
+MD5 43286096e9e6e94c6a5f0da236eb4d14 gift-openft-0.2.1.5.tar.bz2 337280
diff --git a/net-p2p/gift-openft/gift-openft-0.2.1.5.ebuild b/net-p2p/gift-openft/gift-openft-0.2.1.5.ebuild
new file mode 100644
index 000000000000..a88d12ebf23e
--- /dev/null
+++ b/net-p2p/gift-openft/gift-openft-0.2.1.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-openft/gift-openft-0.2.1.5.ebuild,v 1.1 2004/12/06 20:02:50 squinky86 Exp $
+
+IUSE="berkdb"
+DESCRIPTION="The giFT OpenFT plugin"
+HOMEPAGE="http://gift.sf.net/"
+SRC_URI="mirror://sourceforge/gift/${P}.tar.bz2"
+RESTRICT="nomirror"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+
+DEPEND="virtual/libc
+ dev-util/pkgconfig
+ berkdb? ( >=sys-libs/db-3.3 )"
+
+RDEPEND=">=net-p2p/gift-0.11.5
+ >=sys-libs/zlib-1.1.4
+ berkdb? ( >=sys-libs/db-3.3 )"
+
+src_compile() {
+ econf `use_enable berkdb libdb` || die "failed to configure"
+ emake || die "failed to build"
+}
+
+src_install() {
+ einstall giftconfdir=${D}/etc/giFT \
+ plugindir=${D}/usr/lib/giFT \
+ datadir=${D}/usr/share/giFT \
+ giftperldir=${D}/usr/bin \
+ libgiftincdir=${D}/usr/include/libgift || die "Install failed"
+ dodoc README NEWS ChangeLog TODO
+}
+
+pkg_postinst() {
+ if ! use berkdb; then
+ ewarn "To become a search node, you must have berkdb set"
+ ewarn "in your USE flags."
+ echo
+ fi
+ einfo "Before you can use the new plugin,"
+ einfo "you should counfigure it with gift-setup command."
+ echo
+ einfo "To run giFT with OpenFT support, run:"
+ einfo "\tgiFT -p /usr/lib/giFT/libOpenFT.so"
+ echo
+ einfo "Alternatively you can add the following line to"
+ einfo "your ~/.giFT/giftd.conf configuration file:"
+ einfo "plugins = OpenFT"
+}