summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-11-22 22:06:48 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-11-22 22:06:48 +0000
commitc6d4610d29b925c3b664d04b1221f623db17900c (patch)
tree7f5b3e1e0e7a26ce4fe0199def5dc89364ec826d /net-p2p
parentVersion bump. (Jakub Moc) (diff)
downloadgentoo-2-c6d4610d29b925c3b664d04b1221f623db17900c.tar.gz
gentoo-2-c6d4610d29b925c3b664d04b1221f623db17900c.tar.bz2
gentoo-2-c6d4610d29b925c3b664d04b1221f623db17900c.zip
version bump from upstream, drop wxwindows useflag for now
(Portage version: 2.1.3.16)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission/ChangeLog8
-rw-r--r--net-p2p/transmission/files/digest-transmission-0.933
-rw-r--r--net-p2p/transmission/transmission-0.93.ebuild34
3 files changed, 44 insertions, 1 deletions
diff --git a/net-p2p/transmission/ChangeLog b/net-p2p/transmission/ChangeLog
index 64e741c1d195..596ec3352ec9 100644
--- a/net-p2p/transmission/ChangeLog
+++ b/net-p2p/transmission/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/transmission
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.39 2007/11/10 03:53:32 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.40 2007/11/22 22:06:48 compnerd Exp $
+
+*transmission-0.93 (22 Nov 2007)
+
+ 22 Nov 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+ +transmission-0.93.ebuild:
+ Version bump from upstream; drop wxwindows useflag for now
10 Nov 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+files/transmission-0.91-potfiles-fix.patch, transmission-0.91.ebuild:
diff --git a/net-p2p/transmission/files/digest-transmission-0.93 b/net-p2p/transmission/files/digest-transmission-0.93
new file mode 100644
index 000000000000..cfe906839717
--- /dev/null
+++ b/net-p2p/transmission/files/digest-transmission-0.93
@@ -0,0 +1,3 @@
+MD5 8601d25693693ded97fb427428b75fb4 transmission-0.93.tar.bz2 2689601
+RMD160 7341ddca78ea215c14d8be1a3086f2a421dbeece transmission-0.93.tar.bz2 2689601
+SHA256 b611e494501771fc146fc072eaa683adc42e3d7540a082ea3dbe2c48a993fc5d transmission-0.93.tar.bz2 2689601
diff --git a/net-p2p/transmission/transmission-0.93.ebuild b/net-p2p/transmission/transmission-0.93.ebuild
new file mode 100644
index 000000000000..b8be0c5198cb
--- /dev/null
+++ b/net-p2p/transmission/transmission-0.93.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-0.93.ebuild,v 1.1 2007/11/22 22:06:48 compnerd Exp $
+
+inherit autotools
+
+DESCRIPTION="Simple BitTorrent client"
+HOMEPAGE="http://transmission.m0k.org/"
+SRC_URI="http://download.m0k.org/transmission/files/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gtk" # wxwindows"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=dev-libs/openssl-0.9.8
+ gtk? ( >=x11-libs/gtk+-2.6 )"
+# wxwindows? ( =x11-libs/wxGTK-2.6* )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.19
+ gtk? ( >=dev-util/intltool-0.35 )"
+
+src_compile() {
+ econf $(use_with gtk) || die "configure failed"
+ # $(use_with wxwindows wx) || die "configure failed"
+ emake || die "build failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS
+}