summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2008-05-13 02:54:28 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2008-05-13 02:54:28 +0000
commitd0955463aefff2dffb18676f87d1b1eda286836a (patch)
tree4b7f60eba4abbf1c91ad68081c8a7e3bf666f11b /net-p2p
parentStable for HPPA (bug #221063). (diff)
downloadgentoo-2-d0955463aefff2dffb18676f87d1b1eda286836a.tar.gz
gentoo-2-d0955463aefff2dffb18676f87d1b1eda286836a.tar.bz2
gentoo-2-d0955463aefff2dffb18676f87d1b1eda286836a.zip
version bump from upstream
(Portage version: 2.1.5_rc9)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission/ChangeLog8
-rw-r--r--net-p2p/transmission/files/transmission-daemon23
-rw-r--r--net-p2p/transmission/transmission-1.20.ebuild35
3 files changed, 65 insertions, 1 deletions
diff --git a/net-p2p/transmission/ChangeLog b/net-p2p/transmission/ChangeLog
index 4e5a62959fde..02bfd251382e 100644
--- a/net-p2p/transmission/ChangeLog
+++ b/net-p2p/transmission/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/transmission
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.61 2008/05/04 19:15:54 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.62 2008/05/13 02:54:27 compnerd Exp $
+
+*transmission-1.20 (13 May 2008)
+
+ 13 May 2008; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/transmission-daemon, +transmission-1.20.ebuild:
+ Version bump from usptream (fixes bugs #218586, #221859)
04 May 2008; Saleem Abdulrasool <compnerd@gentoo.org>
-transmission-0.82.ebuild, -transmission-1.0.4.ebuild,
diff --git a/net-p2p/transmission/files/transmission-daemon b/net-p2p/transmission/files/transmission-daemon
new file mode 100644
index 000000000000..eb7dbc02037f
--- /dev/null
+++ b/net-p2p/transmission/files/transmission-daemon
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/files/transmission-daemon,v 1.1 2008/05/13 02:54:28 compnerd Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting transmission-daemon"
+ start-stop-daemon --start --quiet --pidfile /var/run/transmission-daemon.pid \
+ --exec /usr/bin/transmission-daemon -- --pidfile /var/run/transmission-daemon.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping transmission-daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/transmission-daemon
+ eend $?
+}
+
+# vim: set ft=gentoo-init-d ts=3 sw=3 et:
diff --git a/net-p2p/transmission/transmission-1.20.ebuild b/net-p2p/transmission/transmission-1.20.ebuild
new file mode 100644
index 000000000000..7a73934a853e
--- /dev/null
+++ b/net-p2p/transmission/transmission-1.20.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-1.20.ebuild,v 1.1 2008/05/13 02:54:27 compnerd Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="Simple BitTorrent client"
+HOMEPAGE="http://www.transmissionbt.com/"
+SRC_URI="http://download.transmissionbt.com/transmission/files/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gtk libnotify"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=dev-libs/openssl-0.9.8
+ gtk? ( >=x11-libs/gtk+-2.6 )
+ libnotify? ( >=x11-libs/libnotify-0.4.4 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.19
+ gtk? ( >=dev-util/intltool-0.35 )"
+
+src_compile() {
+ econf $(use_with gtk) $(use_enable libnotify) --with-wx-config=no || die "configure failed"
+ emake || die "build failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS
+
+ doinitd "${FILESDIR}/transmission-daemon"
+}