summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-09-13 17:56:04 +0000
committerThomas Sachau <tommy@gentoo.org>2010-09-13 17:56:04 +0000
commitd51777820827e683b175c4357516e2542a0950ae (patch)
tree2bb7e644e835ba4c045cb7a553e94fe494a4f7f6 /net-p2p
parentRevbump to respect LDFLAGS. Reported by Diego E. Pettenò <flameeyes@gentoo.o... (diff)
downloadgentoo-2-d51777820827e683b175c4357516e2542a0950ae.tar.gz
gentoo-2-d51777820827e683b175c4357516e2542a0950ae.tar.bz2
gentoo-2-d51777820827e683b175c4357516e2542a0950ae.zip
Version bump
(Portage version: 2.2_rc81-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/fms/ChangeLog8
-rw-r--r--net-p2p/fms/files/quoter.h.patch11
-rw-r--r--net-p2p/fms/fms-0.3.56.ebuild73
3 files changed, 91 insertions, 1 deletions
diff --git a/net-p2p/fms/ChangeLog b/net-p2p/fms/ChangeLog
index 650cd2353180..6e37921b2f58 100644
--- a/net-p2p/fms/ChangeLog
+++ b/net-p2p/fms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/fms
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/ChangeLog,v 1.19 2010/07/17 01:18:59 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/ChangeLog,v 1.20 2010/09/13 17:56:04 tommy Exp $
+
+*fms-0.3.56 (13 Sep 2010)
+
+ 13 Sep 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +fms-0.3.56.ebuild, +files/quoter.h.patch:
+ Version bump
*fms-0.3.54 (17 Jul 2010)
diff --git a/net-p2p/fms/files/quoter.h.patch b/net-p2p/fms/files/quoter.h.patch
new file mode 100644
index 000000000000..18b12be0a4a9
--- /dev/null
+++ b/net-p2p/fms/files/quoter.h.patch
@@ -0,0 +1,11 @@
+--- include/quoter.h 2010-08-22 13:04:34.000000000 +0200
++++ include/quoter.h.new 2010-09-03 18:16:37.169391363 +0200
+@@ -4,7 +4,7 @@
+ #include <vector>
+ #include <string>
+
+-#include "../../../include/keyfinder.h"
++#include "keyfinder.h"
+
+ class QuoterVisitor;
+
diff --git a/net-p2p/fms/fms-0.3.56.ebuild b/net-p2p/fms/fms-0.3.56.ebuild
new file mode 100644
index 000000000000..aa3506a80572
--- /dev/null
+++ b/net-p2p/fms/fms-0.3.56.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/fms-0.3.56.ebuild,v 1.1 2010/09/13 17:56:04 tommy Exp $
+
+EAPI="2"
+
+inherit eutils cmake-utils
+
+DESCRIPTION="A spam-resistant message board application for Freenet"
+HOMEPAGE="http://freenetproject.org/tools.html"
+SRC_URI="mirror://gentoo/${PN}-src-${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="frost"
+
+DEPEND="virtual/libiconv
+ frost? ( >=dev-libs/libtomcrypt-1.17-r3[libtommath] )
+ >=dev-libs/poco-1.2.9
+ || ( >=dev-db/sqlite-3.6.15 =dev-db/sqlite-3.6.13* =dev-db/sqlite-3.6.12* =dev-db/sqlite-3.6.11* =dev-db/sqlite-3.6.6.2* )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ enewgroup freenet
+ enewuser freenet -1 -1 /var/freenet freenet
+}
+
+src_prepare() {
+ edos2unix src/http/pages/showfilepage.cpp
+ epatch "${FILESDIR}"/${PN}-use-system-libs.patch
+ epatch "${FILESDIR}"/quoter.h.patch
+ sed -i "s:LTC_PKCS:LTC_LTC_PKCS:g" src/freenet/frostidentity.cpp
+}
+
+src_configure() {
+ local mycmakeargs="-DI_HAVE_READ_THE_README=ON \
+ -DUSE_BUNDLED_SQLITE=OFF \
+ -DDO_CHARSET_CONVERSION=ON \
+ $(cmake-utils_use frost FROST_SUPPORT)"
+ use frost && append-flags -DLTM_DESC
+ cmake-utils_src_configure
+}
+
+src_install() {
+ insinto /var/freenet/fms
+ dobin "${CMAKE_BUILD_DIR}"/fms || die
+ doins *.htm || die "doinstall failed"
+ doins -r fonts images styles translations || die
+ fperms -R o-rwx /var/freenet/fms/ /usr/bin/fms
+ fowners -R freenet:freenet /var/freenet/fms/ /usr/bin/fms
+ doinitd "${FILESDIR}/fms" || die "installing init.d file failed"
+ dodoc readme.txt || die "installing doc failed"
+}
+
+pkg_postinst() {
+ if ! has_version 'net-p2p/freenet' ; then
+ ewarn "FMS needs a freenet node to up-/download #ssages."
+ ewarn "Please make sure to have a node you can connect to"
+ ewarn "or install net-p2p/freenet to get FMS working."
+ fi
+ elog "By default, the FMS NNTP server will listen on port 1119,"
+ elog "and the web configuration interface will be running at"
+ elog "http://localhost:8080. For more information, read"
+ elog "${ROOT}usr/share/doc/${PF}/readme.txt.bz2"
+ if use frost; then
+ elog " "
+ elog "You need to enable frost on the config page"
+ elog "and restart fms for frost support."
+ fi
+}