summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-09-08 14:36:52 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-09-08 14:36:52 +0000
commitf5aa2c863ea00b63613cce2cf939a75f9a3143ec (patch)
tree5e1c8082096871bf34e009e3cf8a5f08dedc3075 /net-p2p
parentfix #84887, #111507, #122877, #126725, #138321, #151576, #168256, #174442, #1... (diff)
downloadgentoo-2-f5aa2c863ea00b63613cce2cf939a75f9a3143ec.tar.gz
gentoo-2-f5aa2c863ea00b63613cce2cf939a75f9a3143ec.tar.bz2
gentoo-2-f5aa2c863ea00b63613cce2cf939a75f9a3143ec.zip
Version bump wrt bug #182816.
(Portage version: 2.1.3.7)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/ChangeLog7
-rw-r--r--net-p2p/rtorrent/files/digest-rtorrent-0.7.83
-rw-r--r--net-p2p/rtorrent/rtorrent-0.7.8.ebuild48
3 files changed, 57 insertions, 1 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 79cdadb48ed1..962ed4442e80 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.91 2007/05/24 15:47:04 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.92 2007/09/08 14:36:52 drizzt Exp $
+
+*rtorrent-0.7.8 (08 Sep 2007)
+
+ 08 Sep 2007; Timothy Redaelli <drizzt@gentoo.org> +rtorrent-0.7.8.ebuild:
+ Version bump wrt bug #182816.
24 May 2007; Timothy Redaelli <drizzt@gentoo.org> rtorrent-0.7.4.ebuild:
append-flags -fno-strict-aliasing wrt bug #179554
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.7.8 b/net-p2p/rtorrent/files/digest-rtorrent-0.7.8
new file mode 100644
index 000000000000..cfc85574d1b2
--- /dev/null
+++ b/net-p2p/rtorrent/files/digest-rtorrent-0.7.8
@@ -0,0 +1,3 @@
+MD5 50886a98fa2ae16ae33367ef61772e1e rtorrent-0.7.8.tar.gz 489952
+RMD160 77f9b1627a65804d54f204919c7b2d58c95d751b rtorrent-0.7.8.tar.gz 489952
+SHA256 93c0291ac06cafd2466e7c0c1ce918544e49b15effc1d55b1e8a903e3d0f1d8c rtorrent-0.7.8.tar.gz 489952
diff --git a/net-p2p/rtorrent/rtorrent-0.7.8.ebuild b/net-p2p/rtorrent/rtorrent-0.7.8.ebuild
new file mode 100644
index 000000000000..571f1577544b
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.7.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.7.8.ebuild,v 1.1 2007/09/08 14:36:52 drizzt Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=net-libs/libtorrent-0.11.${PV##*.}
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.15
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ replace-flags -Os -O2
+ append-flags -fno-strict-aliasing
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+ fi
+
+ econf \
+ $(use_enable debug) \
+ --disable-xmlrpc-c \ # I want to keep it disabled while >=dev-libs/xmlrpc-c-1.07 is masked
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ elog "rtorrent now supports a configuration file."
+ elog "A sample configuration file for rtorrent is can be found"
+ elog "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}