summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-09-10 13:55:14 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-09-10 13:55:14 +0000
commitc8dc85b650ea47dfe4dd729cded55878c51b7cdd (patch)
tree52996c628911ddbe68597488b07100412ce6ade7 /net-print/cups-filters
parentVersion bump to latest. Stable older. Remove oldest. (diff)
downloadgentoo-2-c8dc85b650ea47dfe4dd729cded55878c51b7cdd.tar.gz
gentoo-2-c8dc85b650ea47dfe4dd729cded55878c51b7cdd.tar.bz2
gentoo-2-c8dc85b650ea47dfe4dd729cded55878c51b7cdd.zip
Version bump to latest. Drop unused patches.
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'net-print/cups-filters')
-rw-r--r--net-print/cups-filters/ChangeLog10
-rw-r--r--net-print/cups-filters/cups-filters-1.0.24.ebuild86
-rw-r--r--net-print/cups-filters/files/cups-filters-1.0.11-makefiles.patch184
-rw-r--r--net-print/cups-filters/files/cups-filters-1.0.19-libdl.patch34
-rw-r--r--net-print/cups-filters/files/cups-filters-1.0.19-poppler020.patch192
5 files changed, 95 insertions, 411 deletions
diff --git a/net-print/cups-filters/ChangeLog b/net-print/cups-filters/ChangeLog
index 4c5b52d5b1d3..0720ef73cbf9 100644
--- a/net-print/cups-filters/ChangeLog
+++ b/net-print/cups-filters/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-print/cups-filters
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/ChangeLog,v 1.38 2012/09/01 17:41:16 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/ChangeLog,v 1.39 2012/09/10 13:55:13 scarabeus Exp $
+
+*cups-filters-1.0.24 (10 Sep 2012)
+
+ 10 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org> +cups-filters-1.0.24.ebuild,
+ -files/cups-filters-1.0.11-makefiles.patch,
+ -files/cups-filters-1.0.19-libdl.patch,
+ -files/cups-filters-1.0.19-poppler020.patch:
+ Version bump to latest. Drop unused patches.
01 Sep 2012; Anthony G. Basile <blueness@gentoo.org>
cups-filters-1.0.23-r1.ebuild, cups-filters-9999.ebuild:
diff --git a/net-print/cups-filters/cups-filters-1.0.24.ebuild b/net-print/cups-filters/cups-filters-1.0.24.ebuild
new file mode 100644
index 000000000000..2a5d45a51c8a
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-1.0.24.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-filters/cups-filters-1.0.24.ebuild,v 1.1 2012/09/10 13:55:13 scarabeus Exp $
+
+EAPI=4
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit base perl-module
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit autotools bzr
+ EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
+ KEYWORDS=""
+else
+ SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86"
+fi
+DESCRIPTION="Cups PDF filters"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdfasstandardprintjobformat"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="jpeg perl png static-libs tiff"
+
+RDEPEND="
+ app-text/ghostscript-gpl
+ app-text/poppler[cxx,jpeg?,lcms,tiff?,xpdf-headers(+)]
+ app-text/qpdf
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/lcms:2
+ >net-print/cups-1.5.9999
+ !<=net-print/cups-1.5.9999
+ sys-devel/bc
+ sys-libs/zlib
+ jpeg? ( virtual/jpeg )
+ perl? ( dev-lang/perl )
+ png? ( media-libs/libpng )
+ tiff? ( media-libs/tiff )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ base_src_prepare
+ if [[ "${PV}" == "9999" ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --with-fontdir="fonts/conf.avail" \
+ --with-pdftops=pdftops \
+ --enable-imagefilters \
+ $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with tiff) \
+ --without-php \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_compile() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_prep
+ perl-module_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_install
+ fixlocalpod
+ popd > /dev/null
+ fi
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/net-print/cups-filters/files/cups-filters-1.0.11-makefiles.patch b/net-print/cups-filters/files/cups-filters-1.0.11-makefiles.patch
deleted file mode 100644
index 2c9c8bc32e58..000000000000
--- a/net-print/cups-filters/files/cups-filters-1.0.11-makefiles.patch
+++ /dev/null
@@ -1,184 +0,0 @@
-diff -urN cups-filters-1.0.11.old/backend/Makefile cups-filters-1.0.11/backend/Makefile
---- cups-filters-1.0.11.old/backend/Makefile 2012-04-03 17:40:50.326979137 +0200
-+++ cups-filters-1.0.11/backend/Makefile 2012-04-03 17:43:59.027982425 +0200
-@@ -74,9 +74,9 @@
-
- install-exec:
- echo Installing backends in $(SERVERBIN)/backend...
-- $(INSTALL_DIR) -m 755 $(SERVERBIN)/backend
-+ $(INSTALL_DIR) -m 755 $(DESTDIR)/$(SERVERBIN)/backend
- for file in $(BACKENDS); do \
-- $(INSTALL_BIN) $$file $(SERVERBIN)/backend; \
-+ $(INSTALL_BIN) $$file $(DESTDIR)/$(SERVERBIN)/backend; \
- done
-
-
-diff -urN cups-filters-1.0.11.old/config-scripts/cups-compiler.m4 cups-filters-1.0.11/config-scripts/cups-compiler.m4
---- cups-filters-1.0.11.old/config-scripts/cups-compiler.m4 2012-04-03 17:40:50.332979138 +0200
-+++ cups-filters-1.0.11/config-scripts/cups-compiler.m4 2012-04-03 17:41:23.281979712 +0200
-@@ -23,13 +23,6 @@
- AC_ARG_WITH(optim, [ --with-optim set optimization flags ])
- AC_ARG_ENABLE(debug, [ --enable-debug build with debugging symbols])
-
--dnl For debugging, keep symbols, otherwise strip them...
--if test x$enable_debug = xyes; then
-- OPTIM="-g"
--else
-- INSTALL_STRIP="-s"
--fi
--
- dnl Read-only data/program support on Linux...
- AC_ARG_ENABLE(relro, [ --enable-relro build with the GCC relro option])
-
-diff -urN cups-filters-1.0.11.old/cupsfilters/Makefile cups-filters-1.0.11/cupsfilters/Makefile
---- cups-filters-1.0.11.old/cupsfilters/Makefile 2012-04-03 17:40:50.330979139 +0200
-+++ cups-filters-1.0.11/cupsfilters/Makefile 2012-04-03 17:57:26.362996484 +0200
-@@ -120,9 +120,9 @@
-
- install-headers:
- echo Installing header files into $(INCLUDEDIR)/cupsfilters...
-- $(INSTALL_DIR) -m 755 $(INCLUDEDIR)/cupsfilters
-+ $(INSTALL_DIR) -m 755 $(DESTDIR)/$(INCLUDEDIR)/cupsfilters
- for file in $(HEADERS); do \
-- $(INSTALL_DATA) $$file $(INCLUDEDIR)/cupsfilters; \
-+ $(INSTALL_DATA) $$file $(DESTDIR)/$(INCLUDEDIR)/cupsfilters; \
- done
-
-
-@@ -132,16 +132,16 @@
-
- install-libs:
- echo Installing libraries in $(LIBDIR)...
-- $(INSTALL_DIR) -m 755 $(LIBDIR)
-- $(INSTALL_LIB) $(LIBCUPSFILTERS) $(LIBDIR)
-- $(INSTALL_DATA) libcupsfilters.a $(LIBDIR)
-+ $(INSTALL_DIR) -m 755 $(DESTDIR)/$(LIBDIR)
-+ $(INSTALL_LIB) $(LIBCUPSFILTERS) $(DESTDIR)/$(LIBDIR)
-+ $(INSTALL_DATA) libcupsfilters.a $(DESTDIR)/$(LIBDIR)
- if test $(LIBCUPSFILTERS) = "libcupsfilters.so.1" -o $(LIBCUPSFILTERS) = "libcupsfilters.sl.1"; then \
-- $(RM) $(LIBDIR)/`basename $(LIBCUPSFILTERS) .1`; \
-- $(LN) $(LIBCUPSFILTERS) $(LIBDIR)/`basename $(LIBCUPSFILTERS) .1`; \
-+ $(RM) $(DESTDIR)/$(LIBDIR)/`basename $(LIBCUPSFILTERS) .1`; \
-+ $(LN) $(LIBCUPSFILTERS) $(DESTDIR)/$(LIBDIR)/`basename $(LIBCUPSFILTERS) .1`; \
- fi
- if test $(LIBCUPSFILTERS) = "libcupsfilters.1.dylib"; then \
-- $(RM) $(LIBDIR)/libcups.dylib; \
-- $(LN) $(LIBCUPSFILTERS) $(LIBDIR)/libcups.dylib; \
-+ $(RM) $(DESTDIR)/$(LIBDIR)/libcups.dylib; \
-+ $(LN) $(LIBCUPSFILTERS) $(DESTDIR)/$(LIBDIR)/libcups.dylib; \
- fi
-
-
-@@ -171,7 +171,7 @@
-
- libcupsfilters.so.1: $(LIBOBJS)
- echo Linking $@...
-- $(DSO) $(ARCHFLAGS) $(DSOFLAGS) -o $@ $(LIBOBJS) $(DSOLIBS) $(LINKCUPS) -lm
-+ $(DSO) $(LDFLAGS) $(ARCHFLAGS) $(DSOFLAGS) -o $@ $(LIBOBJS) $(DSOLIBS) $(LINKCUPS) -lm
- $(RM) `basename $@ .1`
- $(LN) $@ `basename $@ .1`
-
-diff -urN cups-filters-1.0.11.old/filter/Makefile cups-filters-1.0.11/filter/Makefile
---- cups-filters-1.0.11.old/filter/Makefile 2012-04-03 17:40:50.324979137 +0200
-+++ cups-filters-1.0.11/filter/Makefile 2012-04-03 17:53:35.708992459 +0200
-@@ -130,35 +130,35 @@
-
- install-data:
- echo Installing charsets to $(DATADIR)/charsets...
-- $(INSTALL_DIR) -m 755 $(DATADIR)/charsets
-+ $(INSTALL_DIR) -m 755 $(DESTDIR)/$(DATADIR)/charsets
- for file in $(CHARSETS); do \
-- $(INSTALL_DATA) $$file $(DATADIR)/charsets; \
-+ $(INSTALL_DATA) $$file $(DESTDIR)/$(DATADIR)/charsets; \
- done; \
-- $(LN) pdf.utf-8.simple $(DATADIR)/charsets/pdf.utf-8
-+ $(LN) pdf.utf-8.simple $(DESTDIR)/$(DATADIR)/charsets/pdf.utf-8
- echo Installing data files to $(DATADIR)/data...
-- $(INSTALL_DIR) -m 755 $(DATADIR)/data
-+ $(INSTALL_DIR) -m 755 $(DESTDIR)/$(DATADIR)/data
- for file in $(DATAFILES); do \
-- $(INSTALL_DATA) $$file $(DATADIR)/data; \
-+ $(INSTALL_DATA) $$file $(DESTDIR)/$(DATADIR)/data; \
- done
- echo Installing banners to $(DATADIR)/banners...
-- $(INSTALL_DIR) -m 755 $(DATADIR)/banners
-+ $(INSTALL_DIR) -m 755 $(DESTDIR)/$(DATADIR)/banners
- for file in $(BANNERS); do \
-- $(INSTALL_DATA) $$file $(DATADIR)/banners; \
-+ $(INSTALL_DATA) $$file $(DESTDIR)/$(DATADIR)/banners; \
- done
- echo Installing MIME files to $(DATADIR)/mime...
-- $(INSTALL_DIR) -m 755 $(DATADIR)/mime
-+ $(INSTALL_DIR) -m 755 $(DESTDIR)/$(DATADIR)/mime
- for file in $(MIMEFILES); do \
-- $(INSTALL_DATA) $$file $(DATADIR)/mime; \
-+ $(INSTALL_DATA) $$file $(DESTDIR)/$(DATADIR)/mime; \
- done
- echo Installing DRV files to $(DATADIR)/drv...
-- $(INSTALL_DIR) -m 755 $(DATADIR)/drv
-+ $(INSTALL_DIR) -m 755 $(DESTDIR)/$(DATADIR)/drv
- for file in $(DRVFILES); do \
-- $(INSTALL_DATA) $$file $(DATADIR)/drv; \
-+ $(INSTALL_DATA) $$file $(DESTDIR)/$(DATADIR)/drv; \
- done
-- echo Installing PPD files to $(BUILDROOT)${datadir}/ppd/cupsfilters...
-- $(INSTALL_DIR) -m 755 $(BUILDROOT)${datadir}/ppd/cupsfilters
-+ echo Installing PPD files to $(DATADIR)/ppd/cupsfilters...
-+ $(INSTALL_DIR) -m 755 $(DESTDIR)$(DATADIR)/ppd/cupsfilters
- for file in $(PPDFILES); do \
-- $(INSTALL_DATA) $$file $(BUILDROOT)${datadir}/ppd/cupsfilters; \
-+ $(INSTALL_DATA) $$file $(DESTDIR)$(DATADIR)/ppd/cupsfilters; \
- done
-
-
-@@ -168,12 +168,12 @@
-
- install-exec:
- echo Installing filters to $(SERVERBIN)/filter...
-- $(INSTALL_DIR) -m 755 $(SERVERBIN)/filter
-+ $(INSTALL_DIR) -m 755 $(DESTDIR)/$(SERVERBIN)/filter
- for file in $(TARGETS); do \
-- $(INSTALL_BIN) $$file $(SERVERBIN)/filter; \
-+ $(INSTALL_BIN) $$file $(DESTDIR)/$(SERVERBIN)/filter; \
- done
- for file in $(SCRIPTS); do \
-- $(INSTALL_SCRIPT) $$file $(SERVERBIN)/filter; \
-+ $(INSTALL_SCRIPT) $$file $(DESTDIR)/$(SERVERBIN)/filter; \
- done
-
-
-diff -urN cups-filters-1.0.11.old/pdftoopvp/Makefile cups-filters-1.0.11/pdftoopvp/Makefile
---- cups-filters-1.0.11.old/pdftoopvp/Makefile 2012-04-03 17:40:50.331979139 +0200
-+++ cups-filters-1.0.11/pdftoopvp/Makefile 2012-04-03 17:54:47.771993722 +0200
-@@ -60,13 +60,13 @@
-
- install-data: all
- echo Installing configuration files to $(sysconfdir)/fonts/conf.d...
-- $(INSTALL_DIR) -m 755 $(BUILDROOT)$(sysconfdir)/fonts/conf.d
-- $(INSTALL_DATA) -m 644 99pdftoopvp.conf $(BUILDROOT)$(sysconfdir)/fonts/conf.d
-+ $(INSTALL_DIR) -m 755 $(DESTDIR)$(sysconfdir)/fonts/conf.d
-+ $(INSTALL_DATA) -m 644 99pdftoopvp.conf $(DESTDIR)$(sysconfdir)/fonts/conf.d
-
- install-exec: all
- echo Installing filters to $(SERVERBIN)/filter...
-- $(INSTALL_DIR) -m 755 $(SERVERBIN)/filter
-- $(INSTALL_BIN) pdftoopvp $(SERVERBIN)/filter
-+ $(INSTALL_DIR) -m 755 $(DESTDIR)/$(SERVERBIN)/filter
-+ $(INSTALL_BIN) pdftoopvp $(DESTDIR)/$(SERVERBIN)/filter
-
- install-headers:
-
-diff -urN cups-filters-1.0.11.old/pdftopdf/Makefile cups-filters-1.0.11/pdftopdf/Makefile
---- cups-filters-1.0.11.old/pdftopdf/Makefile 2012-04-03 17:40:50.328979140 +0200
-+++ cups-filters-1.0.11/pdftopdf/Makefile 2012-04-03 17:44:39.759983134 +0200
-@@ -78,8 +78,8 @@
-
- install-exec: all
- echo Installing filters in $(SERVERBIN)/filter...
-- $(INSTALL_DIR) -m 755 $(SERVERBIN)/filter
-- $(INSTALL_BIN) pdftopdf $(SERVERBIN)/filter
-+ $(INSTALL_DIR) -m 755 $(DESTDIR)/$(SERVERBIN)/filter
-+ $(INSTALL_BIN) pdftopdf $(DESTDIR)/$(SERVERBIN)/filter
-
- install-headers:
-
diff --git a/net-print/cups-filters/files/cups-filters-1.0.19-libdl.patch b/net-print/cups-filters/files/cups-filters-1.0.19-libdl.patch
deleted file mode 100644
index ad5852ca1c0b..000000000000
--- a/net-print/cups-filters/files/cups-filters-1.0.19-libdl.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-diff -ruN cups-filters-1.0.19.vanilla/Makefile.am cups-filters-1.0.19.orig/Makefile.am
---- cups-filters-1.0.19.vanilla/Makefile.am 2012-06-22 18:11:48.000000000 +0200
-+++ cups-filters-1.0.19.orig/Makefile.am 2012-07-27 20:21:06.630910203 +0200
-@@ -329,7 +329,8 @@
- $(FREETYPE_LIBS) \
- $(FONTCONFIG_LIBS) \
- $(LIBPNG_LIBS) \
-- $(POPPLER_LIBS)
-+ $(POPPLER_LIBS) \
-+ $(LIBDL_LIBS)
-
- EXTRA_DIST += $(pkgfontconfig_DATA)
- # ==========
-diff -ruN cups-filters-1.0.19.vanilla/configure.ac cups-filters-1.0.19.orig/configure.ac
---- cups-filters-1.0.19.vanilla/configure.ac 2012-07-27 20:06:16.697927916 +0200
-+++ cups-filters-1.0.19.orig/configure.ac 2012-07-27 20:20:38.368910216 +0200
-@@ -127,6 +127,17 @@
- AC_CHECK_HEADERS([unistd.h])
- AC_CHECK_HEADERS([zlib.h])
-
-+
-+# ========================
-+# Check for libdl
-+# ========================
-+AC_CHECK_LIB(dl,dlopen)
-+if test x$ac_cv_lib_dl_dlopen != xno; then
-+ LIBDL_LIBS=" -ldl"
-+else
-+ LIBDL_LIBS=""
-+fi
-+
- # =============
- # Image options
- # =============
diff --git a/net-print/cups-filters/files/cups-filters-1.0.19-poppler020.patch b/net-print/cups-filters/files/cups-filters-1.0.19-poppler020.patch
deleted file mode 100644
index 4b6cea901559..000000000000
--- a/net-print/cups-filters/files/cups-filters-1.0.19-poppler020.patch
+++ /dev/null
@@ -1,192 +0,0 @@
-diff -ruN cups-filters-9999.orig/configure.ac cups-filters-9999/configure.ac
---- cups-filters-9999.orig/configure.ac 2012-07-19 00:25:53.311589000 +0200
-+++ cups-filters-9999/configure.ac 2012-07-19 00:25:02.000000000 +0200
-@@ -202,6 +202,7 @@
- # ================
- POPPLER_INCLUDEDIR=`pkg-config poppler --variable includedir`
- AC_CHECK_HEADER([UGooString.h], [AC_DEFINE([HAVE_UGOOSTRING_H],,[Have UGooString.h])], [])
-+AC_CHECK_HEADER([poppler/cpp/poppler-version.h], [AC_DEFINE([HAVE_CPP_POPPLER_VERSION_H],,[Define if you have Poppler's "cpp/poppler-version.h" header file.])], [])
- # FIXME:
- # Use proper c compile check not greps and then just link again poppler with all the features
- # instead of this and all the libs.
-diff -ruN cups-filters-9999.orig/filter/PDFError.h cups-filters-9999/filter/PDFError.h
---- cups-filters-9999.orig/filter/PDFError.h 2012-07-19 00:25:53.311589000 +0200
-+++ cups-filters-9999/filter/PDFError.h 2012-07-19 00:23:58.000000000 +0200
-@@ -31,6 +31,9 @@
- #include <config.h>
- #include <stdarg.h>
- #include <Error.h>
-+#ifdef HAVE_CPP_POPPLER_VERSION_H
-+#include "cpp/poppler-version.h"
-+#endif
-
- #if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 19
- #define pdfError(pos,...) error(errInternal,pos,__VA_ARGS__)
-diff -ruN cups-filters-9999.orig/filter/pdftoijs.cxx cups-filters-9999/filter/pdftoijs.cxx
---- cups-filters-9999.orig/filter/pdftoijs.cxx 2012-07-19 00:25:53.311589000 +0200
-+++ cups-filters-9999/filter/pdftoijs.cxx 2012-07-19 00:23:58.000000000 +0200
-@@ -30,6 +30,9 @@
- #include <config.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#ifdef HAVE_CPP_POPPLER_VERSION_H
-+#include "cpp/poppler-version.h"
-+#endif
- #include <goo/GooString.h>
- #include <goo/gmem.h>
- #include <Object.h>
-diff -ruN cups-filters-9999.orig/filter/pdftoopvp/OPVPError.h cups-filters-9999/filter/pdftoopvp/OPVPError.h
---- cups-filters-9999.orig/filter/pdftoopvp/OPVPError.h 2012-07-19 00:25:53.311589000 +0200
-+++ cups-filters-9999/filter/pdftoopvp/OPVPError.h 2012-07-19 00:23:58.000000000 +0200
-@@ -31,6 +31,9 @@
- #include <config.h>
- #include <stdarg.h>
- #include <Error.h>
-+#ifdef HAVE_CPP_POPPLER_VERSION_H
-+#include "cpp/poppler-version.h"
-+#endif
-
- #if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 19
- #define opvpError(pos,...) error(errInternal,pos,__VA_ARGS__)
-diff -ruN cups-filters-9999.orig/filter/pdftoopvp/OPVPOutputDev.cxx cups-filters-9999/filter/pdftoopvp/OPVPOutputDev.cxx
---- cups-filters-9999.orig/filter/pdftoopvp/OPVPOutputDev.cxx 2012-07-19 00:25:53.311589000 +0200
-+++ cups-filters-9999/filter/pdftoopvp/OPVPOutputDev.cxx 2012-07-19 00:23:58.000000000 +0200
-@@ -8,6 +8,9 @@
- //========================================================================
-
- #include <config.h>
-+#ifdef HAVE_CPP_POPPLER_VERSION_H
-+#include "cpp/poppler-version.h"
-+#endif
-
- #ifdef USE_GCC_PRAGMAS
- #pragma implementation
-diff -ruN cups-filters-9999.orig/filter/pdftoopvp/oprs/OPVPSplash.cxx cups-filters-9999/filter/pdftoopvp/oprs/OPVPSplash.cxx
---- cups-filters-9999.orig/filter/pdftoopvp/oprs/OPVPSplash.cxx 2012-07-19 00:25:53.311589000 +0200
-+++ cups-filters-9999/filter/pdftoopvp/oprs/OPVPSplash.cxx 2012-07-19 00:23:58.000000000 +0200
-@@ -5,6 +5,9 @@
- //========================================================================
-
- #include <config.h>
-+#ifdef HAVE_CPP_POPPLER_VERSION_H
-+#include "cpp/poppler-version.h"
-+#endif
-
- #ifdef USE_GCC_PRAGMAS
- #pragma implementation
-diff -ruN cups-filters-9999.orig/filter/pdftoopvp/oprs/OPVPSplashState.cxx cups-filters-9999/filter/pdftoopvp/oprs/OPVPSplashState.cxx
---- cups-filters-9999.orig/filter/pdftoopvp/oprs/OPVPSplashState.cxx 2012-07-19 00:25:53.311589000 +0200
-+++ cups-filters-9999/filter/pdftoopvp/oprs/OPVPSplashState.cxx 2012-07-19 00:23:58.000000000 +0200
-@@ -11,6 +11,9 @@
- #endif
-
- #include <string.h>
-+#ifdef HAVE_CPP_POPPLER_VERSION_H
-+#include "cpp/poppler-version.h"
-+#endif
- #include "goo/gmem.h"
- #include "splash/SplashPattern.h"
- #include "splash/SplashScreen.h"
-diff -ruN cups-filters-9999.orig/filter/pdftoopvp/oprs/OPVPSplashState.h cups-filters-9999/filter/pdftoopvp/oprs/OPVPSplashState.h
---- cups-filters-9999.orig/filter/pdftoopvp/oprs/OPVPSplashState.h 2012-07-19 00:25:53.311589000 +0200
-+++ cups-filters-9999/filter/pdftoopvp/oprs/OPVPSplashState.h 2012-07-19 00:23:58.000000000 +0200
-@@ -11,6 +11,9 @@
- #pragma interface
- #endif
-
-+#ifdef HAVE_CPP_POPPLER_VERSION_H
-+#include "cpp/poppler-version.h"
-+#endif
- #include "splash/SplashTypes.h"
- #include "splash/SplashState.h"
- #include "splash/Splash.h"
-diff -ruN cups-filters-9999.orig/filter/pdftoopvp/oprs/OPVPSplashXPath.cxx cups-filters-9999/filter/pdftoopvp/oprs/OPVPSplashXPath.cxx
---- cups-filters-9999.orig/filter/pdftoopvp/oprs/OPVPSplashXPath.cxx 2012-07-19 00:25:53.311589000 +0200
-+++ cups-filters-9999/filter/pdftoopvp/oprs/OPVPSplashXPath.cxx 2012-07-19 00:23:58.000000000 +0200
-@@ -1,5 +1,8 @@
- #include <config.h>
- #include <stdio.h>
-+#ifdef HAVE_CPP_POPPLER_VERSION_H
-+#include "cpp/poppler-version.h"
-+#endif
- #include "splash/Splash.h"
- #include "splash/SplashMath.h"
- #include "OPVPSplashClip.h"
-diff -ruN cups-filters-9999.orig/filter/pdftoopvp/oprs/OPVPSplashXPath.h cups-filters-9999/filter/pdftoopvp/oprs/OPVPSplashXPath.h
---- cups-filters-9999.orig/filter/pdftoopvp/oprs/OPVPSplashXPath.h 2012-07-19 00:25:53.311589000 +0200
-+++ cups-filters-9999/filter/pdftoopvp/oprs/OPVPSplashXPath.h 2012-07-19 00:23:58.000000000 +0200
-@@ -2,6 +2,9 @@
- #define OPVPSPLASHXPATH_H
-
- #include <config.h>
-+#ifdef HAVE_CPP_POPPLER_VERSION_H
-+#include "cpp/poppler-version.h"
-+#endif
- #include "splash/SplashXPath.h"
- #include "OPVPSplashPath.h"
- #include "OPVPSplashState.h"
-diff -ruN cups-filters-9999.orig/filter/pdftoopvp/pdftoopvp.cxx cups-filters-9999/filter/pdftoopvp/pdftoopvp.cxx
---- cups-filters-9999.orig/filter/pdftoopvp/pdftoopvp.cxx 2012-07-19 00:25:53.311589000 +0200
-+++ cups-filters-9999/filter/pdftoopvp/pdftoopvp.cxx 2012-07-19 00:23:58.000000000 +0200
-@@ -13,6 +13,9 @@
- #include <unistd.h>
- #include <ctype.h>
- #include <math.h>
-+#ifdef HAVE_CPP_POPPLER_VERSION_H
-+#include "cpp/poppler-version.h"
-+#endif
- #include "goo/GooString.h"
- #define GSTRING_H // for old GooString.h
- #include "goo/gmem.h"
-diff -ruN cups-filters-9999.orig/filter/pdftopdf/P2PError.h cups-filters-9999/filter/pdftopdf/P2PError.h
---- cups-filters-9999.orig/filter/pdftopdf/P2PError.h 2012-07-19 00:25:53.311589000 +0200
-+++ cups-filters-9999/filter/pdftopdf/P2PError.h 2012-07-19 00:23:58.000000000 +0200
-@@ -31,6 +31,9 @@
- #include <config.h>
- #include <stdarg.h>
- #include <Error.h>
-+#ifdef HAVE_CPP_POPPLER_VERSION_H
-+#include "cpp/poppler-version.h"
-+#endif
-
- #if POPPLER_VERSION_MAJOR > 0 || POPPLER_VERSION_MINOR >= 19
- #define p2pError(pos,...) error(errInternal,pos,__VA_ARGS__)
-diff -ruN cups-filters-9999.orig/filter/pdftopdf/P2PFont.cxx cups-filters-9999/filter/pdftopdf/P2PFont.cxx
---- cups-filters-9999.orig/filter/pdftopdf/P2PFont.cxx 2012-07-19 00:25:53.311589000 +0200
-+++ cups-filters-9999/filter/pdftopdf/P2PFont.cxx 2012-07-19 00:23:58.000000000 +0200
-@@ -32,6 +32,9 @@
- #include <sys/types.h>
- #include <unistd.h>
- #include <fcntl.h>
-+#ifdef HAVE_CPP_POPPLER_VERSION_H
-+#include "cpp/poppler-version.h"
-+#endif
- #include "goo/gmem.h"
- #include "P2PFont.h"
- #include "GfxFont.h"
-diff -ruN cups-filters-9999.orig/filter/pdftopdf/pdftopdf.cxx cups-filters-9999/filter/pdftopdf/pdftopdf.cxx
---- cups-filters-9999.orig/filter/pdftopdf/pdftopdf.cxx 2012-07-19 00:25:53.311589000 +0200
-+++ cups-filters-9999/filter/pdftopdf/pdftopdf.cxx 2012-07-19 00:23:58.000000000 +0200
-@@ -29,6 +29,9 @@
- #include <config.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#ifdef HAVE_CPP_POPPLER_VERSION_H
-+#include "cpp/poppler-version.h"
-+#endif
- #include "goo/GooString.h"
- #include "goo/gmem.h"
- #include "Object.h"
-diff -ruN cups-filters-9999.orig/filter/pdftoraster.cxx cups-filters-9999/filter/pdftoraster.cxx
---- cups-filters-9999.orig/filter/pdftoraster.cxx 2012-07-19 00:25:53.311589000 +0200
-+++ cups-filters-9999/filter/pdftoraster.cxx 2012-07-19 00:23:58.000000000 +0200
-@@ -31,6 +31,9 @@
- #include <config.h>
- #include <stdio.h>
- #include <stdlib.h>
-+#ifdef HAVE_CPP_POPPLER_VERSION_H
-+#include "cpp/poppler-version.h"
-+#endif
- #include "goo/GooString.h"
- #include "goo/gmem.h"
- #include "Object.h"