summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2005-06-07 17:02:33 +0000
committerHeinrich Wendel <lanius@gentoo.org>2005-06-07 17:02:33 +0000
commit1d402f607b95682f8a5ee24976bbcefea6809af0 (patch)
tree83052a09168dbba5210e9706d8f4d98fa93acbc6 /net-print/hplip
parentfix depend (diff)
downloadgentoo-2-1d402f607b95682f8a5ee24976bbcefea6809af0.tar.gz
gentoo-2-1d402f607b95682f8a5ee24976bbcefea6809af0.tar.bz2
gentoo-2-1d402f607b95682f8a5ee24976bbcefea6809af0.zip
intial import
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-print/hplip')
-rw-r--r--net-print/hplip/ChangeLog10
-rw-r--r--net-print/hplip/Manifest5
-rw-r--r--net-print/hplip/files/digest-hplip-0.9.32
-rw-r--r--net-print/hplip/files/hplip.init.d40
-rw-r--r--net-print/hplip/hplip-0.9.3.ebuild88
-rw-r--r--net-print/hplip/metadata.xml5
6 files changed, 150 insertions, 0 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
new file mode 100644
index 000000000000..203346a63c54
--- /dev/null
+++ b/net-print/hplip/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-print/hplip
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.1 2005/06/07 17:02:33 lanius Exp $
+
+*hplip-0.9.3 (07 Jun 2005)
+
+ 07 Jun 2005; Heinrich Wendel <lanius@gentoo.org> +metadata.xml,
+ +hplip-0.9.3.ebuild:
+ initial import, bug #73709
+
diff --git a/net-print/hplip/Manifest b/net-print/hplip/Manifest
new file mode 100644
index 000000000000..93d17709c783
--- /dev/null
+++ b/net-print/hplip/Manifest
@@ -0,0 +1,5 @@
+MD5 808ad9588938bbce411cadb12b7ec69e hplip-0.9.3.ebuild 2459
+MD5 71d8526c60f8ee1babd9571293e284dc ChangeLog 263
+MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
+MD5 ce4ebffecf6776bf8b594d515f151b0e files/digest-hplip-0.9.3 146
+MD5 acbd1c5de008bbd9f699216382665b32 files/hplip.init.d 802
diff --git a/net-print/hplip/files/digest-hplip-0.9.3 b/net-print/hplip/files/digest-hplip-0.9.3
new file mode 100644
index 000000000000..b2317375469d
--- /dev/null
+++ b/net-print/hplip/files/digest-hplip-0.9.3
@@ -0,0 +1,2 @@
+MD5 da1de128875173238c65303c7540a555 hplip-0.9.3.tar.gz 10855639
+MD5 73c8a89d1fd5ecfad1da91d28208db82 foomatic-db-hpijs-1.5-20050607.tar.gz 87246
diff --git a/net-print/hplip/files/hplip.init.d b/net-print/hplip/files/hplip.init.d
new file mode 100644
index 000000000000..b7425ace6646
--- /dev/null
+++ b/net-print/hplip/files/hplip.init.d
@@ -0,0 +1,40 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/files/hplip.init.d,v 1.1 2005/06/07 17:02:33 lanius Exp $
+
+depend() {
+ before cupsd
+ after hotplug
+ use net
+}
+
+start() {
+ ebegin "Starting hpiod"
+ start-stop-daemon --start --quiet --exec /usr/sbin/hpiod
+ eend $?
+
+ ebegin "Starting hpssd"
+ start-stop-daemon --quiet --start --exec /usr/share/hplip/hpssd.py \
+ --pidfile /var/run/hpssd.pid >/dev/null 2>&1
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping hpiod"
+ start-stop-daemon --stop --quiet -n hpiod
+ eend $?
+
+ ebegin "Stopping hpssd"
+ start-stop-daemon --stop --pidfile /var/run/hpssd.pid
+ RETVAL=$?
+ for PIDFILE in /var/run/*; do
+ case "$( basename $PIDFILE )" in
+ hpguid-*.pid)
+ read PID < $PIDFILE
+ kill $PID
+ rm $PIDFILE
+ esac
+ done
+ eend $RETVAL
+}
diff --git a/net-print/hplip/hplip-0.9.3.ebuild b/net-print/hplip/hplip-0.9.3.ebuild
new file mode 100644
index 000000000000..32d7a296f0b2
--- /dev/null
+++ b/net-print/hplip/hplip-0.9.3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-0.9.3.ebuild,v 1.1 2005/06/07 17:02:33 lanius Exp $
+
+inherit eutils
+
+DB_V=1.5-20050607
+DESCRIPTION="HP Linux Imaging and Printing System. Includes net-print/hpijs, scanner drivers and service tools."
+HOMEPAGE="http://hpinkjet.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hpinkjet/${P}.tar.gz
+ foomaticdb? ( http://www.linuxprinting.org/download/foomatic/foomatic-db-hpijs-${DB_V}.tar.gz )"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="foomaticdb snmp X qt ppds scanner"
+
+DEPEND="dev-lang/python
+ snmp? ( >=net-analyzer/net-snmp-5.0.9 )
+ !net-print/hpijs
+ !net-print/hpoj"
+
+RDEPEND="virtual/ghostscript
+ >=dev-lang/python-2.2.0
+ scanner? ( >=media-gfx/sane-backends-1.0.9 )
+ scanner? ( || ( X? ( >=media-gfx/xsane-0.89 ) >=media-gfx/sane-frontends-1.0.9 ) )
+ qt? ( >=dev-python/PyQt-3.11 x11-libs/qt )
+ usb? ( dev-libs/libusb sys-apps/hotplug )
+ foomaticdb? ( >=net-print/foomatic )
+ cups? ( net-print/cups )
+ ${DEPEND}"
+
+
+src_compile() {
+ myconf="${myconf} --disable-cups-install --disable-foomatic-install"
+
+ use snmp || myconf="${myconf} --disable-network-build"
+
+ econf ${myconf} || die "Error: econf failed!"
+ emake || die "Error: emake failed!"
+}
+
+
+src_install() {
+ make DESTDIR=${D} install
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/hplip.init.d hplip
+
+ if use scanner; then
+ insinto /etc/sane.d
+ echo "hpaio" > dll.conf
+ doins dll.conf
+
+ dodir /usr/lib/sane
+ dosym /usr/lib/libsane-hpaio.la /usr/lib/sane/libsane-hpaio.la
+ dosym /usr/lib/libsane-hpaio.so /usr/lib/sane/libsane-hpaio.so
+ dosym /usr/lib/libsane-hpaio.so.1 /usr/lib/sane/libsane-hpaio.so.1
+ dosym /usr/lib/libsane-hpaio.so.1.0.0 /usr/lib/sane/libsane-hpaio.so.1.0.0
+ else
+ rm -f ${D}/usr/lib/libsane-hpaio.la
+ rm -f ${D}/usr/lib/libsane-hpaio.so
+ rm -f ${D}/usr/lib/libsane-hpaio.so.1
+ rm -f ${D}/usr/lib/libsane-hpaio.so.1.0.0
+ fi
+
+ if use ppds; then
+ dodir /usr/share
+ mv ${S}/prnt/hpijs/ppd ${D}/usr/share
+ fi
+
+ if use cups && use ppds ; then
+ dodir /usr/share/cups/model
+ dosym /usr/share/ppd /usr/share/cups/model/foomatic-ppds
+ fi
+
+ [ -e /usr/bin/foomatic-rip ] && rm -f ${D}/usr/bin/foomatic-rip
+
+ if use foomaticdb ; then
+ cd ../foomatic-db-hpijs-${DB_V}
+ econf || die "econf failed"
+ rm -fR data-generators/hpijs-rss
+ make || die
+ make DESTDIR=${D} install || die
+ fi
+
+ dodir /usr/share/applications
+ mv ${D}/usr/share/hplip/data/hplip.desktop ${D}/usr/share/applications
+}
diff --git a/net-print/hplip/metadata.xml b/net-print/hplip/metadata.xml
new file mode 100644
index 000000000000..1fa0ca569505
--- /dev/null
+++ b/net-print/hplip/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>printing</herd>
+</pkgmetadata>