summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-01-13 15:08:18 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-01-13 15:08:18 +0000
commit89608d232c4b20698c7629e481142e2a795487b1 (patch)
tree0388218b68d805dbb0b1bec433f96cd4eb070f06 /net-print/hplip
parentReorganize ebuild and depends wrt #205597 (diff)
downloadgentoo-2-89608d232c4b20698c7629e481142e2a795487b1.tar.gz
gentoo-2-89608d232c4b20698c7629e481142e2a795487b1.tar.bz2
gentoo-2-89608d232c4b20698c7629e481142e2a795487b1.zip
Use python.eclass, thanks to Mart Raudsepp (bug #203669).
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'net-print/hplip')
-rw-r--r--net-print/hplip/ChangeLog9
-rw-r--r--net-print/hplip/files/digest-hplip-2.7.12-r13
-rw-r--r--net-print/hplip/hplip-2.7.10.ebuild4
-rw-r--r--net-print/hplip/hplip-2.7.12-r1.ebuild138
-rw-r--r--net-print/hplip/hplip-2.7.12.ebuild4
5 files changed, 152 insertions, 6 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index 32776dd40fb7..d17d50c29c95 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/hplip
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.93 2007/12/27 21:27:27 calchan Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.94 2008/01/13 15:08:18 calchan Exp $
+
+*hplip-2.7.12-r1 (13 Jan 2008)
+
+ 13 Jan 2008; Denis Dupeyron <calchan@gentoo.org> +hplip-2.7.12-r1.ebuild:
+ Use python.eclass, thanks to Mart Raudsepp (bug #203669).
27 Dec 2007; Denis Dupeyron <calchan@gentoo.org>
-files/hplip-1.7.4a-subprocess_replacement.patch,
diff --git a/net-print/hplip/files/digest-hplip-2.7.12-r1 b/net-print/hplip/files/digest-hplip-2.7.12-r1
new file mode 100644
index 000000000000..f976a9f5ae48
--- /dev/null
+++ b/net-print/hplip/files/digest-hplip-2.7.12-r1
@@ -0,0 +1,3 @@
+MD5 ba00337ccf1b520509518bffbec960db hplip-2.7.12.tar.gz 14543662
+RMD160 6d278ccd3d19df46c6d7fc6bd1b9a6b995749f88 hplip-2.7.12.tar.gz 14543662
+SHA256 22c1b626c633acac74ab5f7994060304570a81a038f2be5b9e35e44e938a30a0 hplip-2.7.12.tar.gz 14543662
diff --git a/net-print/hplip/hplip-2.7.10.ebuild b/net-print/hplip/hplip-2.7.10.ebuild
index 0a463151087f..32a490dbb81b 100644
--- a/net-print/hplip/hplip-2.7.10.ebuild
+++ b/net-print/hplip/hplip-2.7.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-2.7.10.ebuild,v 1.6 2007/12/30 18:39:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-2.7.10.ebuild,v 1.7 2008/01/13 15:08:18 calchan Exp $
inherit eutils linux-info
diff --git a/net-print/hplip/hplip-2.7.12-r1.ebuild b/net-print/hplip/hplip-2.7.12-r1.ebuild
new file mode 100644
index 000000000000..53b264f6e513
--- /dev/null
+++ b/net-print/hplip/hplip-2.7.12-r1.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-2.7.12-r1.ebuild,v 1.1 2008/01/13 15:08:18 calchan Exp $
+
+inherit eutils linux-info python
+
+DESCRIPTION="HP Linux Imaging and Printing System. Includes net-print/hpijs, scanner drivers and service tools."
+HOMEPAGE="http://hplip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hplip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="X doc fax minimal parport ppds scanner snmp"
+
+DEPEND="!net-print/hpijs
+ !net-print/hpoj
+ virtual/ghostscript
+ >=media-libs/jpeg-6b
+ net-print/foomatic-filters
+ !minimal? (
+ >=net-print/cups-1.2
+ dev-libs/libusb
+ scanner? ( >=media-gfx/sane-backends-1.0.9 )
+ snmp? (
+ net-analyzer/net-snmp
+ dev-libs/openssl
+ )
+ )"
+
+RDEPEND="${DEPEND}
+ !minimal? (
+ !<sys-fs/udev-114
+ fax? ( dev-python/reportlab )
+ scanner? (
+ dev-python/imaging
+ X? ( >=media-gfx/xsane-0.89 )
+ !X? ( >=media-gfx/sane-frontends-1.0.9 )
+ )
+ X? ( >=dev-python/PyQt-3.14 )
+ )"
+
+CONFIG_CHECK="PARPORT"
+ERROR_PARPORT="Please make sure Device Drivers -> Parallel port support is enabled in your kernel"
+
+pkg_setup() {
+ if ! use ppds ; then
+ ewarn "Not installing built-in PPD files, which is probably not what you want."
+ ewarn "You need USE=ppds if you want to install them."
+ fi
+ if use minimal ; then
+ ewarn "Installing hpijs driver only, make sure you know what you are doing."
+ else
+ use parport && linux-info_pkg_setup
+ fi
+
+ # avoid collisions with cups-1.2 compat symlinks
+ if [ -e "${ROOT}"/usr/lib/cups/backend/hp ] && [ -e "${ROOT}"/usr/libexec/cups/backend/hp ]; then
+ rm -f "${ROOT}"/usr/libexec/cups/backend/hp{,fax};
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s:\$(doc_DATA)::" Makefile.in || die "Patching Makefile.in failed"
+ sed -i -e "s/'skipstone']/'skipstone', 'epiphany']/" \
+ -e "s/'skipstone': ''}/'skipstone': '', 'epiphany': '--new-window'}/" \
+ base/utils.py || die "Patching base/utils.py failed"
+
+ # bug 98428
+ sed -i -e "s:/usr/bin/env python:/usr/bin/python:g" hpssd.py || die "Patching hpssd.py failed"
+
+ # Force recognition of Gentoo distro by hp-check
+ sed -i \
+ -e "s:file('/etc/issue', 'r').read():'Gentoo':" \
+ installer/core_install.py || die "sed core_install.py"
+
+ # Replace udev rules, see bug #197726.
+ rm data/rules/55-hpmud.rules
+ cp "${FILESDIR}"/70-hpmud.rules data/rules
+ sed -i -e "s/55-hpmud.rules/70-hpmud.rules/g" Makefile.* */*.html */*/*.html
+}
+
+src_compile() {
+ econf \
+ --disable-cups11-build \
+ --with-cupsbackenddir=$(cups-config --serverbin)/backend \
+ $(use_enable minimal hpijs-only-build) \
+ $(use_enable doc doc-build) \
+ $(use_enable snmp network-build) \
+ $(use_enable parport pp-build) \
+ $(use_enable scanner scan-build) \
+ $(use_enable X gui-build) \
+ $(use_enable fax fax-build) \
+ $(use_enable ppds foomatic-ppd-install) \
+ --disable-foomatic-xml-install \
+ || die "econf failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ # bug 106035
+ use X || rm -Rf "${D}"/usr/share/applications
+
+ use minimal && rm -rf "${D}"/usr/lib
+}
+
+pkg_preinst() {
+ # try to be very conservative as to when we screw around with config files
+ use minimal && return 0
+ use scanner || return 0
+ [[ ! -e ${ROOT}/etc/sane.d/dll.conf ]] && return 0
+ grep -qs '\<hpaio\>' "${ROOT}"/etc/sane.d/dll.conf && return 0
+
+ cp "${ROOT}"/etc/sane.d/dll.conf "${T}"/dll.conf || return 1
+ echo hpaio >> "${T}"/dll.conf
+ insinto /etc/sane.d
+ doins "${T}"/dll.conf
+}
+
+pkg_postinst() {
+ python_mod_optimize "${ROOT}"usr/share/hplip
+ elog "You should run hp-setup as root if you are installing hplip for the first time, and may also"
+ elog "need to run it if you are upgrading from an earlier version."
+ elog
+ elog "If your device is connected using USB, users will need to be in the lp group to access it."
+ elog
+ elog "This release doesn't use an init script anymore, so you should probably do a"
+ elog "'rc-update del hplip' if you are updating from an old version."
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/hplip
+}
diff --git a/net-print/hplip/hplip-2.7.12.ebuild b/net-print/hplip/hplip-2.7.12.ebuild
index 388ee7df270e..09333f11c8dd 100644
--- a/net-print/hplip/hplip-2.7.12.ebuild
+++ b/net-print/hplip/hplip-2.7.12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-2.7.12.ebuild,v 1.2 2007/12/30 18:39:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-2.7.12.ebuild,v 1.3 2008/01/13 15:08:18 calchan Exp $
inherit eutils linux-info