summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2007-04-23 22:29:26 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2007-04-23 22:29:26 +0000
commitde8b3327e822c7ba005920964ce1bf31071b781a (patch)
tree7f9b225b72f4d024a6f1c0b3f5c50555b9bcd3c4 /net-print/hplip
parentVersion bump, cleanup of older versions (diff)
downloadgentoo-2-de8b3327e822c7ba005920964ce1bf31071b781a.tar.gz
gentoo-2-de8b3327e822c7ba005920964ce1bf31071b781a.tar.bz2
gentoo-2-de8b3327e822c7ba005920964ce1bf31071b781a.zip
1.7.4 version bump.
(Portage version: 2.1.2.2)
Diffstat (limited to 'net-print/hplip')
-rw-r--r--net-print/hplip/ChangeLog7
-rw-r--r--net-print/hplip/files/digest-hplip-1.7.46
-rw-r--r--net-print/hplip/hplip-1.7.4.ebuild124
3 files changed, 136 insertions, 1 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index 96f19c53e3ad..1400e3d1cded 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/hplip
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.59 2007/04/07 13:45:12 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.60 2007/04/23 22:29:26 vanquirius Exp $
+
+*hplip-1.7.4 (23 Apr 2007)
+
+ 23 Apr 2007; Marcelo Goes <vanquirius@gentoo.org> +hplip-1.7.4.ebuild:
+ 1.7.4 version bump.
07 Apr 2007; Stefan Schweizer <genstef@gentoo.org> hplip-1.7.3.ebuild:
Add information about qt3 useflag needed thanks to Matthew Schultz
diff --git a/net-print/hplip/files/digest-hplip-1.7.4 b/net-print/hplip/files/digest-hplip-1.7.4
new file mode 100644
index 000000000000..e223150978db
--- /dev/null
+++ b/net-print/hplip/files/digest-hplip-1.7.4
@@ -0,0 +1,6 @@
+MD5 1c4b65222333d048450d37082d521b1e foomatic-db-hpijs-20060720.tar.gz 98252
+RMD160 0c2c09f3cea6fc2a8e5da216bd9996b96d91613d foomatic-db-hpijs-20060720.tar.gz 98252
+SHA256 1e50f603b46b1d07980212b2e5dfc5d72d07c889259e79ecbf09469fef5ad20e foomatic-db-hpijs-20060720.tar.gz 98252
+MD5 61bff0f674dff2c0ef0a077c0ce17a57 hplip-1.7.4.tar.gz 13565392
+RMD160 1e1cf865be6507fed0cc174eff5ad55002ea435a hplip-1.7.4.tar.gz 13565392
+SHA256 cb9c3531897af9613932fb9896ed2696f8903dd44b2a385a2faff0b819337aa5 hplip-1.7.4.tar.gz 13565392
diff --git a/net-print/hplip/hplip-1.7.4.ebuild b/net-print/hplip/hplip-1.7.4.ebuild
new file mode 100644
index 000000000000..a727502376a7
--- /dev/null
+++ b/net-print/hplip/hplip-1.7.4.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-1.7.4.ebuild,v 1.1 2007/04/23 22:29:26 vanquirius Exp $
+
+inherit eutils
+
+DB_V=20060720
+DESCRIPTION="HP Linux Imaging and Printing System. Includes net-print/hpijs, scanner drivers and service tools."
+HOMEPAGE="http://hplip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hplip/${P}.tar.gz
+ foomaticdb? (
+ http://gentooexperimental.org/~genstef/dist/foomatic-db-hpijs-${DB_V}.tar.gz
+ http://www.linuxprinting.org/download/foomatic/foomatic-db-hpijs-${DB_V}.tar.gz
+ )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="cups foomaticdb snmp qt3 ppds scanner X"
+
+DEPEND=">=dev-lang/python-2.2.0
+ snmp? ( >=net-analyzer/net-snmp-5.0.9 )
+ !net-print/hpijs
+ !net-print/hpoj
+ virtual/ghostscript
+ scanner? (
+ >=media-gfx/sane-backends-1.0.9
+ X? ( || (
+ >=media-gfx/xsane-0.89
+ >=media-gfx/sane-frontends-1.0.9
+ ) )
+ !X? ( || (
+ >=media-gfx/sane-frontends-1.0.9
+ >=media-gfx/xsane-0.89
+ ) )
+ )
+ qt3? ( >=dev-python/PyQt-3.11 =x11-libs/qt-3* )
+ >=dev-libs/libusb-0.1.10a
+ sys-apps/hotplug-base
+ net-print/cups
+ foomaticdb? ( net-print/foomatic-db-engine )
+ >=net-print/foomatic-filters-3.0.2"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ # avoid collisions with cups-1.2 compat symlinks
+ if [ -e ${ROOT}/usr/lib/cups/backend/hp ] && [ -e ${ROOT}/usr/libexec/cups/backend/hp ]; then
+ rm -f ${ROOT}/usr/libexec/cups/backend/hp{,fax};
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # bug 98428
+ sed -i -e "s:/usr/bin/env python:/usr/bin/python:g" \
+ hpssd.py
+}
+src_compile() {
+ econf \
+ $(use_enable snmp network-build) \
+ $(use_enable cups cups-install) \
+ $(use_enable ppds foomatic-install) \
+ || die "econf failed"
+ emake || die "emake failed"
+
+ if use foomaticdb ; then
+ cd ../foomatic-db-hpijs-${DB_V}
+ econf || die "econf failed"
+ rm -fR data-generators/hpijs-rss
+ emake || die "emake failed"
+ fi
+}
+
+
+src_install() {
+ # cups-1.2 installation paths, make sure that the .desktop is installed
+ sed -i -e "s:/usr/lib/cups:$(cups-config --serverbin):" \
+ -e 's:\(ICON_FILE = \).*:\1hplip.desktop:' \
+ -e 's:\(ICON_PATH = \).*:\1/usr/share/applications:' \
+ Makefile
+
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}"/hplip.init.d hplip
+
+ if use scanner; then
+ dodir /usr/$(get_libdir)/sane
+ for i in libsane-hpaio.{la,so{,.1{,.0.0}}}; do
+ dosym /usr/$(get_libdir)/${i} /usr/$(get_libdir)/sane/${i}; done
+ else
+ rm -f "${D}"/usr/$(get_libdir)/libsane-hpaio.{la,so{,.1{,.0.0}}}
+ rm -f "${D}"/etc/sane.d/dll.conf
+ fi
+
+ # bug 106035
+ if ! use qt3 ; then
+ rm -f "${D}"/usr/{bin/hp-,share/hplip/}{print,toolbox}
+ rm -f "${D}"/usr/share/applications/hplip.desktop
+ rm -f "${D}"/usr/lib/menu/hplip
+ fi
+
+ rm -rf ${D}/$(cups-config --serverbin)/filter ${D}/usr/bin/foomatic-rip
+
+ if use foomaticdb ; then
+ cd ../foomatic-db-hpijs-${DB_V}
+ emake DESTDIR="${D}" install || die "emake install failed"
+ fi
+}
+
+pkg_preinst() {
+ if use scanner; then
+ insinto /etc/sane.d
+ [ -e /etc/sane.d/dll.conf ] && cp /etc/sane.d/dll.conf .
+ [ -e ${ROOT}/etc/sane.d/dll.conf ] && cp ${ROOT}/etc/sane.d/dll.conf .
+ grep -q hpaio dll.conf || echo hpaio >> dll.conf
+ doins dll.conf
+ fi
+}
+
+pkg_postinst() {
+ einfo "You need the qt3 useflag enabled to use the guy configurator hp-setup"
+}