summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2005-08-09 01:39:49 +0000
committerLuis Medinas <metalgod@gentoo.org>2005-08-09 01:39:49 +0000
commitdc2682134d556e187834a029f45507605a643fdb (patch)
tree30aeaff2ed9bfe76d8c0f5771288be8314eb4aed /net-print/mtink/mtink-1.0.9.ebuild
parentStable on mips. (diff)
downloadgentoo-2-dc2682134d556e187834a029f45507605a643fdb.tar.gz
gentoo-2-dc2682134d556e187834a029f45507605a643fdb.tar.bz2
gentoo-2-dc2682134d556e187834a029f45507605a643fdb.zip
Version Bump. Added X USE flag thanks to JeR <jer@xs4all.nl> closes bug #99964 .
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-print/mtink/mtink-1.0.9.ebuild')
-rw-r--r--net-print/mtink/mtink-1.0.9.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-print/mtink/mtink-1.0.9.ebuild b/net-print/mtink/mtink-1.0.9.ebuild
new file mode 100644
index 000000000000..db02ca59c5c1
--- /dev/null
+++ b/net-print/mtink/mtink-1.0.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/mtink/mtink-1.0.9.ebuild,v 1.1 2005/08/09 01:39:49 metalgod Exp $
+
+DESCRIPTION="mtink is a status monitor and inkjet cartridge changer for some Epson printers"
+HOMEPAGE="http://xwtools.automatix.de/"
+SRC_URI="http://xwtools.automatix.de/files/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="cups doc X"
+
+DEPEND="X? ( x11-libs/openmotif virtual/x11 )
+ cups? ( net-print/cups )"
+
+inherit eutils
+
+src_compile() {
+ local mytargets
+ mytargets="ttink detect/askPrinter mtinkd"
+ if use X;
+ then
+ mytargets="${mytargets} mtink mtinkc";
+ fi
+ make ${mytargets} || die "Compile problem"
+}
+
+src_install() {
+ exeinto /usr/bin
+ if use X; then
+ doexe mtinkc mtink ttink detect/askPrinter
+ else
+ doexe ttink detect/askPrinter
+ fi
+ exeinto /usr/sbin
+ doexe mtinkd
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/mtinkd.rc mtinkd
+ insinto /etc/conf.d
+ newins ${FILESDIR}/mtinkd.confd mtinkd
+
+ use cups && \
+ exeinto /usr/lib/cups/backend; \
+ doexe etc/mtink-cups
+
+ dodoc README CHANGE.LOG LICENCE
+ use doc && {
+ dohtml html/*.gif html/*.html
+ }
+}
+
+pkg_postinst() {
+ # see #70310
+ chmod 700 /var/mtink /var/run/mtink 2>/dev/null
+
+ einfo
+ einfo "mtink needs correct permissions to access printer device."
+ einfo "To do this you either need to run the following chmod command:"
+ einfo "chmod 666 /dev/<device>"
+ einfo "or set the suid bit on mtink, mtinkc and ttink in /usr/bin"
+ einfo
+}