summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2012-03-10 15:53:55 +0000
committerNathan Phillip Brink <binki@gentoo.org>2012-03-10 15:53:55 +0000
commit07a54134778d64a3308fb52781fe618fd92acf0a (patch)
tree40fe2db2b382212e12f10aeee9f578938b2d5588 /net-print
parentMoving dev-php/yaml to dev-php/YAML (diff)
downloadgentoo-2-07a54134778d64a3308fb52781fe618fd92acf0a.tar.gz
gentoo-2-07a54134778d64a3308fb52781fe618fd92acf0a.tar.bz2
gentoo-2-07a54134778d64a3308fb52781fe618fd92acf0a.zip
Bump to c2esp-24 for bug #406505 by Navid Zamani. Fix docdir and respect CPPFLAGS in the new version.
(Portage version: 2.2.0_alpha90-r1/cvs/Linux x86_64)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/c2esp/ChangeLog11
-rw-r--r--net-print/c2esp/c2esp-24.ebuild53
-rw-r--r--net-print/c2esp/files/c2esp-24-ldflags-cppflags.patch32
3 files changed, 94 insertions, 2 deletions
diff --git a/net-print/c2esp/ChangeLog b/net-print/c2esp/ChangeLog
index d2c3cd9760e2..6e663e46096c 100644
--- a/net-print/c2esp/ChangeLog
+++ b/net-print/c2esp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-print/c2esp
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/c2esp/ChangeLog,v 1.1 2011/08/23 03:59:00 binki Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/c2esp/ChangeLog,v 1.2 2012/03/10 15:53:54 binki Exp $
+
+*c2esp-24 (10 Mar 2012)
+
+ 10 Mar 2012; Nathan Phillip Brink <binki@gentoo.org> +c2esp-24.ebuild,
+ +files/c2esp-24-ldflags-cppflags.patch:
+ Bump to c2esp-24 for bug #406505 by Navid Zamani. Fix docdir and respect
+ CPPFLAGS in the new version.
*c2esp-18 (23 Aug 2011)
diff --git a/net-print/c2esp/c2esp-24.ebuild b/net-print/c2esp/c2esp-24.ebuild
new file mode 100644
index 000000000000..6a64f5f9cee5
--- /dev/null
+++ b/net-print/c2esp/c2esp-24.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/c2esp/c2esp-24.ebuild,v 1.1 2012/03/10 15:53:54 binki Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}${PV}
+
+DESCRIPTION="A cups filter for Kodak ESP printers"
+HOMEPAGE="http://cupsdriverkodak.sf.net/"
+SRC_URI="mirror://sourceforge/cupsdriverkodak/files/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND=">=media-libs/jbigkit-2.0-r1
+ >=net-print/cups-1.4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags-cppflags.patch
+
+ # Remove embedded media-libs/jbigkit
+ rm -f *jbig* || die
+
+ # Remove the embedded jbig files from the Makefile's dependencies:
+ sed -i \
+ -e '/^[a-z0-9.]*:/s/\$(LIBJBG[[:digit:]]*)//g' \
+ -e '/^[a-z0-9.]*:/s/jbig[^ ]*\.h//g' \
+ -e '/\$(INSTALL).*COPYING/d' \
+ Makefile || die
+
+ # Use Gentoo-style cups paths
+ sed -i -e s,/usr/lib/cups/filter,/usr/libexec/cups/filter,g ppd/*.ppd || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LIBJBG=-ljbig LIBJBG85=-ljbig85
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ FILTERBIN="${D}"/usr/libexec/cups/filter \
+ DOCDIR="${ED}"/usr/share/doc/${PF} \
+ install
+}
diff --git a/net-print/c2esp/files/c2esp-24-ldflags-cppflags.patch b/net-print/c2esp/files/c2esp-24-ldflags-cppflags.patch
new file mode 100644
index 000000000000..f1059c465330
--- /dev/null
+++ b/net-print/c2esp/files/c2esp-24-ldflags-cppflags.patch
@@ -0,0 +1,32 @@
+--- a/Makefile
++++ b/Makefile
+@@ -166,16 +166,16 @@
+ @echo
+
+ c2esp: c2esp.o c2espcommon.o $(LIBJBG85)
+- $(CC) $(CFLAGS) -o $@ c2esp.o c2espcommon.o -lcupsimage -lcups -lcupsdriver $(LIBJBG85)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ c2esp.o c2espcommon.o -lcupsimage -lcups -lcupsdriver $(LIBJBG85)
+
+ c2espC: c2espC.o c2espcommon.o
+- $(CC) $(CFLAGS) -o $@ c2espC.o c2espcommon.o -lcupsimage -lcups -lcupsdriver -lz
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ c2espC.o c2espcommon.o -lcupsimage -lcups -lcupsdriver -lz
+
+ command2esp: command2esp.o c2espcommon.o
+- $(CC) $(CFLAGS) -o $@ command2esp.o c2espcommon.o -lcups -lcupsdriver
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ command2esp.o c2espcommon.o -lcups -lcupsdriver
+
+ myopldecode: myopldecode.o $(LIBJBG)
+- $(CC) $(CFLAGS) -o $@ $@.o $(LIBJBG) -lz
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $@.o $(LIBJBG) -lz
+
+ #
+ # Installation rules
+@@ -326,3 +326,8 @@
+ #
+ ppdc KodakESP_10.drv
+ ppdc KodakESP_C_06.drv
++
++# Respect CPPFLAGS.
++.SUFFIXES: .c .o
++.c.o:
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) -o '$@' '$<'