summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-01-07 10:00:03 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-01-07 10:00:03 +0000
commit0817861d3193a5b381695dbbd1264c13e27d21ba (patch)
tree02f487eb2e6e4c06ed02e33a93d1c61ef4e3a422 /net-print
parentFinally fix bug 148728 thanks to kloeri for bumping swig (diff)
downloadgentoo-2-0817861d3193a5b381695dbbd1264c13e27d21ba.tar.gz
gentoo-2-0817861d3193a5b381695dbbd1264c13e27d21ba.tar.bz2
gentoo-2-0817861d3193a5b381695dbbd1264c13e27d21ba.zip
version bump thanks to Francisco Lloret <fcolloret@terra.es> in bug 158909
(Portage version: 2.1.2_rc4-r4)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/hplip/ChangeLog10
-rw-r--r--net-print/hplip/files/digest-hplip-1.6.125
-rw-r--r--net-print/hplip/hplip-1.6.12.ebuild116
3 files changed, 129 insertions, 2 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index 26313b35042d..d35114dfa2d1 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-print/hplip
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.46 2006/11/28 21:51:36 genstef Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.47 2007/01/07 10:00:03 genstef Exp $
+
+*hplip-1.6.12 (07 Jan 2007)
+
+ 07 Jan 2007; <genstef@gentoo.org> -hplip-1.6.10.ebuild,
+ +hplip-1.6.12.ebuild:
+ version bump thanks to Francisco Lloret <fcolloret@terra.es> in bug 158909
28 Nov 2006; Stefan Schweizer <genstef@gentoo.org> hplip-1.6.10.ebuild:
fully fix bug 150801
diff --git a/net-print/hplip/files/digest-hplip-1.6.12 b/net-print/hplip/files/digest-hplip-1.6.12
new file mode 100644
index 000000000000..eaa4baec97d2
--- /dev/null
+++ b/net-print/hplip/files/digest-hplip-1.6.12
@@ -0,0 +1,5 @@
+RMD160 0c2c09f3cea6fc2a8e5da216bd9996b96d91613d foomatic-db-hpijs-20060720.tar.gz 98252
+SHA256 1e50f603b46b1d07980212b2e5dfc5d72d07c889259e79ecbf09469fef5ad20e foomatic-db-hpijs-20060720.tar.gz 98252
+MD5 8adcb93703f6e90510f51b3cf96567c9 hplip-1.6.12.tar.gz 10679971
+RMD160 eec181a1edbbb9087118b4f4c9447b042e202814 hplip-1.6.12.tar.gz 10679971
+SHA256 dd7d992c9d79c3ee7b2949a0c68034411e98f16f2a19aecb120f8d03bc5f8b24 hplip-1.6.12.tar.gz 10679971
diff --git a/net-print/hplip/hplip-1.6.12.ebuild b/net-print/hplip/hplip-1.6.12.ebuild
new file mode 100644
index 000000000000..a63474774315
--- /dev/null
+++ b/net-print/hplip/hplip-1.6.12.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-1.6.12.ebuild,v 1.1 2007/01/07 10:00:03 genstef Exp $
+
+inherit eutils
+
+DB_V=20060720
+DESCRIPTION="HP Linux Imaging and Printing System. Includes net-print/hpijs, scanner drivers and service tools."
+HOMEPAGE="http://hplip.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hplip/${P}.tar.gz
+ foomaticdb? (
+ http://gentooexperimental.org/~genstef/dist/foomatic-db-hpijs-${DB_V}.tar.gz
+ http://www.linuxprinting.org/download/foomatic/foomatic-db-hpijs-${DB_V}.tar.gz
+ )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="foomaticdb snmp X qt3 ppds scanner"
+
+DEPEND=">=dev-lang/python-2.2.0
+ snmp? ( >=net-analyzer/net-snmp-5.0.9 )
+ !net-print/hpijs
+ !net-print/hpoj
+ virtual/ghostscript
+ scanner? (
+ >=media-gfx/sane-backends-1.0.9
+ || (
+ X? ( >=media-gfx/xsane-0.89 )
+ >=media-gfx/sane-frontends-1.0.9
+ )
+ )
+ qt3? ( >=dev-python/PyQt-3.11 =x11-libs/qt-3* )
+ >=dev-libs/libusb-0.1.10a
+ sys-apps/hotplug-base
+ net-print/cups
+ foomaticdb? ( net-print/foomatic-db-engine )
+ >=net-print/foomatic-filters-3.0.2"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ # avoid collisions with cups-1.2 compat symlinks
+ if [ -e ${ROOT}/usr/lib/cups/backend/hp ] && [ -e ${ROOT}/usr/libexec/cups/backend/hp ]; then
+ rm -f ${ROOT}/usr/libexec/cups/backend/hp{,fax};
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # bug 98428
+ sed -i -e "s:/usr/bin/env python:/usr/bin/python:g" \
+ hpssd.py
+}
+src_compile() {
+ econf \
+ $(use_enable snmp network-build) \
+ $(use_enable cups cups-install) \
+ $(use_enable ppds foomatic-install) \
+ || die "econf failed"
+ emake || die "emake failed"
+
+ if use foomaticdb ; then
+ cd ../foomatic-db-hpijs-${DB_V}
+ econf || die "econf failed"
+ rm -fR data-generators/hpijs-rss
+ emake || die "emake failed"
+ fi
+}
+
+
+src_install() {
+ # cups-1.2 installation paths, make sure that the .desktop is installed
+ sed -i -e "s:/usr/lib/cups:$(cups-config --serverbin):" \
+ -e 's:\(ICON_FILE = \).*:\1hplip.desktop:' \
+ -e 's:\(ICON_PATH = \).*:\1/usr/share/applications:' \
+ Makefile
+
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ newinitd "${FILESDIR}"/hplip.init.d hplip
+
+ if use scanner; then
+ dodir /usr/$(get_libdir)/sane
+ for i in libsane-hpaio.{la,so{,.1{,.0.0}}}; do
+ dosym /usr/$(get_libdir)/${i} /usr/$(get_libdir)/sane/${i}; done
+ else
+ rm -f "${D}"/usr/$(get_libdir)/libsane-hpaio.{la,so{,.1{,.0.0}}}
+ rm -f "${D}"/etc/sane.d/dll.conf
+ fi
+
+ # bug 106035
+ if ! use qt3 ; then
+ rm -f "${D}"/usr/{bin/hp-,share/hplip/}{print,toolbox}
+ rm -f "${D}"/usr/share/applications/hplip.desktop
+ rm -f "${D}"/usr/lib/menu/hplip
+ fi
+
+ rm -rf ${D}/$(cups-config --serverbin)/filter ${D}/usr/bin/foomatic-rip
+
+ if use foomaticdb ; then
+ cd ../foomatic-db-hpijs-${DB_V}
+ emake DESTDIR="${D}" install || die "emake install failed"
+ fi
+}
+
+pkg_preinst() {
+ if use scanner; then
+ insinto /etc/sane.d
+ [ -e /etc/sane.d/dll.conf ] && cp /etc/sane.d/dll.conf .
+ [ -e ${ROOT}/etc/sane.d/dll.conf ] && cp ${ROOT}/etc/sane.d/dll.conf .
+ grep -q hpaio dll.conf || echo hpaio >> dll.conf
+ doins dll.conf
+ fi
+}