summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-01-24 19:50:49 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-01-24 19:50:49 +0000
commit8adaae77a1972db76d03b95f2395b1dcf8699d23 (patch)
treede9523e5af9472fc8cdaff1b508c4dddf3fd3722 /net-print
parentVersion bump to fix an issue on on IA64. This version changes the default fo... (diff)
downloadgentoo-2-8adaae77a1972db76d03b95f2395b1dcf8699d23.tar.gz
gentoo-2-8adaae77a1972db76d03b95f2395b1dcf8699d23.tar.bz2
gentoo-2-8adaae77a1972db76d03b95f2395b1dcf8699d23.zip
version bump thanks to Jeremy Heslop <jeremy@jheslop.com> in bug 120132
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/mtink/ChangeLog7
-rw-r--r--net-print/mtink/Manifest14
-rw-r--r--net-print/mtink/files/digest-mtink-1.0.111
-rw-r--r--net-print/mtink/mtink-1.0.11.ebuild70
4 files changed, 80 insertions, 12 deletions
diff --git a/net-print/mtink/ChangeLog b/net-print/mtink/ChangeLog
index 5a7b72a5870b..57f9bf6788c6 100644
--- a/net-print/mtink/ChangeLog
+++ b/net-print/mtink/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/mtink
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/mtink/ChangeLog,v 1.19 2006/01/20 03:54:46 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/mtink/ChangeLog,v 1.20 2006/01/24 19:50:49 genstef Exp $
+
+*mtink-1.0.11 (24 Jan 2006)
+
+ 24 Jan 2006; Stefan Schweizer <genstef@gentoo.org> +mtink-1.0.11.ebuild:
+ version bump thanks to Jeremy Heslop <jeremy@jheslop.com> in bug 120132
20 Jan 2006; Joshua Jackson <tsunam@gentoo.org> mtink-1.0.9.ebuild:
stable on x86 for bug #119588
diff --git a/net-print/mtink/Manifest b/net-print/mtink/Manifest
index 028884ad90e6..099fab0eff54 100644
--- a/net-print/mtink/Manifest
+++ b/net-print/mtink/Manifest
@@ -1,18 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 457746dc9ea5f669cc6dc0d718238ce9 ChangeLog 2427
+MD5 06b6f63fc094ff75712fdf539f2aeec8 ChangeLog 2606
+MD5 93bba250c77a04f4020831245ec45e3d files/digest-mtink-1.0.11 64
MD5 6bf7b30c283a992ce56095736e46c764 files/digest-mtink-1.0.5 63
MD5 651ef751bcc8d6f211743e77dc6ed352 files/digest-mtink-1.0.9 63
MD5 3d7d657325f8c614eab923174f39d213 files/mtinkd.confd 494
MD5 3d70b9a7f2797c53b2514593ca34d634 files/mtinkd.rc 439
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
+MD5 3b456b4196a53723ca4d5f65490f2231 mtink-1.0.11.ebuild 1612
MD5 fa7e1a19bdf30d50217691ac7b21fc11 mtink-1.0.5.ebuild 1320
MD5 3b456b4196a53723ca4d5f65490f2231 mtink-1.0.9.ebuild 1612
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFD0F/WSENan+PfizARArj3AJ0R1vNtlYhgMRdpQlCKEmvjvQcoKACfel0/
-AM8Sq1TAOTZGRor158Mzb2Y=
-=dcUQ
------END PGP SIGNATURE-----
diff --git a/net-print/mtink/files/digest-mtink-1.0.11 b/net-print/mtink/files/digest-mtink-1.0.11
new file mode 100644
index 000000000000..ea97fbfc1bd6
--- /dev/null
+++ b/net-print/mtink/files/digest-mtink-1.0.11
@@ -0,0 +1 @@
+MD5 f4778fc42a90c5eef6ba46198db04972 mtink-1.0.11.tar.gz 905081
diff --git a/net-print/mtink/mtink-1.0.11.ebuild b/net-print/mtink/mtink-1.0.11.ebuild
new file mode 100644
index 000000000000..68d09c110e95
--- /dev/null
+++ b/net-print/mtink/mtink-1.0.11.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/mtink/mtink-1.0.11.ebuild,v 1.1 2006/01/24 19:50:49 genstef Exp $
+
+inherit eutils
+
+DESCRIPTION="mtink is a status monitor and inkjet cartridge changer for some Epson printers"
+HOMEPAGE="http://xwtools.automatix.de/"
+SRC_URI="http://xwtools.automatix.de/files/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="cups doc X"
+
+DEPEND="X? (
+ || (
+ ( x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt )
+ virtual/x11
+ )
+ )
+ cups? ( net-print/cups )
+ dev-libs/libusb"
+
+src_compile() {
+ local mytargets
+ mytargets="ttink detect/askPrinter mtinkd"
+ if use X;
+ then
+ mytargets="${mytargets} mtink mtinkc";
+ fi
+ make ${mytargets} || die "Compile problem"
+}
+
+src_install() {
+ exeinto /usr/bin
+ if use X; then
+ doexe mtinkc mtink ttink detect/askPrinter
+ else
+ doexe ttink detect/askPrinter
+ fi
+ exeinto /usr/sbin
+ doexe mtinkd
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/mtinkd.rc mtinkd
+ insinto /etc/conf.d
+ newins ${FILESDIR}/mtinkd.confd mtinkd
+
+ use cups && \
+ exeinto /usr/lib/cups/backend; \
+ doexe etc/mtink-cups
+
+ dodoc README CHANGE.LOG LICENCE
+ use doc && {
+ dohtml html/*.gif html/*.html
+ }
+}
+
+pkg_postinst() {
+ # see #70310
+ chmod 700 /var/mtink /var/run/mtink 2>/dev/null
+
+ einfo
+ einfo "mtink needs correct permissions to access printer device."
+ einfo "To do this you either need to run the following chmod command:"
+ einfo "chmod 666 /dev/<device>"
+ einfo "or set the suid bit on mtink, mtinkc and ttink in /usr/bin"
+ einfo
+}