summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-12-10 14:10:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-12-10 14:10:53 +0000
commitabaf9f409ed6167e4d36c5735da6da21a4afb60a (patch)
tree43a223e290995f74b84ac43a3bdeff49ea26d414 /net-print
parentBased on 3.1.4 + genpatches-3.1-6 + grsecurity-2.2.2-3.1.4-201112082139 (diff)
downloadgentoo-2-abaf9f409ed6167e4d36c5735da6da21a4afb60a.tar.gz
gentoo-2-abaf9f409ed6167e4d36c5735da6da21a4afb60a.tar.bz2
gentoo-2-abaf9f409ed6167e4d36c5735da6da21a4afb60a.zip
Fix compability with fltk-1.3.0 wrt #351894 by Peter Ruskin and Yury Fedorchenko
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/xpp/ChangeLog9
-rw-r--r--net-print/xpp/files/xpp-fltk-1.3.0.patch44
-rw-r--r--net-print/xpp/xpp-1.5-r1.ebuild49
3 files changed, 101 insertions, 1 deletions
diff --git a/net-print/xpp/ChangeLog b/net-print/xpp/ChangeLog
index b70dfc8256f2..df10baa062f2 100644
--- a/net-print/xpp/ChangeLog
+++ b/net-print/xpp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-print/xpp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/xpp/ChangeLog,v 1.23 2011/06/02 19:14:36 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/xpp/ChangeLog,v 1.24 2011/12/10 14:10:53 ssuominen Exp $
+
+*xpp-1.5-r1 (10 Dec 2011)
+
+ 10 Dec 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +files/xpp-fltk-1.3.0.patch, +xpp-1.5-r1.ebuild:
+ Fix compability with fltk-1.3.0 wrt #351894 by Peter Ruskin and Yury
+ Fedorchenko
02 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org> xpp-1.5.ebuild:
Make build again, EAPI bump, no prestripped files (bug 252030)
diff --git a/net-print/xpp/files/xpp-fltk-1.3.0.patch b/net-print/xpp/files/xpp-fltk-1.3.0.patch
new file mode 100644
index 000000000000..8b921b8d17e7
--- /dev/null
+++ b/net-print/xpp/files/xpp-fltk-1.3.0.patch
@@ -0,0 +1,44 @@
+http://bugs.gentoo.org/351894
+
+--- mainwindow.fl
++++ mainwindow.fl
+@@ -70,7 +70,7 @@
+ fileList->value(print->filelist);
+ }}
+ private xywh {440 75 65 25} down_box DOWN_BOX shortcut 0x80062 align 16
+- code0 {\#include <FL/fl_file_chooser.H>}
++ code0 {\#include <FL/Fl_File_Chooser.H>}
+ code1 {\#include "xpp.h"}
+ }
+ Fl_Scroll printerList {
+--- xpp.cxx
++++ xpp.cxx
+@@ -2500,7 +2500,7 @@
+ // Redraw the destination menu in the main window
+
+ printerPack->parent()->redraw();
+- printerPack->draw();
++ ((Fl_Widget*)printerPack)->draw();
+
+ }
+
+@@ -2674,7 +2674,7 @@
+ // Redraw the destination menu in the main window
+
+ printerPack->parent()->redraw();
+- printerPack->draw();
++ ((Fl_Widget*)printerPack)->draw();
+
+ return(dest_index);
+ }
+--- xppmain.cxx
++++ xppmain.cxx
+@@ -32,7 +32,7 @@
+ */
+
+ #include "mainwindow.h"
+-#include <Fl/Fl_Shared_Image.h>
++#include <FL/Fl_Shared_Image.H>
+
+ /*
+ * 'main()' - Do all what xpp should do
diff --git a/net-print/xpp/xpp-1.5-r1.ebuild b/net-print/xpp/xpp-1.5-r1.ebuild
new file mode 100644
index 000000000000..abc4d3a29f15
--- /dev/null
+++ b/net-print/xpp/xpp-1.5-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/xpp/xpp-1.5-r1.ebuild,v 1.1 2011/12/10 14:10:53 ssuominen Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="X Printing Panel"
+SRC_URI="mirror://sourceforge/cups/${P}.tar.gz"
+HOMEPAGE="http://cups.sourceforge.net/xpp/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="net-print/cups
+ >=x11-libs/fltk-1.3.0:1
+ virtual/jpeg
+ media-libs/libpng:0
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/xpp-gcc4.patch \
+ "${FILESDIR}"/xpp-glibc-2.10.patch \
+ "${FILESDIR}"/xpp-fltk-1.3.0.patch
+}
+
+src_configure() {
+ tc-export CXX
+ export LDFLAGS="-L/usr/lib/fltk-1 -lfltk"
+ export CPPFLAGS="-I/usr/include/fltk-1"
+
+ STRIP="$(type -P true)" econf
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ einstall
+ dodoc ChangeLog README
+}