summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-02-18 02:27:25 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-02-18 02:27:25 +0000
commit2620c03a4c677a99a45fe122dc0d5b19d8a6b850 (patch)
tree525c9037ee5e9f6150b0e3883ff9a174f20578cc /net-proxy/c-icap
parentBump for security bug #355333. (diff)
downloadgentoo-2-2620c03a4c677a99a45fe122dc0d5b19d8a6b850.tar.gz
gentoo-2-2620c03a4c677a99a45fe122dc0d5b19d8a6b850.tar.bz2
gentoo-2-2620c03a4c677a99a45fe122dc0d5b19d8a6b850.zip
Version bump; add a logrotate file so that logs don't fill in your disk.
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy/c-icap')
-rw-r--r--net-proxy/c-icap/ChangeLog10
-rw-r--r--net-proxy/c-icap/c-icap-0.1.4.ebuild105
-rw-r--r--net-proxy/c-icap/files/c-icap.logrotate13
3 files changed, 126 insertions, 2 deletions
diff --git a/net-proxy/c-icap/ChangeLog b/net-proxy/c-icap/ChangeLog
index 90669b5e90e6..23a1ca6c076a 100644
--- a/net-proxy/c-icap/ChangeLog
+++ b/net-proxy/c-icap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/c-icap
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/c-icap/ChangeLog,v 1.3 2010/12/26 16:35:39 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/c-icap/ChangeLog,v 1.4 2011/02/18 02:27:22 flameeyes Exp $
+
+*c-icap-0.1.4 (18 Feb 2011)
+
+ 18 Feb 2011; Diego E. Pettenò <flameeyes@gentoo.org> +c-icap-0.1.4.ebuild,
+ +files/c-icap.logrotate:
+ Version bump; add a logrotate file so that logs don't fill in your disk.
26 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org> c-icap-0.1.3.ebuild,
+files/c-icap-0.1.3+db-5.0.patch:
diff --git a/net-proxy/c-icap/c-icap-0.1.4.ebuild b/net-proxy/c-icap/c-icap-0.1.4.ebuild
new file mode 100644
index 000000000000..30115585f012
--- /dev/null
+++ b/net-proxy/c-icap/c-icap-0.1.4.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/c-icap/c-icap-0.1.4.ebuild,v 1.1 2011/02/18 02:27:22 flameeyes Exp $
+
+EAPI=2
+
+inherit eutils multilib autotools
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="C Implementation of an ICAP server"
+HOMEPAGE="http://c-icap.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="berkdb ldap ipv6 ldap"
+
+RDEPEND="berkdb? ( sys-libs/db )
+ ldap? ( net-nds/openldap )
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.1.3-asneeded.patch"
+ epatch "${FILESDIR}/${PN}-0.1.3-implicit.patch"
+ epatch "${FILESDIR}/${PN}-0.1.3+db-5.0.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/${PN} \
+ --disable-dependency-tracking \
+ --disable-maintainer-mode \
+ --disable-static \
+ --enable-large-files \
+ $(use_enable ipv6) \
+ $(use_with berkdb bdb) \
+ $(use_with ldap)
+}
+
+src_compile() {
+ emake LOGDIR="/var/log" || die
+}
+
+src_install() {
+ emake \
+ LOGDIR="/var/log" \
+ DESTDIR="${D}" install || die
+
+ find "${D}" -name '*.la' -delete || die
+
+ # Move the daemon out of the way
+ dodir /usr/libexec
+ mv "${D}"/usr/bin/c-icap "${D}"/usr/libexec || die
+
+ # Remove the default configuration files since we have etc-update to
+ # take care of it for us.
+ rm "${D}"/etc/${PN}/c-icap.*.default || die
+
+ # Fix the configuration file; for some reason it's a bit messy
+ # around.
+ sed -i \
+ -e 's:/usr/var/:/var/:g' \
+ -e 's:/var/log/:/var/log/c-icap/:g' \
+ -e 's:/usr/etc/:/etc/c-icap/:g' \
+ -e 's:/usr/local/c-icap/etc/:/etc/c-icap/:g' \
+ -e 's:/usr/lib/:/usr/'$(get_libdir)'/:g' \
+ "${D}"/etc/${PN}/c-icap.conf \
+ || die
+
+ dodoc AUTHORS README TODO ChangeLog || die
+
+ newinitd "${FILESDIR}/${PN}.init" ${PN} || die
+ keepdir /var/log/c-icap || die
+
+ insopts -m0644
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+}
+
+pkg_postinst() {
+ elog "To enable Squid to call the ICAP modules from a local server you should set"
+ elog "the following in your squid.conf:"
+ elog ""
+ elog " icap_enable on"
+ elog ""
+ elog " # not strictly needed, but some modules might make use of these"
+ elog " icap_send_client_ip on"
+ elog " icap_send_client_username on"
+ elog ""
+ elog " icap_service service_req reqmod_precache bypass=1 icap://localhost:1344/service"
+ elog " adaptation_access service_req allow all"
+ elog ""
+ elog " icap_service service_resp respmod_precache bypass=0 icap://localhost:1344/service"
+ elog " adaptation_access service_resp allow all"
+ elog ""
+ elog "You obviously will have to replace \"service\" with the actual ICAP service to"
+ elog "use."
+}
diff --git a/net-proxy/c-icap/files/c-icap.logrotate b/net-proxy/c-icap/files/c-icap.logrotate
new file mode 100644
index 000000000000..c4c0a5d34f6e
--- /dev/null
+++ b/net-proxy/c-icap/files/c-icap.logrotate
@@ -0,0 +1,13 @@
+/var/log/c-icap/access.log {
+ missingok
+ postrotate
+ /etc/init.d/c-icap restart
+ endscript
+}
+
+/var/log/cicap-server.log {
+ missingok
+ postrotate
+ /etc/init.d/c-icap restart
+ endscript
+}