summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-08-29 06:43:12 +0000
committerAlin Năstac <mrness@gentoo.org>2005-08-29 06:43:12 +0000
commit48b4839449345e6105374aeec863c4bf7d641a46 (patch)
tree766e523a239d67aa189e5e028a74e798bacdf892 /net-proxy/dansguardian/dansguardian-2.8.0.6.ebuild
parentstable for x86; tidy (diff)
downloadgentoo-2-48b4839449345e6105374aeec863c4bf7d641a46.tar.gz
gentoo-2-48b4839449345e6105374aeec863c4bf7d641a46.tar.bz2
gentoo-2-48b4839449345e6105374aeec863c4bf7d641a46.zip
version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-proxy/dansguardian/dansguardian-2.8.0.6.ebuild')
-rw-r--r--net-proxy/dansguardian/dansguardian-2.8.0.6.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-proxy/dansguardian/dansguardian-2.8.0.6.ebuild b/net-proxy/dansguardian/dansguardian-2.8.0.6.ebuild
new file mode 100644
index 000000000000..26c4e6af1d62
--- /dev/null
+++ b/net-proxy/dansguardian/dansguardian-2.8.0.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/dansguardian/dansguardian-2.8.0.6.ebuild,v 1.1 2005/08/29 06:43:12 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="Web content filtering via proxy"
+HOMEPAGE="http://dansguardian.org"
+SRC_URI="http://mirror.dansguardian.org/downloads/2/Stable/${P}.source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND="!net-proxy/dansguardian-dgav
+ virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/dansguardian-xnaughty-2.7.6-1.diff
+}
+
+src_compile() {
+ ./configure \
+ --prefix= \
+ --installprefix=${D} \
+ --mandir=/usr/share/man/ \
+ --cgidir=/var/www/localhost/cgi-bin/ || die "./configure failed"
+ emake OPTIMISE="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ if [ -d "/etc/logrotate.d" ]; then
+ dodir /etc/logrotate.d
+ fi
+ make install || die "make install failed"
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dansguardian.init dansguardian
+
+ rm -rf ${D}/etc/rc.d
+
+ #Fixing location of initscript
+ sed -i -e 's/rc.d\///' ${D}/etc/dansguardian/logrotation
+
+ dodoc INSTALL README LICENSE
+}