summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-03-04 12:41:03 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-03-04 12:41:03 +0000
commit6c2216883e21f0cf09b2c79c5c4f47c749417a6a (patch)
tree5593ec03f0a91963eca5b3ec9d652085188d860a /net-proxy/dante
parentStable for HPPA (bug #459452). (diff)
downloadgentoo-2-6c2216883e21f0cf09b2c79c5c4f47c749417a6a.tar.gz
gentoo-2-6c2216883e21f0cf09b2c79c5c4f47c749417a6a.tar.bz2
gentoo-2-6c2216883e21f0cf09b2c79c5c4f47c749417a6a.zip
Version bump to 1.4.0_pre1.
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'net-proxy/dante')
-rw-r--r--net-proxy/dante/ChangeLog9
-rw-r--r--net-proxy/dante/dante-1.4.0_pre1.ebuild80
2 files changed, 87 insertions, 2 deletions
diff --git a/net-proxy/dante/ChangeLog b/net-proxy/dante/ChangeLog
index b716e9036b73..66654bb25fd7 100644
--- a/net-proxy/dante/ChangeLog
+++ b/net-proxy/dante/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-proxy/dante
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/dante/ChangeLog,v 1.64 2012/04/26 16:53:40 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/dante/ChangeLog,v 1.65 2013/03/04 12:41:03 tomwij Exp $
+
+*dante-1.4.0_pre1 (04 Mar 2013)
+
+ 04 Mar 2013; Tom Wijsman <TomWij@gentoo.org> +dante-1.4.0_pre1.ebuild:
+ Version bump to 1.4.0_pre1.
26 Apr 2012; Alexis Ballier <aballier@gentoo.org> dante-1.3.2.ebuild:
keyword ~amd64-fbsd
diff --git a/net-proxy/dante/dante-1.4.0_pre1.ebuild b/net-proxy/dante/dante-1.4.0_pre1.ebuild
new file mode 100644
index 000000000000..dd003b6f1dd9
--- /dev/null
+++ b/net-proxy/dante/dante-1.4.0_pre1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/dante/dante-1.4.0_pre1.ebuild,v 1.1 2013/03/04 12:41:03 tomwij Exp $
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="A free socks4,5 and msproxy implementation"
+HOMEPAGE="http://www.inet.no/dante/"
+MY_P="${P/_/-}"
+SRC_URI="ftp://ftp.inet.no/pub/socks/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug kerberos pam selinux static-libs tcpd"
+
+RDEPEND="pam? ( virtual/pam )
+ kerberos? ( virtual/krb5 )
+ selinux? ( sec-policy/selinux-dante )
+ tcpd? ( sys-apps/tcp-wrappers )
+ userland_GNU? ( virtual/shadow )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+DOCS="BUGS CREDITS NEWS README SUPPORT doc/README* doc/*.txt doc/SOCKS4.protocol"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.3.0-socksify.patch
+
+ sed -i \
+ -e 's:/etc/socks\.conf:"${EPREFIX}"/etc/socks/socks.conf:' \
+ -e 's:/etc/sockd\.conf:"${EPREFIX}"/etc/socks/sockd.conf:' \
+ doc/{socksify.1,socks.conf.5,sockd.conf.5,sockd.8} \
+ || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-socks-conf="${EPREFIX}"/etc/socks/socks.conf \
+ --with-sockd-conf="${EPREFIX}"/etc/socks/sockd.conf \
+ --without-upnp \
+ $(use_enable debug) \
+ $(use_with kerberos gssapi) \
+ $(use_with pam) \
+ $(use_enable static-libs static) \
+ $(use_enable tcpd libwrap)
+}
+
+src_install() {
+ default
+
+ # default configuration files
+ insinto /etc/socks
+ doins "${FILESDIR}"/sock?.conf
+ pushd "${ED}/etc/socks" > /dev/null
+ use pam && epatch "${FILESDIR}/sockd.conf-with-pam.patch"
+ use tcpd && epatch "${FILESDIR}/sockd.conf-with-libwrap.patch"
+ popd > /dev/null
+
+ # init script
+ newinitd "${FILESDIR}/dante-sockd-init" dante-sockd
+ newconfd "${FILESDIR}/dante-sockd-conf" dante-sockd
+
+ # example configuration files
+ docinto examples
+ dodoc example/*.conf
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm '{}' +
+}
+
+pkg_postinst() {
+ enewuser sockd -1 -1 /etc/socks daemon
+}