summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-08-15 22:59:49 +0000
committerAlin Năstac <mrness@gentoo.org>2009-08-15 22:59:49 +0000
commitb9e5b3a514803d1dcd8bac445410158f78ac22b7 (patch)
tree1d192c8cabd55791f370041832d21b1319f9b0f4 /net-proxy/haproxy
parentRemove old ebuild. (diff)
downloadgentoo-2-b9e5b3a514803d1dcd8bac445410158f78ac22b7.tar.gz
gentoo-2-b9e5b3a514803d1dcd8bac445410158f78ac22b7.tar.bz2
gentoo-2-b9e5b3a514803d1dcd8bac445410158f78ac22b7.zip
Version bump (#280971).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy/haproxy')
-rw-r--r--net-proxy/haproxy/ChangeLog7
-rw-r--r--net-proxy/haproxy/haproxy-1.3.20.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/net-proxy/haproxy/ChangeLog b/net-proxy/haproxy/ChangeLog
index 9d248f30a541..b35f5d446608 100644
--- a/net-proxy/haproxy/ChangeLog
+++ b/net-proxy/haproxy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-proxy/haproxy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.29 2009/08/08 09:41:21 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.30 2009/08/15 22:59:49 mrness Exp $
+
+*haproxy-1.3.20 (15 Aug 2009)
+
+ 15 Aug 2009; Alin Năstac <mrness@gentoo.org> +haproxy-1.3.20.ebuild:
+ Version bump (#280971).
*haproxy-1.3.19 (08 Aug 2009)
*haproxy-1.3.15.10 (08 Aug 2009)
diff --git a/net-proxy/haproxy/haproxy-1.3.20.ebuild b/net-proxy/haproxy/haproxy-1.3.20.ebuild
new file mode 100644
index 000000000000..2cd9c2c2fa44
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.3.20.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.20.ebuild,v 1.1 2009/08/15 22:59:49 mrness Exp $
+
+inherit versionator eutils
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="pcre"
+
+DEPEND="pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup haproxy
+ enewuser haproxy -1 -1 -1 haproxy
+}
+
+src_compile() {
+ local ARGS="TARGET=linux26"
+ use pcre && ARGS="${ARGS} USE_PCRE=1"
+ emake ADDINC="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${ARGS}
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe haproxy
+ newinitd "${FILESDIR}/haproxy.initd" haproxy
+
+ # Don't install useless files
+ rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/*.txt
+ docinto examples
+ dodoc examples/*.cfg
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ ewarn "You need to create /etc/haproxy.cfg before you start the haproxy service."
+ ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
+ ewarn "Make use of them with the \"user\" and \"group\" directives."
+
+ if [[ -d "${ROOT}/usr/share/doc/${PF}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${PF}"
+ fi
+ fi
+}