summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-11-04 01:49:32 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-11-04 01:49:32 +0000
commit29e7d35e5a3c430cc62f4f498f3a64831b42f1ba (patch)
treeb29e8d89bf1f694596998361a37dedabbf7f9cbd /net-proxy/torsocks/torsocks-1.2.ebuild
parentVersion bump (diff)
downloadgentoo-2-29e7d35e5a3c430cc62f4f498f3a64831b42f1ba.tar.gz
gentoo-2-29e7d35e5a3c430cc62f4f498f3a64831b42f1ba.tar.bz2
gentoo-2-29e7d35e5a3c430cc62f4f498f3a64831b42f1ba.zip
Version bump
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy/torsocks/torsocks-1.2.ebuild')
-rw-r--r--net-proxy/torsocks/torsocks-1.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-proxy/torsocks/torsocks-1.2.ebuild b/net-proxy/torsocks/torsocks-1.2.ebuild
new file mode 100644
index 000000000000..277e29161a7b
--- /dev/null
+++ b/net-proxy/torsocks/torsocks-1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/torsocks/torsocks-1.2.ebuild,v 1.1 2011/11/04 01:49:32 blueness Exp $
+
+EAPI=4
+
+inherit multilib
+
+DESCRIPTION="Use most socks-friendly applications with Tor."
+HOMEPAGE="http://code.google.com/p/torsocks"
+SRC_URI="http://${PN}.googlecode.com/files/${PN}-1.2.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+# We do not depend on tor which might be running on a different box
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ #Remove libtool .la files
+ cd "${D}"/usr/$(get_libdir)/torsocks
+ rm -f *.la
+}