summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2006-07-04 17:33:10 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2006-07-04 17:33:10 +0000
commit62d5c40fdc9ee01be4bba79b652beef223159caf (patch)
tree436fb932eb346eebe7e3db71272457b7a5bd9065 /net-proxy/ziproxy
parent* bump (diff)
downloadgentoo-2-62d5c40fdc9ee01be4bba79b652beef223159caf.tar.gz
gentoo-2-62d5c40fdc9ee01be4bba79b652beef223159caf.tar.bz2
gentoo-2-62d5c40fdc9ee01be4bba79b652beef223159caf.zip
version bump, solving bug #139135.
(Portage version: 2.1.1_pre2-r1)
Diffstat (limited to 'net-proxy/ziproxy')
-rw-r--r--net-proxy/ziproxy/ChangeLog8
-rw-r--r--net-proxy/ziproxy/files/digest-ziproxy-2.0.03
-rw-r--r--net-proxy/ziproxy/files/ziproxy-2.0.confd12
-rw-r--r--net-proxy/ziproxy/files/ziproxy-2.0.initd26
-rw-r--r--net-proxy/ziproxy/ziproxy-2.0.0.ebuild71
5 files changed, 119 insertions, 1 deletions
diff --git a/net-proxy/ziproxy/ChangeLog b/net-proxy/ziproxy/ChangeLog
index bce2817c0121..16dfedcf0270 100644
--- a/net-proxy/ziproxy/ChangeLog
+++ b/net-proxy/ziproxy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/ziproxy
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/ziproxy/ChangeLog,v 1.4 2006/03/06 22:58:33 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ziproxy/ChangeLog,v 1.5 2006/07/04 17:33:10 sbriesen Exp $
+
+*ziproxy-2.0.0 (04 Jul 2006)
+
+ 04 Jul 2006; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/ziproxy-2.0.confd, +files/ziproxy-2.0.initd, +ziproxy-2.0.0.ebuild:
+ version bump, solving bug #139135.
06 Mar 2006; Alin Nastac <mrness@gentoo.org> -ziproxy-1.5.1.ebuild:
Remove old version.
diff --git a/net-proxy/ziproxy/files/digest-ziproxy-2.0.0 b/net-proxy/ziproxy/files/digest-ziproxy-2.0.0
new file mode 100644
index 000000000000..987441af98a7
--- /dev/null
+++ b/net-proxy/ziproxy/files/digest-ziproxy-2.0.0
@@ -0,0 +1,3 @@
+MD5 de9c66860b0f56e940eb92f0a7c867c9 ziproxy-2.0.0.tar.bz2 124371
+RMD160 bf9e5b7c500f7c12328e690830f45dcc0cc1169a ziproxy-2.0.0.tar.bz2 124371
+SHA256 9c3d755bd8e384185c3715c32eaf17d49825dc4e23cc99fcc94270c77d7b22a3 ziproxy-2.0.0.tar.bz2 124371
diff --git a/net-proxy/ziproxy/files/ziproxy-2.0.confd b/net-proxy/ziproxy/files/ziproxy-2.0.confd
new file mode 100644
index 000000000000..73417ca560c0
--- /dev/null
+++ b/net-proxy/ziproxy/files/ziproxy-2.0.confd
@@ -0,0 +1,12 @@
+# configuraton file for /etc/init.d/ziproxy
+
+# Full path to ziproxy.conf file (instead of default one).
+#
+#CONFIG="/etc/ziproxy.conf"
+
+# Limit incoming connections only from the specified address(es).
+# This option has the same meaning, but higher precedence as
+# "OnlyFrom=" option in configuration file. Uncomment it
+# if you want to set it.
+#
+#ONLYFROM="<IP.address or hostname>"
diff --git a/net-proxy/ziproxy/files/ziproxy-2.0.initd b/net-proxy/ziproxy/files/ziproxy-2.0.initd
new file mode 100644
index 000000000000..2a82e14eb78b
--- /dev/null
+++ b/net-proxy/ziproxy/files/ziproxy-2.0.initd
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ziproxy/files/ziproxy-2.0.initd,v 1.1 2006/07/04 17:33:10 sbriesen Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ local OPT="-d"
+ ebegin "Starting ziproxy"
+
+ [ -n "${CONFIG}" ] && OPT="${OPT} -c ${CONFIG}"
+ [ -n "${ONLYFROM}" ] && OPT="${OPT} -f ${ONLYFROM}"
+
+ start-stop-daemon --quiet --start --pidfile /var/run/ziproxy.pid \
+ --chuid ziproxy:ziproxy --exec /usr/bin/ziproxy -- ${OPT} > /var/run/ziproxy.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ziproxy"
+ start-stop-daemon --stop --quiet --pidfile /var/run/ziproxy.pid
+ eend $?
+}
diff --git a/net-proxy/ziproxy/ziproxy-2.0.0.ebuild b/net-proxy/ziproxy/ziproxy-2.0.0.ebuild
new file mode 100644
index 000000000000..1801a0a549e7
--- /dev/null
+++ b/net-proxy/ziproxy/ziproxy-2.0.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/ziproxy/ziproxy-2.0.0.ebuild,v 1.1 2006/07/04 17:33:10 sbriesen Exp $
+
+inherit eutils
+
+DESCRIPTION="A forwarding, non-caching, compressing web proxy server"
+HOMEPAGE="http://ziproxy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="jpeg2k xinetd"
+
+DEPEND="dev-libs/confuse
+ media-libs/giflib
+ media-libs/libpng
+ media-libs/jpeg
+ sys-libs/zlib
+ jpeg2k? ( media-libs/jasper )
+ xinetd? ( virtual/inetd )"
+
+
+pkg_setup() {
+ enewgroup ziproxy
+ enewuser ziproxy -1 -1 -1 ziproxy
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix sample config file
+ sed -i -e "s:/usr/local/ziproxy/\(ziproxy.passwd\):/etc/\1:g" \
+ -e "s:/var/ziproxy/:/var/lib/ziproxy/:g" etc/ziproxy.conf
+
+ # fix sample xintd config
+ sed -i -e "s:root:ziproxy:g" etc/xinetd.d/ziproxy
+}
+
+src_compile() {
+ local myconf="--enable-shared-confuse --with-cfgfile=/etc/ziproxy.conf" # --enable-testprogs
+ use jpeg2k && myconf="${myconf} --with-jasper" # use_with doesn't work
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog CREDITS README stats.awk
+ use jpeg2k && dodoc JPEG2000.txt
+
+ insinto /etc
+ doins etc/ziproxy.conf
+
+ insinto /var/lib/ziproxy/error
+ doins var/ziproxy/error/*.html
+
+ if use xinetd; then
+ insinto /etc/xinetd.d
+ doins etc/xinetd.d/ziproxy
+ else
+ newinitd "${FILESDIR}/${PN}-${PV%.*}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}-${PV%.*}.confd" ${PN}
+ fi
+
+ diropts -m0750 -o ziproxy -g ziproxy
+ keepdir /var/log/ziproxy
+}