summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-04-14 12:34:30 +0000
committerAlin Năstac <mrness@gentoo.org>2006-04-14 12:34:30 +0000
commit6b18814ae2387bbb1e2b380728157e4df40011ae (patch)
tree108f1a573a5c864ae2be91e0a45ce5225475ccb3 /net-proxy
parentAdded unsquashfs to dobin and closing bug #129875. (diff)
downloadgentoo-2-6b18814ae2387bbb1e2b380728157e4df40011ae.tar.gz
gentoo-2-6b18814ae2387bbb1e2b380728157e4df40011ae.tar.bz2
gentoo-2-6b18814ae2387bbb1e2b380728157e4df40011ae.zip
Version bump. Add gnutls and zlib USE flags.
(Portage version: 2.0.54)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/wwwoffle/ChangeLog7
-rw-r--r--net-proxy/wwwoffle/Manifest12
-rw-r--r--net-proxy/wwwoffle/files/digest-wwwoffle-2.91
-rw-r--r--net-proxy/wwwoffle/wwwoffle-2.9.ebuild158
4 files changed, 167 insertions, 11 deletions
diff --git a/net-proxy/wwwoffle/ChangeLog b/net-proxy/wwwoffle/ChangeLog
index ee7bbdc38b9e..c95a3bc11316 100644
--- a/net-proxy/wwwoffle/ChangeLog
+++ b/net-proxy/wwwoffle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-proxy/wwwoffle
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/ChangeLog,v 1.8 2006/03/06 22:54:55 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/ChangeLog,v 1.9 2006/04/14 12:34:30 mrness Exp $
+
+*wwwoffle-2.9 (14 Apr 2006)
+
+ 14 Apr 2006; Alin Nastac <mrness@gentoo.org> +wwwoffle-2.9.ebuild:
+ Version bump. Add gnutls and zlib USE flags.
06 Mar 2006; Alin Nastac <mrness@gentoo.org> -files/wwwoffled-online-2.8b,
-files/wwwoffled, -wwwoffle-2.8b.ebuild, wwwoffle-2.8e.ebuild:
diff --git a/net-proxy/wwwoffle/Manifest b/net-proxy/wwwoffle/Manifest
index 467f035ca008..a5d3454fc942 100644
--- a/net-proxy/wwwoffle/Manifest
+++ b/net-proxy/wwwoffle/Manifest
@@ -1,17 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 d1eba39850476671b45ccfbf0d95bda0 ChangeLog 7137
MD5 a627d44111b7ff1d162ac248f5c35376 files/digest-wwwoffle-2.8e 63
+MD5 cebdf87d07b34aa39e54896936f18eab files/digest-wwwoffle-2.9 62
MD5 848cabe3390aa24c7aea9d08c8d1d937 files/wwwoffle-online.confd 426
MD5 f710c01ec4b28de6014c40ee7f4f6046 files/wwwoffle-online.initd 696
MD5 9976f6cc21d8fd01b67cb72fc7cf3198 files/wwwoffle.initd 539
MD5 2f092f7d958b226c98713d29cff08f9d metadata.xml 502
MD5 b32055c6ea5422b6186b09203a4315e2 wwwoffle-2.8e.ebuild 5140
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2.1 (GNU/Linux)
-
-iD8DBQFEDL3PjG8pv1lIUX4RAsQtAKDqpwVhGonB/D63tx4LHxnD607rdgCg4RvE
-qumt9Tw3phNO4I89eoKtJhs=
-=091c
------END PGP SIGNATURE-----
+MD5 2e4a6aea8d537d2b146769c1197d6187 wwwoffle-2.9.ebuild 5141
diff --git a/net-proxy/wwwoffle/files/digest-wwwoffle-2.9 b/net-proxy/wwwoffle/files/digest-wwwoffle-2.9
new file mode 100644
index 000000000000..fb4123c27354
--- /dev/null
+++ b/net-proxy/wwwoffle/files/digest-wwwoffle-2.9
@@ -0,0 +1 @@
+MD5 e8e7f3bdf1ff0a9baa26e5aebd6ad396 wwwoffle-2.9.tgz 1074108
diff --git a/net-proxy/wwwoffle/wwwoffle-2.9.ebuild b/net-proxy/wwwoffle/wwwoffle-2.9.ebuild
new file mode 100644
index 000000000000..9f5aaf23a63a
--- /dev/null
+++ b/net-proxy/wwwoffle/wwwoffle-2.9.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/wwwoffle/wwwoffle-2.9.ebuild,v 1.1 2006/04/14 12:34:30 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="wwwoffle = WWW Offline Explorer, an adv. caching proxy especially suitable for nonpermanent (e.g. dialup) Internet connections"
+SRC_URI="http://www.gedanken.freeserve.co.uk/download-wwwoffle/${P}.tgz"
+HOMEPAGE="http://www.gedanken.demon.co.uk/wwwoffle"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="gnutls ipv6 zlib"
+
+RDEPEND="gnutls? ( net-libs/gnutls )
+ zlib? ( sys-libs/zlib )"
+DEPEND="dev-lang/perl
+ sys-devel/flex
+ ${RDEPEND}"
+
+# Unsure whether to depend on >=www-misc/htdig-3.1.6-r4 or not
+
+pkg_setup() {
+ # Add a wwwoffle user
+ enewgroup wwwoffle
+ enewuser wwwoffle -1 -1 /var/spool/wwwoffle wwwoffle
+}
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e 's#$(TAR) xpf #$(TAR) --no-same-owner -xpf #' \
+ "${S}/cache/Makefile.in"
+}
+
+src_compile() {
+ # TODO confdir back to default /etc/wwwoffle
+ # allows to change config file using web interface.
+
+ econf $(use_with ipv6) || die "econf failed"
+ emake || die "emake failed"
+
+ if [ -f "${ROOT}/etc/wwwoffle.conf" ] ; then
+ einfo "Upgrading current configuration file"
+ cp "${ROOT}/etc/wwwoffle.conf" conf/wwwoffle.conf
+ conf/upgrade-config.pl conf/wwwoffle.conf
+
+ # Hack to stop regeneration of config file
+ touch conf/conf-file
+
+ einfo "Changing the default user (and group) to wwwoffle"
+ sed -i -e 's/\(run-[gu]id\)[ \t]*=[ \t]*[a-zA-Z0-9]*[ \t]*$/\1 = wwwoffle/g' \
+ conf/wwwoffle.conf
+ else
+ einfo "Changing the default user (and group) to wwwoffle"
+ sed -i -e 's/#\(run-[gu]id\)[ \t]*=[ \t]*[a-zA-Z0-9]*[ \t]*$/\1 = wwwoffle/g' \
+ conf/wwwoffle.conf.template
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # documentation fix
+ # del empty doc dirs
+ rmdir "${D}/usr/doc/${PN}"/{it,nl,ru}
+ dodir /usr/share/doc
+ mv "${D}/usr/doc/wwwoffle" "${D}/usr/share/doc/${PF}"
+
+ #Updated configuration file
+ #if [ -f "${ROOT}/etc/wwwoffle.conf" ]; then
+ # mv "${D}/etc/wwwoffle.conf" "${D}/etc/wwwoffle.conf.updated"
+ #fi
+
+ # install the wwwoffled init script
+ newinitd "${FILESDIR}/${PN}.initd" wwwoffled
+ newinitd "${FILESDIR}/${PN}-online.initd" wwwoffled-online
+ newconfd "${FILESDIR}/${PN}-online.confd" wwwoffled-online
+
+ keepdir /var/spool/wwwoffle/{http,outgoing,monitor,lasttime,lastout,local}
+ for number in 1 2 3 4 5 6 7 8 9; do
+ keepdir "/var/spool/wwwoffle/prevtime${number}" "/var/spool/wwwoffle/prevout${number}"
+ done
+
+ # empty dirs are removed during update
+ keepdir \
+ /var/spool/wwwoffle/search/{mnogosearch/db,htdig/tmp,htdig/db-lasttime,htdig/db,namazu/db}
+
+ touch \
+ "${D}/var/spool/wwwoffle/search/htdig/wwwoffle-htdig.log" \
+ "${D}/var/spool/wwwoffle/search/mnogosearch/wwwoffle-mnogosearch.log" \
+ "${D}/var/spool/wwwoffle/search/namazu/wwwoffle-namazu.log"
+
+ chown -R wwwoffle:wwwoffle "${D}/var/spool/wwwoffle" "${D}/etc/wwwoffle"
+
+ # TODO htdig indexing as part of initscripts
+
+ # robots.txt modification - /var/spool/wwwoffle/html/en
+ # - remove Disallow: /index
+ sed -i -e "s|Disallow:.*/index|#Disallow: /index|" "${D}/var/spool/wwwoffle/html/en/robots.txt"
+
+ rmdir "${D}/usr/doc"
+ chmod -R o-w "${D}/var/spool/wwwoffle" #some file have w permission for world!
+}
+
+pkg_preinst() {
+ # Add a wwwoffle user - required here for binary packages
+ enewgroup wwwoffle
+ enewuser wwwoffle -1 -1 /var/spool/wwwoffle wwwoffle
+
+ # TODO maybe rootjail ${ROOT}
+ source /etc/init.d/functions.sh
+ if [ -L "${svcdir}/started/wwwoffled" ]; then
+ einfo "The wwwoffled init script is running. I'll stop it, merge the new files and
+ restart the script."
+ /etc/init.d/wwwoffled stop
+ # Just to be sure...
+ start-stop-daemon --stop --quiet --name wwwoffled
+ touch "${T}/stopped"
+ fi
+}
+
+pkg_postinst() {
+ # fix permissions for those upgrading
+
+ for number in 1 2 3 4 5 6 7 8 9;
+ do
+ [ ! -d "${ROOT}/var/spool/wwwoffle/prevtime${number}" ] && \
+ keepdir "${ROOT}/var/spool/wwwoffle/prevtime${number}"
+ [ ! -d "${ROOT}/var/spool/wwwoffle/prevout${number}" ] && \
+ keepdir "${ROOT}/var/spool/wwwoffle/prevout${number}"
+ done
+
+ chown -R wwwoffle:wwwoffle "${ROOT}/var/spool/wwwoffle" "${ROOT}/etc/wwwoffle"
+
+ # Need to sumbit patch upstream to allow this.
+ #fowners root:wwwoffle /var/spool/wwwoffle
+ #fowners wwwoffle:wwwoffle /var/spool/wwwoffle
+
+ [ -f "${T}/stopped" ] && \
+ ewarn "wwwoffled was stopped. /etc/init.d/wwwoffled start to restart AFTER etc-update"
+
+ einfo "wwwoffled should run as an ordinary user now. The run-uid and run-gid should be set"
+ einfo "to \"wwwoffle\" in your /etc/wwwoffle/wwwoffle.conf. Please uncomment this if it hasn't been already"
+
+ einfo "This is for your own security. Otherwise wwwoffle is run as root which is relay bad if"
+ einfo "there is an exploit in this program that allows remote/local users to execute arbitary"
+ einfo "commands as the root user."
+
+ if [ -f "${ROOT}/etc/wwwoffle.conf" ]; then
+ ewarn "Configuration file is /etc/wwwoffle/wwwoffle.conf now"
+ ewarn "Suggest you move ${ROOT}etc/wwwoffle.conf"
+ fi
+
+ # if htdig - run script for full database index
+ # TODO
+}