summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-01-26 17:56:50 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-01-26 17:56:50 +0000
commita89d0f6b0b636056bb1ec9c8cef1f89b1c28bb93 (patch)
treed862d991c8d6df2e1ca60612e7fe3416372eb54b /net-proxy
parentFix building against kernel 3.13, bug #498766. Import of Emil Karlson's ebuil... (diff)
downloadgentoo-2-a89d0f6b0b636056bb1ec9c8cef1f89b1c28bb93.tar.gz
gentoo-2-a89d0f6b0b636056bb1ec9c8cef1f89b1c28bb93.tar.bz2
gentoo-2-a89d0f6b0b636056bb1ec9c8cef1f89b1c28bb93.zip
Version bump, fix bug #493058
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/torsocks/ChangeLog10
-rw-r--r--net-proxy/torsocks/files/fix-find-libc.so.patch12
-rw-r--r--net-proxy/torsocks/torsocks-2.0.0_rc3.ebuild44
3 files changed, 64 insertions, 2 deletions
diff --git a/net-proxy/torsocks/ChangeLog b/net-proxy/torsocks/ChangeLog
index 095010d85587..1ffd1045c949 100644
--- a/net-proxy/torsocks/ChangeLog
+++ b/net-proxy/torsocks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/torsocks
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/torsocks/ChangeLog,v 1.13 2013/09/17 19:12:35 blueness Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/torsocks/ChangeLog,v 1.14 2014/01/26 17:56:50 blueness Exp $
+
+*torsocks-2.0.0_rc3 (26 Jan 2014)
+
+ 26 Jan 2014; Anthony G. Basile <blueness@gentoo.org>
+ +files/fix-find-libc.so.patch, +torsocks-2.0.0_rc3.ebuild:
+ Version bump, fix bug #493058
17 Sep 2013; Anthony G. Basile <blueness@gentoo.org>
torsocks-2.0.0_rc2.ebuild:
diff --git a/net-proxy/torsocks/files/fix-find-libc.so.patch b/net-proxy/torsocks/files/fix-find-libc.so.patch
new file mode 100644
index 000000000000..0fb1949116e1
--- /dev/null
+++ b/net-proxy/torsocks/files/fix-find-libc.so.patch
@@ -0,0 +1,12 @@
+diff -Nuar torsocks-2.0.0-rc3.orig/configure.ac torsocks-2.0.0-rc3/configure.ac
+--- torsocks-2.0.0-rc3.orig/configure.ac 2013-11-03 13:24:51.000000000 -0500
++++ torsocks-2.0.0-rc3/configure.ac 2014-01-26 12:49:55.157606016 -0500
+@@ -132,7 +132,7 @@
+ dnl Get libc full system path. Use prefix or some hardcoded standard
+ dnl location on Unixish system.
+ AC_MSG_CHECKING(location of libc.so)
+-for DIR in "$prefix/lib" "$prefix/usr/lib" '/lib' '/usr/lib'; do
++for DIR in "$prefix/lib*" "$prefix/usr/lib*" '/lib*' '/usr/lib*'; do
+ if test "${LIBC_PATH}" = ""; then
+ LIBC_PATH=`$FIND $DIR -name "libc.so.?" 2>/dev/null | $TAIL -1`
+ fi
diff --git a/net-proxy/torsocks/torsocks-2.0.0_rc3.ebuild b/net-proxy/torsocks/torsocks-2.0.0_rc3.ebuild
new file mode 100644
index 000000000000..655c22bc3fb4
--- /dev/null
+++ b/net-proxy/torsocks/torsocks-2.0.0_rc3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/torsocks/torsocks-2.0.0_rc3.ebuild,v 1.1 2014/01/26 17:56:50 blueness Exp $
+
+EAPI="5"
+
+inherit autotools eutils multilib versionator
+
+MY_PV="$(replace_version_separator 3 -)"
+MY_PF="${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_PF}"
+
+DESCRIPTION="Use most socks-friendly applications with Tor."
+HOMEPAGE="http://github.com/dgoulet/torsocks"
+SRC_URI="https://github.com/dgoulet/torsocks/archive/v${MY_PV}.tar.gz -> ${MY_PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs"
+
+# We do not depend on tor which might be running on a different box
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-docdir-r2.patch
+ epatch "${FILESDIR}"/fix-find-libc.so.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ dodoc ChangeLog README TODO doc/notes/DEBUG doc/socks/{SOCKS5,socks-extensions.txt}
+
+ #Remove libtool .la files
+ cd "${D}"/usr/$(get_libdir)/torsocks
+ rm -f *.la
+}