summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-12-27 01:15:48 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-12-27 01:15:48 +0000
commitded18b0698f1285888f57fd457e6e36e4acf77fe (patch)
tree815db4d7192670271991a0ef62956d05aedf670b /net-proxy
parentStable for ppc/ppc64; bug #394879 (diff)
downloadgentoo-2-ded18b0698f1285888f57fd457e6e36e4acf77fe.tar.gz
gentoo-2-ded18b0698f1285888f57fd457e6e36e4acf77fe.tar.bz2
gentoo-2-ded18b0698f1285888f57fd457e6e36e4acf77fe.zip
Put doc files in proper docdir, bug #395951
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/torsocks/ChangeLog7
-rw-r--r--net-proxy/torsocks/files/fix-docdir.patch24
-rw-r--r--net-proxy/torsocks/torsocks-1.2-r1.ebuild38
3 files changed, 69 insertions, 0 deletions
diff --git a/net-proxy/torsocks/ChangeLog b/net-proxy/torsocks/ChangeLog
index 9bc0d319c34c..9f578f7d5218 100644
--- a/net-proxy/torsocks/ChangeLog
+++ b/net-proxy/torsocks/ChangeLog
@@ -1,4 +1,11 @@
+
+*torsocks-1.2-r1 (27 Dec 2011)
+
+ 27 Dec 2011; Anthony G. Basile <blueness@gentoo.org> +torsocks-1.2-r1.ebuild,
+ +files/fix-docdir.patch:
+ Put doc files in proper docdir, bug #395951
+
19 Dec 2011; Agostino Sarubbo <ago@gentoo.org> torsocks-1.2.ebuild:
Stable for AMD64, wrt bug #395215
diff --git a/net-proxy/torsocks/files/fix-docdir.patch b/net-proxy/torsocks/files/fix-docdir.patch
new file mode 100644
index 000000000000..899c15b16721
--- /dev/null
+++ b/net-proxy/torsocks/files/fix-docdir.patch
@@ -0,0 +1,24 @@
+diff -Naur torsocks-1.2.orig/doc/Makefile.am torsocks-1.2/doc/Makefile.am
+--- torsocks-1.2.orig/doc/Makefile.am 2011-10-26 14:30:26.000000000 -0400
++++ torsocks-1.2/doc/Makefile.am 2011-12-26 20:05:40.000000000 -0500
+@@ -7,8 +7,6 @@
+ # Install man pages
+ dist_man_MANS = torsocks.1 torsocks.8 usewithtor.1 torsocks.conf.5
+
+-dist_data_DATA = socks/SOCKS5 socks/SOCKS4.protocol socks/socks-extensions.txt \
+- patches/compilewarnings.patch patches/conffile.patch patches/getaddrbyhost.patch \
+- patches/getpeername.patch patches/infiniteloop.patch patches/localaddresses.patch \
+- patches/README patches/README.TORDNS patches/tordns.patch notes/DEBUG
++dist_doc_DATA = socks/SOCKS5 socks/SOCKS4.protocol socks/socks-extensions.txt \
++ notes/DEBUG
+
+diff -Naur torsocks-1.2.orig/test/Makefile.am torsocks-1.2/test/Makefile.am
+--- torsocks-1.2.orig/test/Makefile.am 2011-10-26 14:21:57.000000000 -0400
++++ torsocks-1.2/test/Makefile.am 2011-12-26 20:04:34.000000000 -0500
+@@ -4,4 +4,4 @@
+ test_torsocks_LDFLAGS= $(TESTLDFLAGS)
+ CLEANFILES= test_torsocks
+
+-dist_data_DATA = run_tests.sh expectedresults.txt
+\ No newline at end of file
++dist_doc_DATA = run_tests.sh expectedresults.txt
diff --git a/net-proxy/torsocks/torsocks-1.2-r1.ebuild b/net-proxy/torsocks/torsocks-1.2-r1.ebuild
new file mode 100644
index 000000000000..9d782807d5e9
--- /dev/null
+++ b/net-proxy/torsocks/torsocks-1.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/torsocks/torsocks-1.2-r1.ebuild,v 1.1 2011/12/27 01:15:48 blueness Exp $
+
+EAPI="4"
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Use most socks-friendly applications with Tor."
+HOMEPAGE="http://code.google.com/p/torsocks"
+SRC_URI="http://${PN}.googlecode.com/files/${PN}-1.2.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+# We do not depend on tor which might be running on a different box
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-docdir.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF} \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ #Remove libtool .la files
+ cd "${D}"/usr/$(get_libdir)/torsocks
+ rm -f *.la
+}