summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2010-11-03 21:09:25 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2010-11-03 21:09:25 +0000
commit4a11d44852a93c30592ee967c3b1cbc1a4014c2d (patch)
tree3a2a89bb9144db31198af2f58d5f494a1960ce8e /net-voip/telepathy-gabble
parentarm stable, bug #331531 (diff)
downloadgentoo-2-4a11d44852a93c30592ee967c3b1cbc1a4014c2d.tar.gz
gentoo-2-4a11d44852a93c30592ee967c3b1cbc1a4014c2d.tar.bz2
gentoo-2-4a11d44852a93c30592ee967c3b1cbc1a4014c2d.zip
Bump to 0.10.4. Updated internal wocky, some bug fixes. Stop touching --enable-debug - upstream needs this to be on by default to get meaningful logs. Runtime impact is negligible.
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'net-voip/telepathy-gabble')
-rw-r--r--net-voip/telepathy-gabble/ChangeLog10
-rw-r--r--net-voip/telepathy-gabble/telepathy-gabble-0.10.4.ebuild49
2 files changed, 58 insertions, 1 deletions
diff --git a/net-voip/telepathy-gabble/ChangeLog b/net-voip/telepathy-gabble/ChangeLog
index 07bfdf7361a3..679fc4aa1643 100644
--- a/net-voip/telepathy-gabble/ChangeLog
+++ b/net-voip/telepathy-gabble/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-voip/telepathy-gabble
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.64 2010/10/10 16:11:57 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/ChangeLog,v 1.65 2010/11/03 21:09:25 ford_prefect Exp $
+
+*telepathy-gabble-0.10.4 (03 Nov 2010)
+
+ 03 Nov 2010; Arun Raghavan <ford_prefect@gentoo.org>
+ +telepathy-gabble-0.10.4.ebuild:
+ Bump to 0.10.4. Updated internal wocky, some bug fixes. Stop touching
+ --enable-debug - upstream needs this to be on by default to get meaningful
+ logs. Runtime impact is negligible.
10 Oct 2010; Tobias Klausmann <klausman@gentoo.org>
telepathy-gabble-0.8.14.ebuild:
diff --git a/net-voip/telepathy-gabble/telepathy-gabble-0.10.4.ebuild b/net-voip/telepathy-gabble/telepathy-gabble-0.10.4.ebuild
new file mode 100644
index 000000000000..235b186b5276
--- /dev/null
+++ b/net-voip/telepathy-gabble/telepathy-gabble-0.10.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-gabble/telepathy-gabble-0.10.4.ebuild,v 1.1 2010/11/03 21:09:25 ford_prefect Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A Jabber/XMPP connection manager, this handles single and multi user chats and voice calls."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug test"
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.82
+ >=net-libs/telepathy-glib-0.11.16
+ net-libs/libsoup:2.4[ssl]
+ >=net-libs/libnice-0.0.11
+ >=net-libs/gnutls-2.10.2
+ dev-db/sqlite:3
+ dev-libs/libxml2
+ !<net-im/telepathy-mission-control-5.5.0"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-lang/python-2.5
+ test? ( >=dev-python/twisted-0.8.2
+ >=dev-python/twisted-words-0.8.2
+ >=dev-python/dbus-python-0.83 )"
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable debug handle-leak-debug)
+}
+
+src_test() {
+ # Twisted tests fail, upstream bug #30565
+ emake -C tests check-TESTS || die "tests failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS NEWS ChangeLog README || die "dodoc failed"
+}