summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-06-19 07:47:23 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-06-19 07:47:23 +0000
commitfbf77f085467ffe97a534450080e5d6cf15ff672 (patch)
tree864c3749b16fbd55bfcfd4cf1f60ca52fe83bec5 /net-voip/yate
parentAdd NETSURF_COMPONENT_TYPE default, restore .desktop generation (diff)
downloadgentoo-2-fbf77f085467ffe97a534450080e5d6cf15ff672.tar.gz
gentoo-2-fbf77f085467ffe97a534450080e5d6cf15ff672.tar.bz2
gentoo-2-fbf77f085467ffe97a534450080e5d6cf15ff672.zip
Add comment about parallel compile issue, bug #312407. Remove some unnecessary die calls.
(Portage version: 2.1.12.2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-voip/yate')
-rw-r--r--net-voip/yate/ChangeLog7
-rw-r--r--net-voip/yate/yate-4.3.0.1.ebuild17
2 files changed, 15 insertions, 9 deletions
diff --git a/net-voip/yate/ChangeLog b/net-voip/yate/ChangeLog
index 5a6eada18145..25a2eba848ef 100644
--- a/net-voip/yate/ChangeLog
+++ b/net-voip/yate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-voip/yate
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/yate/ChangeLog,v 1.19 2013/06/19 06:38:58 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/yate/ChangeLog,v 1.20 2013/06/19 07:47:23 chithanh Exp $
+
+ 19 Jun 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ yate-4.3.0.1.ebuild:
+ Add comment about parallel compile issue, bug #312407. Remove some unnecessary
+ die calls.
19 Jun 2013; Sergey Popov <pinkbyte@gentoo.org> yate-4.3.0.1.ebuild:
Fix desktop file, wrt bug #463442. Thanks to Andreis Vinogradovs for
diff --git a/net-voip/yate/yate-4.3.0.1.ebuild b/net-voip/yate/yate-4.3.0.1.ebuild
index cf16891dd90a..785722a7fff0 100644
--- a/net-voip/yate/yate-4.3.0.1.ebuild
+++ b/net-voip/yate/yate-4.3.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/yate/yate-4.3.0.1.ebuild,v 1.2 2013/06/19 06:38:58 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/yate/yate-4.3.0.1.ebuild,v 1.3 2013/06/19 07:47:23 chithanh Exp $
EAPI=5
@@ -86,8 +86,9 @@ src_configure() {
}
src_compile() {
+ # fails parallel build, bug #312407
if use debug; then
- emake -j1 ddebug || die "emake ddebug failed"
+ emake -j1 ddebug
else
emake -j1
fi
@@ -101,17 +102,17 @@ src_test() {
}
src_install() {
- emake DESTDIR="${D}" install-noapi || die "emake install-noapi failed"
+ emake DESTDIR="${D}" install-noapi
- dodoc ChangeLog README || die "dodoc failed"
+ dodoc ChangeLog README
insinto /etc/logrotate.d
- newins packing/${PN}.logrotate ${PN} || die "newins failed"
+ newins packing/${PN}.logrotate ${PN}
- newinitd "${FILESDIR}"/${PN}.initd ${PN} || die "newinitd failed"
- newconfd "${FILESDIR}"/${PN}.confd ${PN} || die "newconfd failed"
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
if use doc; then
- emake DESTDIR="${D}" install-api || die "emake install-api failed"
+ emake DESTDIR="${D}" install-api
fi
}