summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2010-03-26 21:11:09 +0000
committerOlivier Crête <tester@gentoo.org>2010-03-26 21:11:09 +0000
commit9e0cc9cdc6ac4b5ff03faccf1f90028f8625c6c9 (patch)
treece7ccd1714f16f54455a6dcb4c42da4febe247a6 /net-voip
parentVersion bump (diff)
downloadgentoo-2-9e0cc9cdc6ac4b5ff03faccf1f90028f8625c6c9.tar.gz
gentoo-2-9e0cc9cdc6ac4b5ff03faccf1f90028f8625c6c9.tar.bz2
gentoo-2-9e0cc9cdc6ac4b5ff03faccf1f90028f8625c6c9.zip
Version bump
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'net-voip')
-rw-r--r--net-voip/telepathy-sofiasip/ChangeLog8
-rw-r--r--net-voip/telepathy-sofiasip/telepathy-sofiasip-0.6.2.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/net-voip/telepathy-sofiasip/ChangeLog b/net-voip/telepathy-sofiasip/ChangeLog
index 33c847cae99a..127c22c2a8b1 100644
--- a/net-voip/telepathy-sofiasip/ChangeLog
+++ b/net-voip/telepathy-sofiasip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-voip/telepathy-sofiasip
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-sofiasip/ChangeLog,v 1.8 2010/02/19 19:25:26 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-sofiasip/ChangeLog,v 1.9 2010/03/26 21:11:09 tester Exp $
+
+*telepathy-sofiasip-0.6.2 (26 Mar 2010)
+
+ 26 Mar 2010; Olivier Crête <tester@gentoo.org>
+ +telepathy-sofiasip-0.6.2.ebuild:
+ Version bump
19 Feb 2010; Raúl Porcel <armin76@gentoo.org>
telepathy-sofiasip-0.5.17.ebuild, telepathy-sofiasip-0.5.18.ebuild:
diff --git a/net-voip/telepathy-sofiasip/telepathy-sofiasip-0.6.2.ebuild b/net-voip/telepathy-sofiasip/telepathy-sofiasip-0.6.2.ebuild
new file mode 100644
index 000000000000..077c171320b3
--- /dev/null
+++ b/net-voip/telepathy-sofiasip/telepathy-sofiasip-0.6.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-sofiasip/telepathy-sofiasip-0.6.2.ebuild,v 1.1 2010/03/26 21:11:09 tester Exp $
+
+inherit autotools
+
+DESCRIPTION="A SIP connection manager for Telepathy based around the Sofia-SIP library."
+HOMEPAGE="http://telepathy.freedesktop.org/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="debug test"
+
+RDEPEND=">=net-libs/sofia-sip-1.12.10
+ >=net-libs/telepathy-glib-0.8.0
+ >=dev-libs/glib-2.16
+ sys-apps/dbus
+ dev-libs/dbus-glib"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ dev-lang/python
+ test? ( dev-python/twisted )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ sed -i -e "s/python2.5/python2.6 python2.5/" configure.ac
+ rm ltmain.sh m4/libtool.m4 m4/lt*.m4
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable debug) || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}