summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2009-12-14 17:33:02 +0000
committerFabio Erculiani <lxnay@gentoo.org>2009-12-14 17:33:02 +0000
commitf3ab625b9dd46ab4ca31660292091d2d92a9c551 (patch)
tree1df08a72f2716f639ead979d1581ac1eed18cb9c /net-wireless/acx/acx-0.3.37_p20080210.ebuild
parentVersion bump, use pid variables in init script by Polynomial-C in bug #296864 (diff)
downloadgentoo-2-f3ab625b9dd46ab4ca31660292091d2d92a9c551.tar.gz
gentoo-2-f3ab625b9dd46ab4ca31660292091d2d92a9c551.tar.bz2
gentoo-2-f3ab625b9dd46ab4ca31660292091d2d92a9c551.zip
Fix compilation with latest kernels (2.6.31, 2.6.32), thanks everybody involved, close bug #229459, #265000, #243392
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'net-wireless/acx/acx-0.3.37_p20080210.ebuild')
-rw-r--r--net-wireless/acx/acx-0.3.37_p20080210.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-wireless/acx/acx-0.3.37_p20080210.ebuild b/net-wireless/acx/acx-0.3.37_p20080210.ebuild
new file mode 100644
index 000000000000..db07159afe2e
--- /dev/null
+++ b/net-wireless/acx/acx-0.3.37_p20080210.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/acx-0.3.37_p20080210.ebuild,v 1.1 2009/12/14 17:33:02 lxnay Exp $
+
+inherit linux-mod
+
+PATCHLEVEL=${PV##*_p}
+
+DESCRIPTION="Driver for the ACX100 and ACX111 wireless chipset (CardBus, PCI, USB)"
+HOMEPAGE="http://acx100.sourceforge.net/"
+SRC_URI="http://downloads.sourceforge.net/acx100/${PN}-${PATCHLEVEL}.tar.bz2"
+
+LICENSE="GPL-2 as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="debug"
+
+RDEPEND="net-wireless/wireless-tools
+ net-wireless/acx-firmware"
+
+S=${WORKDIR}/${PN}-${PATCHLEVEL}
+
+MODULE_NAMES="acx(net:${S})"
+CONFIG_CHECK="WIRELESS_EXT FW_LOADER"
+BUILD_TARGETS="modules"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="-C ${KV_DIR} SUBDIRS=${S}"
+}
+
+src_unpack() {
+ unpack ${A}
+ chmod ug+w . -R
+
+ # The default acx_config.h has some rather over-zealous debug output.
+ cd "${S}"
+ if ! use debug; then
+ sed -i '/^#define ACX_DEBUG/s/2/0/' acx_config.h || die "Failed to disable debug support"
+ fi
+
+ # Apply various fixes to make module compile with 2.6.31+ kernels
+ # thanks to Mepis
+ epatch "${FILESDIR}"/2.6.31+-mepis/*
+
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README
+}