summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Hale <tseng@gentoo.org>2004-08-31 12:08:44 +0000
committerBrandon Hale <tseng@gentoo.org>2004-08-31 12:08:44 +0000
commit51593efabb5d76a6dbf32d2bfc86a034b0be6157 (patch)
treeffbb0b4a18ce5895b5a251702a6bf724966cb734 /net-wireless/airsnort/airsnort-0.2.4a.ebuild
parentAdded a unconditionnal -fPIC patch (#55238). (Manifest recommit) (diff)
downloadgentoo-2-51593efabb5d76a6dbf32d2bfc86a034b0be6157.tar.gz
gentoo-2-51593efabb5d76a6dbf32d2bfc86a034b0be6157.tar.bz2
gentoo-2-51593efabb5d76a6dbf32d2bfc86a034b0be6157.zip
Version bump. This version uses new monitor mode code available in orinico-cvs.
Diffstat (limited to 'net-wireless/airsnort/airsnort-0.2.4a.ebuild')
-rw-r--r--net-wireless/airsnort/airsnort-0.2.4a.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-wireless/airsnort/airsnort-0.2.4a.ebuild b/net-wireless/airsnort/airsnort-0.2.4a.ebuild
new file mode 100644
index 000000000000..4ffe3ca83877
--- /dev/null
+++ b/net-wireless/airsnort/airsnort-0.2.4a.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/airsnort/airsnort-0.2.4a.ebuild,v 1.1 2004/08/31 12:08:44 tseng Exp $
+
+DESCRIPTION="802.11b Wireless Packet Sniffer/WEP Cracker"
+HOMEPAGE="http://airsnort.shmoo.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="pcmcia"
+
+DEPEND=">=sys-devel/autoconf-2.13
+ =x11-libs/gtk+-2*
+ >=net-libs/libpcap-0.7.1
+ >=gnome-base/libgnomeui-2*
+ pcmcia? ( >=sys-apps/pcmcia-cs-3.1.33 )"
+
+src_compile() {
+ ./autogen.sh \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./autogen failed"
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README README.decrypt AUTHORS ChangeLog TODO faq.txt
+}
+pkg_postinst() {
+ einfo "Make sure to emerge linux-wlan-ng if you want support"
+ einfo "for Prism2 based cards in airsnort."
+}