summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-05-09 19:22:21 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-05-09 19:22:21 +0000
commit1213556733771803b1e6ed5c417acb2e08aaca02 (patch)
tree8ae24d463f0a2f303369d3c70a17568ff03b07fc /net-wireless/at76c503a
parentFix qt deps. (diff)
downloadgentoo-2-1213556733771803b1e6ed5c417acb2e08aaca02.tar.gz
gentoo-2-1213556733771803b1e6ed5c417acb2e08aaca02.tar.bz2
gentoo-2-1213556733771803b1e6ed5c417acb2e08aaca02.zip
Add kernel 2.6.20 support thanks to steev in bug 164659
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-wireless/at76c503a')
-rw-r--r--net-wireless/at76c503a/ChangeLog6
-rw-r--r--net-wireless/at76c503a/at76c503a-0.14_beta1.ebuild11
-rw-r--r--net-wireless/at76c503a/files/at76c503a-2.6.20.patch35
3 files changed, 49 insertions, 3 deletions
diff --git a/net-wireless/at76c503a/ChangeLog b/net-wireless/at76c503a/ChangeLog
index b3c3e74a7fb6..a720715e4778 100644
--- a/net-wireless/at76c503a/ChangeLog
+++ b/net-wireless/at76c503a/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-wireless/at76c503a
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/at76c503a/ChangeLog,v 1.14 2007/05/09 18:48:00 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/at76c503a/ChangeLog,v 1.15 2007/05/09 19:22:21 genstef Exp $
+
+ 09 May 2007; Stefan Schweizer <genstef@gentoo.org>
+ +files/at76c503a-2.6.20.patch, at76c503a-0.14_beta1.ebuild:
+ Add kernel 2.6.20 support thanks to steev in bug 164659
*at76c503a-9999 (09 May 2007)
diff --git a/net-wireless/at76c503a/at76c503a-0.14_beta1.ebuild b/net-wireless/at76c503a/at76c503a-0.14_beta1.ebuild
index 0a7ef506b8ac..82bcbd6c1e5d 100644
--- a/net-wireless/at76c503a/at76c503a-0.14_beta1.ebuild
+++ b/net-wireless/at76c503a/at76c503a-0.14_beta1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/at76c503a/at76c503a-0.14_beta1.ebuild,v 1.3 2007/05/09 18:48:00 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/at76c503a/at76c503a-0.14_beta1.ebuild,v 1.4 2007/05/09 19:22:21 genstef Exp $
-inherit linux-mod
+inherit linux-mod eutils
MY_P=at76_usb-${PV/_}
+DESCRIPTION="at76c503 is a Linux driver for the wlan USB adapter based on the Atmel at76c503 chip. It currently supports ad-hoc mode, infrastructure mode, and WEP. It supports adapters from Atmel, the Belkin F5D6050, Netgear MA101, and others."
HOMEPAGE="http://developer.berlios.de/projects/at76c503a/"
SRC_URI="http://download.berlios.de/at76c503a/${MY_P}.tar.gz"
LICENSE="GPL-2"
@@ -27,6 +28,12 @@ pkg_setup() {
BUILD_PARAMS="KERNEL_PATH=${KV_DIR}"
}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/at76c503a-2.6.20.patch
+}
+
src_install() {
linux-mod_src_install
diff --git a/net-wireless/at76c503a/files/at76c503a-2.6.20.patch b/net-wireless/at76c503a/files/at76c503a-2.6.20.patch
new file mode 100644
index 000000000000..3158dcabc49d
--- /dev/null
+++ b/net-wireless/at76c503a/files/at76c503a-2.6.20.patch
@@ -0,0 +1,35 @@
+diff -ruN at76_usb-0.14beta1.orig/at76c503.c at76_usb-0.14beta1/at76c503.c
+--- at76_usb-0.14beta1.orig/at76c503.c 2007-02-09 22:34:44.000000000 -0600
++++ at76_usb-0.14beta1/at76c503.c 2007-02-09 22:36:01.000000000 -0600
+@@ -18,10 +18,14 @@
+ * Some iw_handler code was taken from airo.c, (C) 1999 Benjamin Reed
+ */
+
++#include <linux/version.h>
++#if KERNEL_VERSION(2,6,19) > LINUX_VERSION_CODE
+ #include <linux/config.h>
++#else
++#include <linux/autoconf.h>
++#endif
+ #include <linux/init.h>
+ #include <linux/kernel.h>
+-#include <linux/version.h>
+ #include <linux/sched.h>
+ #include <linux/errno.h>
+ #include <linux/poll.h>
+diff -ruN at76_usb-0.14beta1.orig/at76_usbdfu.c at76_usb-0.14beta1/at76_usbdfu.c
+--- at76_usb-0.14beta1.orig/at76_usbdfu.c 2007-02-09 22:34:44.000000000 -0600
++++ at76_usb-0.14beta1/at76_usbdfu.c 2007-02-09 22:36:40.000000000 -0600
+@@ -24,7 +24,12 @@
+ * - Firmware upload (device-to-host) support
+ */
+
++#include <linux/version.h>
++#if KERNEL_VERSION(2,6,19) > LINUX_VERSION_CODE
+ #include <linux/config.h>
++#else
++#include <linux/autoconf.h>
++#endif
+ #include <linux/slab.h>
+ #include <linux/usb.h>
+ #include "at76c503.h"