summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2005-07-06 10:46:12 +0000
committerAlastair Tse <liquidx@gentoo.org>2005-07-06 10:46:12 +0000
commitecdf7c4e29797a2f338241f812f365072cffcc07 (patch)
treea3380c36524f98a0cf6b4512cde9e20ae2f1f9c9 /net-wireless/gnome-bluetooth/gnome-bluetooth-0.5.1-r2.ebuild
parentversion bump (diff)
downloadgentoo-2-ecdf7c4e29797a2f338241f812f365072cffcc07.tar.gz
gentoo-2-ecdf7c4e29797a2f338241f812f365072cffcc07.tar.bz2
gentoo-2-ecdf7c4e29797a2f338241f812f365072cffcc07.zip
added gnome python patch (#97632)
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-wireless/gnome-bluetooth/gnome-bluetooth-0.5.1-r2.ebuild')
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-0.5.1-r2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-0.5.1-r2.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-0.5.1-r2.ebuild
new file mode 100644
index 000000000000..d0cbc2de97fa
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-0.5.1-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnome-bluetooth/gnome-bluetooth-0.5.1-r2.ebuild,v 1.1 2005/07/06 10:46:12 liquidx Exp $
+
+inherit distutils gnome2 eutils
+
+DESCRIPTION="Gnome2 Bluetooth integration suite."
+HOMEPAGE="http://usefulinc.com/software/gnome-bluetooth/"
+SRC_URI="http://downloads.usefulinc.com/gnome-bluetooth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+IUSE=""
+
+RDEPEND=">=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-vfs-2.1.3
+ >=x11-libs/gtk+-2
+ >=gnome-base/librsvg-2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libbonoboui-2
+ >=gnome-base/gconf-2
+ >=gnome-base/orbit-2
+ >=dev-util/gob-2
+ >=dev-libs/openobex-1
+ >=net-wireless/bluez-libs-2.7
+ >=net-wireless/libbtctl-0.4.1
+ >=dev-python/pygtk-2.0
+ >=dev-python/gnome-python-2"
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+DOCS="README NEWS AUTHORS COPYING ChangeLog"
+MAKEOPTS="${MAKEOPTS} -j1"
+PYTHON_MODNAME="gnomebt"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gobcrash.patch
+ epatch ${FILESDIR}/${P}-obex_xfer_rate.patch
+ epatch ${FILESDIR}/${P}-gnome.patch
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ gnome2_pkg_postrm
+}