summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2003-11-04 08:03:58 +0000
committerWolfram Schlich <wschlich@gentoo.org>2003-11-04 08:03:58 +0000
commit74002cfc35639e87ec331b48f86392dd413843f6 (patch)
treeebc33b206a295c3fc772e707ab6132252faea558 /net-wireless/hostap-driver
parentversion bump (diff)
downloadgentoo-2-74002cfc35639e87ec331b48f86392dd413843f6.tar.gz
gentoo-2-74002cfc35639e87ec331b48f86392dd413843f6.tar.bz2
gentoo-2-74002cfc35639e87ec331b48f86392dd413843f6.zip
version bump
Diffstat (limited to 'net-wireless/hostap-driver')
-rw-r--r--net-wireless/hostap-driver/ChangeLog8
-rw-r--r--net-wireless/hostap-driver/Manifest4
-rw-r--r--net-wireless/hostap-driver/files/digest-hostap-driver-0.1.21
-rw-r--r--net-wireless/hostap-driver/hostap-driver-0.1.2.ebuild109
4 files changed, 119 insertions, 3 deletions
diff --git a/net-wireless/hostap-driver/ChangeLog b/net-wireless/hostap-driver/ChangeLog
index 0a4e78d05e7b..9e426ab604ca 100644
--- a/net-wireless/hostap-driver/ChangeLog
+++ b/net-wireless/hostap-driver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/hostap-driver
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-driver/ChangeLog,v 1.1 2003/10/20 22:28:51 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-driver/ChangeLog,v 1.2 2003/11/04 08:02:08 wschlich Exp $
+
+*hostap-driver-0.1.2 (04 Nov 2003)
+
+ 04 Nov 2003; Wolfram Schlich <wschlich@gentoo.org>
+ hostap-driver-0.1.2.ebuild:
+ Version bump
*hostap-driver-0.1.1 (21 Oct 2003)
diff --git a/net-wireless/hostap-driver/Manifest b/net-wireless/hostap-driver/Manifest
index 24a27280ca2a..dcec989c888c 100644
--- a/net-wireless/hostap-driver/Manifest
+++ b/net-wireless/hostap-driver/Manifest
@@ -1,6 +1,6 @@
-MD5 a05209c3d01b02709d79dce0172fe4ce ChangeLog 522
+MD5 609298b6f0fec884d376d1d3cae8cdb4 ChangeLog 522
MD5 e837e0ccb2e7f52991d700388c1d5f92 hostap-driver-0.1.1.ebuild 3757
MD5 c8d062581aead1cc0fb7bd3b4331ff19 metadata.xml 722
-MD5 e837e0ccb2e7f52991d700388c1d5f92 hostap-driver-0.1.2.ebuild 3757
+MD5 b7c81aebe7f8a4c21b1dcbfc0d62eb8a hostap-driver-0.1.2.ebuild 3757
MD5 75dda0e477834ba5a6c5c88cfb402fe7 files/digest-hostap-driver-0.1.1 71
MD5 5c57e0825ccb41c219c9d86c6a9114e5 files/digest-hostap-driver-0.1.2 71
diff --git a/net-wireless/hostap-driver/files/digest-hostap-driver-0.1.2 b/net-wireless/hostap-driver/files/digest-hostap-driver-0.1.2
new file mode 100644
index 000000000000..f805ddce209b
--- /dev/null
+++ b/net-wireless/hostap-driver/files/digest-hostap-driver-0.1.2
@@ -0,0 +1 @@
+MD5 48dc3ddd8a8b1d47002b54f7a8fee7da hostap-driver-0.1.2.tar.gz 168410
diff --git a/net-wireless/hostap-driver/hostap-driver-0.1.2.ebuild b/net-wireless/hostap-driver/hostap-driver-0.1.2.ebuild
new file mode 100644
index 000000000000..a9f5c91e5fe3
--- /dev/null
+++ b/net-wireless/hostap-driver/hostap-driver-0.1.2.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-driver/hostap-driver-0.1.2.ebuild,v 1.1 2003/11/04 08:02:08 wschlich Exp $
+
+inherit eutils
+
+DESCRIPTION="HostAP wireless drivers"
+HOMEPAGE="http://hostap.epitest.fi/"
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="pcmcia hostap-nopci hostap-noplx"
+DEPEND=">=net-wireless/wireless-tools-25
+ pcmcia? ( >=sys-apps/pcmcia-cs-3.2.1 )"
+RDEPEND="!net-wireless/hostap"
+S="${WORKDIR}/${P}"
+LIB_PATH="/lib/modules/${KV}"
+
+src_unpack() {
+ check_KV
+ unpack ${A}
+ cd "${S}"
+
+ ## set compiler options
+ sed -i -e "s:gcc:${CC}:" "${S}/Makefile"
+ # sed -i -e "s:-O2:${CFLAGS}:" "${S}/Makefile" # improper CFLAGS could cause unresolved symbols in the modules
+
+ ## fix for new coreutils (#31801)
+ sed -i -e "s:tail -1:tail -n 1:" "${S}/Makefile"
+
+ ## use pcmcia-cs sources if kernel tree pcmcia support is disabled and USE=pcmcia is set
+ if use pcmcia >&/dev/null; then
+ if egrep '^CONFIG_PCMCIA=[ym]' /usr/src/linux/.config >&/dev/null; then
+ einfo "Kernel PCMCIA is enabled, skipping external pcmcia-cs sources"
+ else
+ einfo "Kernel PCMCIA is disabled, using external pcmcia-cs sources"
+ ## get ebuild of currently installed pcmcia-cs package
+ PCMCIA_CS_EBUILD=(/var/db/pkg/sys-apps/pcmcia-cs-*/pcmcia-cs-*.ebuild) ## use bash globbing
+ if [ ! -f "${PCMCIA_CS_EBUILD}" ]; then
+ die "ERROR: pcmcia-cs ebuild (${PCMCIA_CS_EBUILD}) not found - are you sure pcmcia-cs is installed?"
+ fi
+ PCMCIA_CS_VER="${PCMCIA_CS_EBUILD##*/}" ## -> pcmcia-cs-VER.ebuild
+ PCMCIA_CS_VER="${PCMCIA_CS_VER/pcmcia-cs-/}" ## strip 'pcmcia-cs-'
+ PCMCIA_CS_VER="${PCMCIA_CS_VER/.ebuild/}" ## strip '.ebuild'
+ PCMCIA_PATH="${WORKDIR}/pcmcia-cs-${PCMCIA_CS_VER}"
+ sed -i -e "s:^PCMCIA_PATH=:PCMCIA_PATH=${PCMCIA_PATH}:" "${S}/Makefile"
+ ## unpack external pcmcia-cs sources
+ cd "${WORKDIR}"
+ unpack pcmcia-cs-${PCMCIA_CS_VER}.tar.gz ## unpack the pcmcia-cs sources to PCMCIA_PATH
+ cd pcmcia-cs-${PCMCIA_CS_VER}
+ ## when not configured, pcmcia-cs spits out lots of errors (since 3.2.5)
+ if ! ./Configure -n --srctree --kernel=/usr/src/linux >&/dev/null; then
+ eerror "External pcmcia-cs configuration failed"
+ die
+ fi
+ fi
+ fi
+}
+
+src_compile() {
+
+ local mydrivers
+
+ use pcmcia && mydrivers="${mydrivers} pccard"
+ use hostap-nopci || mydrivers="${mydrivers} pci"
+ use hostap-noplx || mydrivers="${mydrivers} plx"
+
+ einfo "Building the following drivers: ${mydrivers}"
+ emake EXTRA_CFLAGS="-DPRISM2_DOWNLOAD_SUPPORT" ${mydrivers} || die
+}
+
+src_install() {
+ dodir ${LIB_PATH}/net
+ cp ${S}/driver/modules/{hostap.o,hostap_crypt_wep.o} \
+ ${D}${LIB_PATH}/net/
+# local myinstall="install_hostap install_crypt"
+
+ if use pcmcia >&/dev/null; then
+ dodir ${LIB_PATH}/pcmcia
+ dodir /etc/pcmcia
+ cp ${S}/driver/modules/hostap_cs.o ${D}/${LIB_PATH}/pcmcia/
+ cp ${S}/driver/etc/hostap_cs.conf ${D}/etc/pcmcia/
+ if [ -r /etc/pcmcia/prism2.conf ]; then
+ einfo "You may need to edit or remove /etc/pcmcia/prism2.conf"
+ einfo "This is usually a result of conflicts with the"
+ einfo "linux-wlan-ng drivers."
+ fi
+# myinstall="${myinstall} install_pccard"
+ fi
+
+ if ! use hostap-nopci >&/dev/null; then
+ cp ${S}/driver/modules/hostap_pci.o \
+ ${D}${LIB_PATH}/net/
+# myinstall="${myinstall} install_pci"
+ fi
+
+ if ! use hostap-noplx >&/dev/null; then
+ cp ${S}/driver/modules/hostap_plx.o \
+ ${D}${LIB_PATH}/net/
+# myinstall="${myinstall} install_plx"
+ fi
+# emake DESTDIR="${D}" ${myinstall}
+ dodoc README ChangeLog
+}
+pkg_postinst(){
+ einfo "Checking kernel module dependancies"
+ cd /usr/src/linux && make _modinst_post ## depmod
+}