summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-12-18 00:33:31 +0000
committerChristian Heim <phreak@gentoo.org>2006-12-18 00:33:31 +0000
commiteaebd0feac7da20ccfca133703f8ab396a3db3b2 (patch)
treec85aafec9a7148b1326c6babe182a8515442aebd /net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild
parentDropped old versions. Version bump. Updated bash-completion file and Exuberan... (diff)
downloadgentoo-2-eaebd0feac7da20ccfca133703f8ab396a3db3b2.tar.gz
gentoo-2-eaebd0feac7da20ccfca133703f8ab396a3db3b2.tar.bz2
gentoo-2-eaebd0feac7da20ccfca133703f8ab396a3db3b2.zip
Adding a postinst hack, to change the permission/ownership in case the package is already present on the system. Without this hack, the permission/ownership changes to /sbin/ipw3945d and /var/run/ipw3945d wont be merged onto the ROOT filesystem.
(Portage version: 2.1.2_rc3-r6)
Diffstat (limited to 'net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild')
-rw-r--r--net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild26
1 files changed, 24 insertions, 2 deletions
diff --git a/net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild b/net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild
index 583385f76f33..cae6ca997439 100644
--- a/net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild
+++ b/net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild,v 1.2 2006/12/17 21:46:35 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ipw3945d/ipw3945d-1.7.22-r4.ebuild,v 1.3 2006/12/18 00:33:31 phreak Exp $
inherit eutils
@@ -50,6 +50,28 @@ pkg_postinst() {
if [ -f "${ROOT}/etc/modules.d/${PN}" ] ; then
${ROOT}/sbin/modules-update --force
fi
+
+ echo
+
+ # These nasty live-filesystem fixes are needed, because if the files are
+ # already there, the permissions applied in src_install() won't get
+ # transferred to the live filesystem. Once portage is fixed with regard to
+ # this, these hacks can go away.
+
+ # Fix the permissions of /sbin/ipw3945d
+ ebegin "Fixing permissions of ${ROOT}/sbin/ipw3945d"
+ fperms 04450 ${ROOT}/sbin/ipw3945d
+ eend $?
+
+ # Fixing ownership of /var/run/ipw3945d
+ ebegin "Fixing ownership of ${ROOT}/var/run/ipw3945d"
+ fowners ipw3945d:root ${ROOT}/var/run/ipw3945d
+ eend $?
+
+ echo
+
einfo "The ipw3945 daemon is now started by udev. The daemon should be"
- einfo "brought up automatically."
+ einfo "brought up automatically once you reboot. Also make sure when you"
+ einfo "update from a previous version, you need to reboot in order to"
+ einfo "replace an existing version of this daemon!"
}