summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-02 06:53:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-02 06:53:17 +0000
commit11ae47ec57041d3e8b006a35ecb74c007a2f704d (patch)
tree92bf1b58ef8061d432f253b414ff455de694742e /net-wireless/kbluetooth
parentMask all of dev-db/mysql-community for security vulnerabilities that are only... (diff)
downloadgentoo-2-11ae47ec57041d3e8b006a35ecb74c007a2f704d.tar.gz
gentoo-2-11ae47ec57041d3e8b006a35ecb74c007a2f704d.tar.bz2
gentoo-2-11ae47ec57041d3e8b006a35ecb74c007a2f704d.zip
Version bump.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'net-wireless/kbluetooth')
-rw-r--r--net-wireless/kbluetooth/ChangeLog8
-rw-r--r--net-wireless/kbluetooth/kbluetooth-0.4.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/net-wireless/kbluetooth/ChangeLog b/net-wireless/kbluetooth/ChangeLog
index 5055b7adb533..9ecb54bd36fd 100644
--- a/net-wireless/kbluetooth/ChangeLog
+++ b/net-wireless/kbluetooth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/kbluetooth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/kbluetooth/ChangeLog,v 1.5 2010/01/31 17:06:01 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/kbluetooth/ChangeLog,v 1.6 2010/02/02 06:53:17 ssuominen Exp $
+
+*kbluetooth-0.4 (02 Feb 2010)
+
+ 02 Feb 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +kbluetooth-0.4.ebuild:
+ Version bump.
31 Jan 2010; Samuli Suominen <ssuominen@gentoo.org>
kbluetooth-0.4_rc2.ebuild:
diff --git a/net-wireless/kbluetooth/kbluetooth-0.4.ebuild b/net-wireless/kbluetooth/kbluetooth-0.4.ebuild
new file mode 100644
index 000000000000..80b6b48f8d4e
--- /dev/null
+++ b/net-wireless/kbluetooth/kbluetooth-0.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/kbluetooth/kbluetooth-0.4.ebuild,v 1.1 2010/02/02 06:53:17 ssuominen Exp $
+
+EAPI=2
+KDE_LINGUAS="cs da de en_GB eo es et fr ga gl it km lt nds nl pa pt pt_BR ro
+ru sv tr uk zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="Bluetooth utils for KDE4"
+HOMEPAGE="http://techbase.kde.org/Kbluetooth"
+SRC_URI="http://kde-apps.org/CONTENT/content-files/112110-${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug semantic-desktop"
+
+COMMON_DEPEND=">=kde-base/solid-${KDE_MINIMAL}[bluetooth]
+ >=kde-base/libkworkspace-${KDE_MINIMAL}
+ >=kde-base/libknotificationitem-${KDE_MINIMAL}
+ >=kde-base/kdelibs-${KDE_MINIMAL}[semantic-desktop?]"
+RDEPEND="${COMMON_DEPEND}
+ app-mobilephone/obex-data-server
+ app-mobilephone/obexftp"
+DEPEND="${COMMON_DEPEND}"
+
+DOCS="AUTHORS ChangeLog TODO"
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ sed -e 's/${KDE4WORKSPACE_SOLIDCONTROL_LIBRARY}/solidcontrol/g' \
+ -i src/CMakeLists.txt \
+ -i src/device-manager/CMakeLists.txt \
+ -i src/inputwizard/CMakeLists.txt \
+ || die "Failed to patch CMake files"
+}
+
+src_configure() {
+ mycmakeargs+=( $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano) )
+ kde4-base_src_configure
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+ ewarn "net-wireless/bluez can't work as normal user, so you need to setup"
+ ewarn "your dbus privilege granting yourself, see bug:"
+ ewarn "http://bugs.gentoo.org/279616"
+}