summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-01-29 23:05:12 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-01-29 23:05:12 +0000
commit22dde114ef34055f8a31f39463c22ffd32980071 (patch)
tree4bed537824730434efe84a6b1f140da1761f3087 /net-wireless/libbtctl/libbtctl-0.10.0.ebuild
parentNew and spiffy version of the old eclass. (diff)
downloadgentoo-2-22dde114ef34055f8a31f39463c22ffd32980071.tar.gz
gentoo-2-22dde114ef34055f8a31f39463c22ffd32980071.tar.bz2
gentoo-2-22dde114ef34055f8a31f39463c22ffd32980071.zip
Fix parallel make, bug #235991. Fix effectless sed. Remove old revisions.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-wireless/libbtctl/libbtctl-0.10.0.ebuild')
-rw-r--r--net-wireless/libbtctl/libbtctl-0.10.0.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/net-wireless/libbtctl/libbtctl-0.10.0.ebuild b/net-wireless/libbtctl/libbtctl-0.10.0.ebuild
index ebea93e045c0..d37caad41360 100644
--- a/net-wireless/libbtctl/libbtctl-0.10.0.ebuild
+++ b/net-wireless/libbtctl/libbtctl-0.10.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/libbtctl/libbtctl-0.10.0.ebuild,v 1.2 2008/04/17 19:31:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/libbtctl/libbtctl-0.10.0.ebuild,v 1.3 2009/01/29 23:05:11 eva Exp $
-inherit gnome2 multilib mono autotools
+inherit autotools gnome2 multilib mono
DESCRIPTION="A GObject wrapper for Bluetooth functionality"
HOMEPAGE="http://live.gnome.org/GnomeBluetooth"
@@ -30,7 +30,6 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
doc? ( dev-util/gtk-doc )"
-MAKEOPTS="${MAKEOPTS} -j1"
DOCS="README NEWS ChangeLog AUTHORS COPYING"
src_unpack() {
@@ -39,8 +38,11 @@ src_unpack() {
# Fix multilib
sed -e "s:\/lib\/:\/$(get_libdir)\/:" -i src/Makefile.am
+ # Fix parallel make, bug #235991
+ epatch "${FILESDIR}/${P}-parallel-make.patch"
+
# Fix tests (needed with eautoreconf)
- intltoolize --force
+ intltoolize --force --copy --automake || die "intltoolize failed"
eautoreconf
}
@@ -49,7 +51,8 @@ pkg_setup() {
}
src_compile() {
- sed -i -e 's/libext="a/& la/' libtool
+ gnome2_src_configure
- gnome2_src_compile
+ sed -e 's/libext="a/& la/' -i libtool || die "sed failed"
+ emake || die "compile failure"
}