summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-03-07 10:30:07 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-03-07 10:30:07 +0000
commit9f8897555a085631b65af3c74d0b5a832b17f4ee (patch)
tree8f963ba8bc9450e102188364b75519b84f05e2ca /net-wireless/mate-bluetooth
parentVersion bump. (diff)
downloadgentoo-2-9f8897555a085631b65af3c74d0b5a832b17f4ee.tar.gz
gentoo-2-9f8897555a085631b65af3c74d0b5a832b17f4ee.tar.bz2
gentoo-2-9f8897555a085631b65af3c74d0b5a832b17f4ee.zip
New ebuild for net-wireless/mate-bluetooth, fork of bluez-gnome focused on integration with MATE; imported from the mate-overlay, reviewed and adjusted.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'net-wireless/mate-bluetooth')
-rw-r--r--net-wireless/mate-bluetooth/ChangeLog10
-rw-r--r--net-wireless/mate-bluetooth/files/80-mate-rfkill.rules5
-rw-r--r--net-wireless/mate-bluetooth/mate-bluetooth-1.6.0.ebuild89
-rw-r--r--net-wireless/mate-bluetooth/metadata.xml8
4 files changed, 112 insertions, 0 deletions
diff --git a/net-wireless/mate-bluetooth/ChangeLog b/net-wireless/mate-bluetooth/ChangeLog
new file mode 100644
index 000000000000..baec2d2c9b9f
--- /dev/null
+++ b/net-wireless/mate-bluetooth/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-wireless/mate-bluetooth
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/mate-bluetooth/ChangeLog,v 1.1 2014/03/07 10:30:06 tomwij Exp $
+
+*mate-bluetooth-1.6.0 (07 Mar 2014)
+
+ 07 Mar 2014; Tom Wijsman <TomWij@gentoo.org> +files/80-mate-rfkill.rules,
+ +mate-bluetooth-1.6.0.ebuild, +metadata.xml:
+ New ebuild for net-wireless/mate-bluetooth, fork of bluez-gnome focused on
+ integration with MATE; imported from the mate-overlay, reviewed and adjusted.
diff --git a/net-wireless/mate-bluetooth/files/80-mate-rfkill.rules b/net-wireless/mate-bluetooth/files/80-mate-rfkill.rules
new file mode 100644
index 000000000000..61f9ca5eb0d1
--- /dev/null
+++ b/net-wireless/mate-bluetooth/files/80-mate-rfkill.rules
@@ -0,0 +1,5 @@
+# do not edit this file, it will be overwritten on update
+
+# network
+KERNEL=="rfkill", GROUP="plugdev", MODE="0664"
+
diff --git a/net-wireless/mate-bluetooth/mate-bluetooth-1.6.0.ebuild b/net-wireless/mate-bluetooth/mate-bluetooth-1.6.0.ebuild
new file mode 100644
index 000000000000..dded74f8f255
--- /dev/null
+++ b/net-wireless/mate-bluetooth/mate-bluetooth-1.6.0.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/mate-bluetooth/mate-bluetooth-1.6.0.ebuild,v 1.1 2014/03/07 10:30:06 tomwij Exp $
+
+EAPI="5"
+
+GCONF_DEBUG="yes"
+
+inherit autotools gnome2 multilib user versionator
+
+MATE_BRANCH="$(get_version_component_range 1-2)"
+
+SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
+DESCRIPTION="Fork of bluez-gnome focused on integration with MATE"
+HOMEPAGE="http://mate-desktop.org/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+introspection test"
+
+RESTRICT="test"
+
+COMMON_DEPEND=">=dev-libs/dbus-glib-0.74:0
+ >=dev-libs/glib-2.25.7:2
+ >=x11-libs/gtk+-2.19.1:2
+ >=dev-libs/libunique-1:1
+ >=x11-libs/libnotify-0.7:0"
+
+RDEPEND="${COMMON_DEPEND}
+ app-mobilephone/obexd:0
+ net-wireless/bluez:0=
+ virtual/udev:0
+ virtual/libintl:0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:0 )"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=app-text/mate-doc-utils-1.2.1:0
+ app-text/scrollkeeper:0
+ dev-libs/libxml2:2
+ >=dev-util/gtk-doc-1.9:0
+ >=dev-util/intltool-0.35:0
+ >=mate-base/mate-common-1.6
+ sys-devel/gettext:0
+ sys-libs/glibc:2.2
+ virtual/pkgconfig:0
+ x11-libs/libX11:0
+ x11-libs/libXi:0
+ x11-proto/xproto:0"
+
+src_prepare() {
+ # Fix test
+ sed -i 's:applet/bluetooth-:applet/mate-bluetooth-:g' \
+ po/POTFILES.skip || die
+
+ mate-doc-prepare --force --copy || die
+ mate-doc-common --copy || die
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --disable-desktop-update \
+ --disable-icon-update \
+ --disable-moblin \
+ --disable-schemas-compile
+}
+
+DOCS="AUTHORS README NEWS ChangeLog"
+
+src_install() {
+ gnome2_src_install
+
+ insinto /lib/udev/rules.d/
+ doins "${FILESDIR}"/80-mate-rfkill.rules
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ enewgroup plugdev
+
+ elog "Don't forget to add yourself to the plugdev group "
+ elog "if you want to be able to control the bluetooth transmitter."
+}
diff --git a/net-wireless/mate-bluetooth/metadata.xml b/net-wireless/mate-bluetooth/metadata.xml
new file mode 100644
index 000000000000..dca1781cb290
--- /dev/null
+++ b/net-wireless/mate-bluetooth/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>TomWij@gentoo.org</email>
+ <name>Tom Wijsman</name>
+ </maintainer>
+</pkgmetadata>