summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-02-06 16:53:32 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-02-06 16:53:32 +0000
commita1c281a7dc8dfd2941502f6b02451585ca047bc0 (patch)
tree16f92e9279df940056c488cc731a124e0b5e3c56 /net-wireless/rfkill
parentBump to 1.5.3 (a.k.a. 1.6.0 beta3) (diff)
downloadgentoo-2-a1c281a7dc8dfd2941502f6b02451585ca047bc0.tar.gz
gentoo-2-a1c281a7dc8dfd2941502f6b02451585ca047bc0.tar.bz2
gentoo-2-a1c281a7dc8dfd2941502f6b02451585ca047bc0.zip
Major documentation updates and minor bugfixes.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'net-wireless/rfkill')
-rw-r--r--net-wireless/rfkill/ChangeLog9
-rw-r--r--net-wireless/rfkill/rfkill-0.4.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/net-wireless/rfkill/ChangeLog b/net-wireless/rfkill/ChangeLog
index 2f7aee89dd1d..b22c73fe8ff4 100644
--- a/net-wireless/rfkill/ChangeLog
+++ b/net-wireless/rfkill/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/rfkill
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/rfkill/ChangeLog,v 1.3 2009/12/01 19:02:58 fauli Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/rfkill/ChangeLog,v 1.4 2010/02/06 16:53:32 chainsaw Exp $
+
+*rfkill-0.4 (06 Feb 2010)
+
+ 06 Feb 2010; <chainsaw@gentoo.org> +rfkill-0.4.ebuild:
+ Major documentation updates and minor bugfixes.
01 Dec 2009; Christian Faulhammer <fauli@gentoo.org> rfkill-0.2.ebuild:
add ~x86, bug 293143
diff --git a/net-wireless/rfkill/rfkill-0.4.ebuild b/net-wireless/rfkill/rfkill-0.4.ebuild
new file mode 100644
index 000000000000..bb7e3f78c266
--- /dev/null
+++ b/net-wireless/rfkill/rfkill-0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/rfkill/rfkill-0.4.ebuild,v 1.1 2010/02/06 16:53:32 chainsaw Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to read and control rfkill status through /dev/rfkill"
+HOMEPAGE="http://wireless.kernel.org/en/users/Documentation/rfkill"
+SRC_URI="http://wireless.kernel.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-devel/make"
+
+CC=$(tc-getCC)
+LD=$(tc-getLD)
+
+src_compile() {
+ emake || die "Failed to compile"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Failed to install"
+}