summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-02-10 10:58:08 +0000
committerChristian Heim <phreak@gentoo.org>2007-02-10 10:58:08 +0000
commitc815795fca682ad4b91a6d18b24ed23726d7c318 (patch)
treeafd9a1b4a3ac5280a0734bfa533f3aa50675fb5b /net-wireless/rfswitch/rfswitch-1.1.ebuild
parentRemove libtar automagic, bug #154194 (diff)
downloadgentoo-2-c815795fca682ad4b91a6d18b24ed23726d7c318.tar.gz
gentoo-2-c815795fca682ad4b91a6d18b24ed23726d7c318.tar.bz2
gentoo-2-c815795fca682ad4b91a6d18b24ed23726d7c318.zip
Version bump, also fixing compile issues with kernel >=2.6.19. Thanks to Sebastian T. Hafner <sonix-gentoobugs at own-hero.net> for reporting.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'net-wireless/rfswitch/rfswitch-1.1.ebuild')
-rw-r--r--net-wireless/rfswitch/rfswitch-1.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-wireless/rfswitch/rfswitch-1.1.ebuild b/net-wireless/rfswitch/rfswitch-1.1.ebuild
new file mode 100644
index 000000000000..00c8e385e9b7
--- /dev/null
+++ b/net-wireless/rfswitch/rfswitch-1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/rfswitch/rfswitch-1.1.ebuild,v 1.1 2007/02/10 10:58:08 phreak Exp $
+
+inherit linux-mod
+
+DESCRIPTION="Drivers for software based wireless radio switches"
+HOMEPAGE="http://rfswitch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+RDEPEND=""
+
+BUILD_TARGETS="modules"
+
+MODULE_NAMES="av5100(net/wireless:)
+ pbe5(net/wireless:)"
+MODULESD_AV5100_DOCS="README"
+
+# Use the in-kernel ipw2100 modules
+CONFIG_CHECK="IPW2100"
+ERROR_IPW2100="${P} requires support for ipw2100 (CONFIG_IPW2100)."
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is 2 4 ; then
+ die "${P} does not support building against kernel 2.4.x"
+ fi
+
+ BUILD_PARAMS="KSRC=${KV_DIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ convert_to_m "${S}"/Makefile
+
+ # Compile fixes for >=kernel-2.6.19
+ sed -i "s,#include <linux/config.h>,#include <linux/autoconf.h>," \
+ "${S}"/av5100.c "${S}"/pbe5.c
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc ISSUES
+}