summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2014-04-08 02:36:20 +0000
committerRick Farina <zerochaos@gentoo.org>2014-04-08 02:36:20 +0000
commita99b3f7df8058bfe5f5c076756bc35fa7911d692 (patch)
tree6548341a01702b5786c15ec0f252880c662367fe /net-wireless/ubertooth
parentQA: Dropping ppc stable keyword as libreoffice dropped it. #506294 (diff)
downloadgentoo-2-a99b3f7df8058bfe5f5c076756bc35fa7911d692.tar.gz
gentoo-2-a99b3f7df8058bfe5f5c076756bc35fa7911d692.tar.bz2
gentoo-2-a99b3f7df8058bfe5f5c076756bc35fa7911d692.zip
new release from upstream and live fixes
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-wireless/ubertooth')
-rw-r--r--net-wireless/ubertooth/ChangeLog10
-rw-r--r--net-wireless/ubertooth/metadata.xml1
-rw-r--r--net-wireless/ubertooth/ubertooth-2014.04.1.ebuild116
-rw-r--r--net-wireless/ubertooth/ubertooth-9999.ebuild128
4 files changed, 166 insertions, 89 deletions
diff --git a/net-wireless/ubertooth/ChangeLog b/net-wireless/ubertooth/ChangeLog
index 625a0a0177f4..6027aaf925b2 100644
--- a/net-wireless/ubertooth/ChangeLog
+++ b/net-wireless/ubertooth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/ubertooth
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ubertooth/ChangeLog,v 1.20 2013/04/27 23:07:53 zerochaos Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ubertooth/ChangeLog,v 1.21 2014/04/08 02:36:20 zerochaos Exp $
+
+*ubertooth-2014.04.1 (08 Apr 2014)
+
+ 08 Apr 2014; Rick Farina <zerochaos@gentoo.org> +ubertooth-2014.04.1.ebuild,
+ metadata.xml, ubertooth-9999.ebuild:
+ new release from upstream and live fixes
*ubertooth-2012.10.1-r1 (27 Apr 2013)
diff --git a/net-wireless/ubertooth/metadata.xml b/net-wireless/ubertooth/metadata.xml
index 35b8d4fc5c78..a5ca3ccec704 100644
--- a/net-wireless/ubertooth/metadata.xml
+++ b/net-wireless/ubertooth/metadata.xml
@@ -8,6 +8,7 @@
<longdescription lang="en">
</longdescription>
<use>
+ <flag name="bluez">use bluez to support clock following and scanning</flag>
<flag name="clock_debug">support for clock following an existing local bluetooth connection with bluez</flag>
<flag name="dfu">Install ubertooth-dfu (needed for read/write of firmware)</flag>
<flag name="specan">Enable the ubertooth spectrum analyzer</flag>
diff --git a/net-wireless/ubertooth/ubertooth-2014.04.1.ebuild b/net-wireless/ubertooth/ubertooth-2014.04.1.ebuild
new file mode 100644
index 000000000000..c5d408409744
--- /dev/null
+++ b/net-wireless/ubertooth/ubertooth-2014.04.1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ubertooth/ubertooth-2014.04.1.ebuild,v 1.1 2014/04/08 02:36:20 zerochaos Exp $
+
+EAPI="5"
+
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit multilib distutils cmake-utils
+
+HOMEPAGE="http://ubertooth.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+bluez +dfu +specan +python +ubertooth1-firmware +udev"
+REQUIRED_USE="dfu? ( python )
+ specan? ( python )
+ ubertooth1-firmware? ( dfu )
+ python? ( || ( dfu specan ) )"
+DEPEND="bluez? ( net-wireless/bluez )
+ >=net-libs/libbtbb-2014.02.2:=
+ net-libs/libpcap"
+RDEPEND="${DEPEND}
+ specan? ( virtual/libusb:1
+ >=dev-qt/qtgui-4.7.2:4
+ >=dev-python/pyside-1.0.2
+ >=dev-python/numpy-1.3
+ >=dev-python/pyusb-1.0.0_alpha1 )
+ dfu? ( virtual/libusb:1
+ >=dev-python/pyusb-1.0.0_alpha1 )
+ udev? ( virtual/udev )"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/greatscottgadgets/ubertooth.git"
+ inherit git-r3
+ KEYWORDS=""
+ S="${WORKDIR}/${P}/host"
+else
+ MY_PV=${PV/\./-}
+ MY_PV=${MY_PV/./-R}
+ S="${WORKDIR}/${PN}-${MY_PV}/host"
+ SRC_URI="https://github.com/greatscottgadgets/${PN}/releases/download/${MY_PV}/${PN}-${MY_PV}.tar.xz"
+ #re-add arm keyword after making a lib-only target
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+DESCRIPTION="An open source wireless development platform suitable for Bluetooth experimentation"
+
+#readd firmware building, but do it right
+#USE="-fortran -mudflap -nls -openmp -multilib" crossdev --without-headers --genv 'EXTRA_ECONF="--with-mode=thumb --with-cpu=cortex-m3 --with-float=soft"' -s4 -t arm-cortexm3-eabi
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup;
+ DISTUTILS_SETUP_FILES=()
+ if use dfu; then
+ DISTUTILS_SETUP_FILES+=("${S}/python/usb_dfu|setup.py")
+ PYTHON_MODNAME="dfu"
+ fi
+ if use specan; then
+ DISTUTILS_SETUP_FILES+=("${S}/python/specan_ui|setup.py")
+ PYTHON_MODNAME+=" specan"
+ fi
+ fi
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ use python && distutils_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable bluez USE_BLUEZ)
+ -DDISABLE_PYTHON=true
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ use python && distutils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ insinto /lib/firmware
+ cd "${WORKDIR}/${PN}-${MY_PV}" || die
+ if [[ ${PV} == "9999" ]] ; then
+ ewarn "Firmware isn't available for git releases, we assume you are already"
+ ewarn "on the latest and/or can build your own."
+ else
+ use ubertooth1-firmware && doins ubertooth-one-firmware-bin/bluetooth_rxtx.bin
+ fi
+
+ if use udev; then
+ insinto /lib/udev/rules.d/
+ doins "${S}"/lib${PN}/40-${PN}.rules
+ fi
+
+ use python && distutils_src_install
+
+ elog "Everyone can read from the ubertooth, but to talk to it"
+ elog "your user needs to be in the usb group."
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/net-wireless/ubertooth/ubertooth-9999.ebuild b/net-wireless/ubertooth/ubertooth-9999.ebuild
index 9a2b33a868eb..9e569b632640 100644
--- a/net-wireless/ubertooth/ubertooth-9999.ebuild
+++ b/net-wireless/ubertooth/ubertooth-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ubertooth/ubertooth-9999.ebuild,v 1.19 2013/03/02 23:12:29 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ubertooth/ubertooth-9999.ebuild,v 1.20 2014/04/08 02:36:20 zerochaos Exp $
EAPI="5"
@@ -8,19 +8,20 @@ PYTHON_DEPEND="python? 2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
-inherit multilib distutils
+inherit multilib distutils cmake-utils
HOMEPAGE="http://ubertooth.sourceforge.net/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+dfu clock_debug +specan +python ubertooth0-firmware +ubertooth1-firmware"
+IUSE="+bluez +dfu +specan +python +ubertooth1-firmware +udev"
REQUIRED_USE="dfu? ( python )
specan? ( python )
- ubertooth0-firmware? ( dfu )
ubertooth1-firmware? ( dfu )
python? ( || ( dfu specan ) )"
-DEPEND="clock_debug? ( net-wireless/bluez )"
+DEPEND="bluez? ( net-wireless/bluez )
+ >=net-libs/libbtbb-${PV}:=
+ net-libs/libpcap"
RDEPEND="${DEPEND}
specan? ( virtual/libusb:1
>=dev-qt/qtgui-4.7.2:4
@@ -28,117 +29,79 @@ RDEPEND="${DEPEND}
>=dev-python/numpy-1.3
>=dev-python/pyusb-1.0.0_alpha1 )
dfu? ( virtual/libusb:1
- >=dev-python/pyusb-1.0.0_alpha1 )"
+ >=dev-python/pyusb-1.0.0_alpha1 )
+ udev? ( virtual/udev )"
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="http://git.code.sf.net/p/ubertooth/code"
- EGIT_PROJECT="ubertooth"
- inherit git-2
+ EGIT_REPO_URI="https://github.com/greatscottgadgets/ubertooth.git"
+ inherit git-r3
KEYWORDS=""
- DEPEND="=net-libs/libbtbb-9999"
- RDEPEND="${RDEPEND}
- =net-libs/libbtbb-9999"
- DEPEND="ubertooth0-firmware? ( sys-devel/crossdev )
- ubertooth1-firmware? ( sys-devel/crossdev )"
+ S="${WORKDIR}/${P}/host"
else
- MY_P=${P/\./-}
- MY_P=${MY_P/./-R}
- S=${WORKDIR}/${MY_P}
- SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+ MY_PV=${PV/\./-}
+ MY_PV=${MY_PV/./-R}
+ S="${WORKDIR}/${PN}-${MY_PV}/host"
+ SRC_URI="https://github.com/greatscottgadgets/${PN}/releases/download/${MY_PV}/${PN}-${MY_PV}.tar.xz"
#re-add arm keyword after making a lib-only target
KEYWORDS="~amd64 ~arm ~x86"
- DEPEND=">=net-libs/libbtbb-${PV}"
- RDEPEND="${RDEPEND}
- >=net-libs/libbtbb-${PV}"
fi
DESCRIPTION="An open source wireless development platform suitable for Bluetooth experimentation"
-have_clock_debug() {
- use clock_debug && echo "true" || echo "false"
-}
+#readd firmware building, but do it right
+#USE="-fortran -mudflap -nls -openmp -multilib" crossdev --without-headers --genv 'EXTRA_ECONF="--with-mode=thumb --with-cpu=cortex-m3 --with-float=soft"' -s4 -t arm-cortexm3-eabi
pkg_setup() {
-if [[ ${PV} == "9999" ]] ; then
- #ebegin "arm-none-eabi-gcc"
- #if type -p arm-none-eabi-gcc > /dev/null ; then
- # eend 0
- #else
- # eend 1
- # eerror "Failed to locate 'arm-none-eabi-gcc' in \$PATH. You can install the needed toolchain using:"
- # eerror " $ crossdev --genv 'USE=\"-openmp -fortran\"' -s4 -t arm-none-eabi"
- # die "arm-none-eabi toolchain not found"
- #fi
- ewarn "bypassing live pkg_setup because firmware building doesn't work"
-fi
if use python; then
- #I would prefer like this but we can't multiconditional PYTHON_DEPEND in EAPI4
- #if use dfu || use specan; then
python_pkg_setup;
DISTUTILS_SETUP_FILES=()
if use dfu; then
- DISTUTILS_SETUP_FILES+=("${S}/host/usb_dfu|setup.py")
+ DISTUTILS_SETUP_FILES+=("${S}/python/usb_dfu|setup.py")
PYTHON_MODNAME="dfu"
fi
if use specan; then
- DISTUTILS_SETUP_FILES+=("${S}/host/specan_ui|setup.py")
+ DISTUTILS_SETUP_FILES+=("${S}/python/specan_ui|setup.py")
PYTHON_MODNAME+=" specan"
fi
fi
}
src_prepare() {
+ cmake-utils_src_prepare
use python && distutils_src_prepare
}
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable bluez USE_BLUEZ)
+ -DDISABLE_PYTHON=true
+ )
+ cmake-utils_src_configure
+}
+
src_compile() {
- cd "${S}/host/bluetooth_rxtx" || die
- emake \
- clock_debug="$(have_clock_debug)"
+ cmake-utils_src_compile
use python && distutils_src_compile
- if [[ ${PV} == "9999" ]] ; then
- #cd "${S}"/firmware/bluetooth_rxtx || die
- #if use ubertooth0-firmware; then
- # SVN_REV_NUM="-D'SVN_REV_NUM'=${ESVN_WC_REVISION}" BOARD=UBERTOOTH_ZERO emake -j1
- # mv bluetooth_rxtx.bin bluetooth_rxtx_U0.bin || die
- # emake clean
- #fi
- #if use ubertooth1-firmware; then
- # SVN_REV_NUM="-D'SVN_REV_NUM'=${ESVN_WC_REVISION}" emake -j1
- # mv bluetooth_rxtx.bin bluetooth_rxtx_U1.bin || die
- #fi
- ewarn "bypassing firmware build because the resulting firmware fails"
- fi
}
src_install() {
- cd host || die
- dobin bluetooth_rxtx/ubertooth-dump bluetooth_rxtx/ubertooth-lap \
- bluetooth_rxtx/ubertooth-btle bluetooth_rxtx/ubertooth-uap \
- bluetooth_rxtx/ubertooth-hop bluetooth_rxtx/ubertooth-util
- use clock_debug && dobin bluetooth_rxtx/ubertooth-follow bluetooth_rxtx/ubertooth-scan
-
- use python && distutils_src_install
- use specan && dobin specan_ui/ubertooth-specan-ui
- use dfu && dobin usb_dfu/ubertooth-dfu
-
- dolib.so bluetooth_rxtx/libubertooth.so.0.1
- dosym libubertooth.so.0.1 /usr/$(get_libdir)/libubertooth.so.0
- dosym libubertooth.so.0.1 /usr/$(get_libdir)/libubertooth.so
+ cmake-utils_src_install
insinto /lib/firmware
- cd "${S}"
+ cd "${WORKDIR}/{PN}-${MY_PV}" || die
if [[ ${PV} == "9999" ]] ; then
- #use ubertooth0-firmware && doins firmware/bluetooth_rxtx/bluetooth_rxtx_U0.bin
- #use ubertooth1-firmware && doins firmware/bluetooth_rxtx/bluetooth_rxtx_U1.bin
- ewarn "bypassing firmware install because the built firmware doesn't work"
+ ewarn "Firmware isn't available for git releases, we assume you are already"
+ ewarn "on the latest and/or can build your own."
else
- use ubertooth0-firmware && newins ubertooth-zero-firmware-bin/bluetooth_rxtx.bin bluetooth_rxtx_U0.bin
- use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rxtx.bin bluetooth_rxtx_U1.bin
+ use ubertooth1-firmware && doins ubertooth-one-firmware-bin/bluetooth_rxtx.bin
fi
- insinto /lib/udev/rules.d/
- doins "${S}"/host/bluetooth_rxtx/40-ubertooth.rules
+ if use udev; then
+ insinto /lib/udev/rules.d/
+ doins "${S}"/lib${PN}/40-${PN}.rules
+ fi
+
+ use python && distutils_src_install
elog "Everyone can read from the ubertooth, but to talk to it"
elog "your user needs to be in the usb group."
@@ -146,15 +109,6 @@ src_install() {
pkg_postinst() {
use python && distutils_pkg_postinst
-
- #if use ubertooth0-firmware || use ubertooth1-firmware; then
- # ewarn "currently the firmware builds using cross dev but is completely"
- # ewarn "NON-FUNCTIONAL. This is supported for development only."
- # ewarn "If you do not know what you are doing to NOT install this version"
- # ewarn "of the firmware. If you ignore this warning and break your device"
- # ewarn "you can find repair instructions at ${HOMEPAGE}"
- # ewarn "You have been warned."
- #fi
}
pkg_postrm() {