summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-12-19 17:22:29 +0000
committerRoy Marples <uberlord@gentoo.org>2006-12-19 17:22:29 +0000
commit6d3ae16d727c2e6a244cf839930ad428e8659131 (patch)
treed328c8959936836853f2d25f1d8aa14b908fac89 /net-wireless
parentPunt old versions (diff)
downloadgentoo-2-6d3ae16d727c2e6a244cf839930ad428e8659131.tar.gz
gentoo-2-6d3ae16d727c2e6a244cf839930ad428e8659131.tar.bz2
gentoo-2-6d3ae16d727c2e6a244cf839930ad428e8659131.zip
debug USE flag now requires CONFIG_DEBUG_FS to be enabled in the kernel.
(Portage version: 2.1.2_rc3-r7)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/rt2x00/ChangeLog5
-rw-r--r--net-wireless/rt2x00/rt2x00-9999.ebuild16
2 files changed, 18 insertions, 3 deletions
diff --git a/net-wireless/rt2x00/ChangeLog b/net-wireless/rt2x00/ChangeLog
index 2fb5044b2149..71d50a070846 100644
--- a/net-wireless/rt2x00/ChangeLog
+++ b/net-wireless/rt2x00/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-wireless/rt2x00
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/rt2x00/ChangeLog,v 1.18 2006/11/23 14:53:03 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/rt2x00/ChangeLog,v 1.19 2006/12/19 17:22:29 uberlord Exp $
+
+ 19 Dec 2006; Roy Marples <uberlord@gentoo.org> rt2x00-9999.ebuild:
+ debug USE flag now requires CONFIG_DEBUG_FS to be enabled in the kernel.
23 Nov 2006; Roy Marples <uberlord@gentoo.org> rt2x00-9999.ebuild:
Drop the eeprom USE flag and build the module when any pci devices are built.
diff --git a/net-wireless/rt2x00/rt2x00-9999.ebuild b/net-wireless/rt2x00/rt2x00-9999.ebuild
index 90894aec0f07..475988c038ab 100644
--- a/net-wireless/rt2x00/rt2x00-9999.ebuild
+++ b/net-wireless/rt2x00/rt2x00-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/rt2x00/rt2x00-9999.ebuild,v 1.17 2006/11/23 14:53:03 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/rt2x00/rt2x00-9999.ebuild,v 1.18 2006/12/19 17:22:29 uberlord Exp $
inherit linux-mod cvs
@@ -52,6 +52,11 @@ pkg_setup() {
ERROR_FW_LOADER="${P} requires support for Firmware module loading (CONFIG_FW_LOADER)."
fi
+ if use debug ; then
+ CONFIG_CHECK="${CONFIG_CHECK} DEBUG_FS"
+ ERROR_DEBUG_FS="${P} requires Kernel Debug FS support (CONFIG_DEBUG_FS)"
+ fi
+
kernel_is lt 2 6 17 && die "${P} requires at least kernel 2.6.17"
linux-mod_pkg_setup
BUILD_PARAMS="KERNDIR=${KV_DIR} KERNOUT=${KV_OUT_DIR}"
@@ -80,8 +85,15 @@ src_compile() {
# Generate the config file now
echo "# Config file generated by portage" > config
-
MODULE_NAMES="80211(rt2x00:) rc80211_simple(rt2x00:)"
+
+ # Enable the new DEBUGFS module
+ if use debug ; then
+ echo "CONFIG_RT2X00_DEBUGFS=y" >> config
+ echo "CONFIG_RT2X00_DEBUGFS_ASM=${asm}" >> config
+ MODULE_NAMES="${MODULE_NAMES} rt2x00debug(rt2x00:)"
+ fi
+
# RT61 and RT73 require CONFIG_CRC_ITU_T
if [[ ${full} == "y" ]] || \
use rt61pci || use rt73usb ; then