summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-02-19 22:27:11 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-02-19 22:27:11 +0000
commitd4ed9fdf59a002b02528fb594ee3d9e4e84d17b6 (patch)
treec8b753f4ecc1e7852ff19c0801ba0a2e2afb5b17 /net-wireless
parentFix ebuild header, bug 403705. (diff)
downloadgentoo-2-d4ed9fdf59a002b02528fb594ee3d9e4e84d17b6.tar.gz
gentoo-2-d4ed9fdf59a002b02528fb594ee3d9e4e84d17b6.tar.bz2
gentoo-2-d4ed9fdf59a002b02528fb594ee3d9e4e84d17b6.zip
Bug #404573: import old ebuilds from wispy-tools package, along with all fixes in those ebuilds. This includes an old stable keyword as well.
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/spectools/ChangeLog15
-rw-r--r--net-wireless/spectools/files/spectools-2009.02.1-libusb-compat.patch20
-rw-r--r--net-wireless/spectools/files/spectools-2009.02.1-udev-rules.patch32
-rw-r--r--net-wireless/spectools/metadata.xml9
-rw-r--r--net-wireless/spectools/spectools-2006.03.1.ebuild49
-rw-r--r--net-wireless/spectools/spectools-2006.09.1.ebuild49
-rw-r--r--net-wireless/spectools/spectools-2009.02.1.ebuild72
-rw-r--r--net-wireless/spectools/spectools-2011.08.1-r1.ebuild73
8 files changed, 316 insertions, 3 deletions
diff --git a/net-wireless/spectools/ChangeLog b/net-wireless/spectools/ChangeLog
index 3df73271ec52..91b68ff42f39 100644
--- a/net-wireless/spectools/ChangeLog
+++ b/net-wireless/spectools/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for net-wireless/spectools
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/spectools/ChangeLog,v 1.1 2012/02/17 03:30:54 steev Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/spectools/ChangeLog,v 1.2 2012/02/19 22:27:11 robbat2 Exp $
+
+*spectools-2006.03.1 (19 Feb 2012)
+*spectools-2006.09.1 (19 Feb 2012)
+*spectools-2011.08.1-r1 (19 Feb 2012)
+*spectools-2009.02.1 (19 Feb 2012)
+
+ 19 Feb 2012; Robin H. Johnson <robbat2@gentoo.org>
+ +files/spectools-2009.02.1-libusb-compat.patch,
+ +files/spectools-2009.02.1-udev-rules.patch, +spectools-2006.03.1.ebuild,
+ +spectools-2006.09.1.ebuild, +spectools-2009.02.1.ebuild,
+ +spectools-2011.08.1-r1.ebuild, metadata.xml:
+ Bug #404573: import old ebuilds from wispy-tools package, along with all fixes
+ in those ebuilds. This includes an old stable keyword as well.
*spectools-2011.08.1 (17 Feb 2012)
diff --git a/net-wireless/spectools/files/spectools-2009.02.1-libusb-compat.patch b/net-wireless/spectools/files/spectools-2009.02.1-libusb-compat.patch
new file mode 100644
index 000000000000..589e2253fca6
--- /dev/null
+++ b/net-wireless/spectools/files/spectools-2009.02.1-libusb-compat.patch
@@ -0,0 +1,20 @@
+diff -Nuar spectools-2009-02-R1.orig/wispy_hw_dbx.c spectools-2009-02-R1/wispy_hw_dbx.c
+--- spectools-2009-02-R1.orig/wispy_hw_dbx.c 2009-02-03 13:41:16.000000000 -0800
++++ spectools-2009-02-R1/wispy_hw_dbx.c 2012-02-19 14:12:20.516850122 -0800
+@@ -589,15 +589,13 @@
+ return auxptr->sockpair[0];
+ }
+
+-extern int usb_debug;
+-
+ int wispydbx_usb_open(wispy_phy *phydev) {
+ int pid_status;
+ struct usb_dev_handle *wispy;
+ wispydbx_usb_aux *auxptr = (wispydbx_usb_aux *) phydev->auxptr;
+ wispydbx_startsweep startcmd;
+
+- usb_debug = 1024;
++ usb_set_debug(1024);
+
+ /* Make the client/server socketpair */
+ if (socketpair(PF_UNIX, SOCK_DGRAM, 0, auxptr->sockpair) < 0) {
diff --git a/net-wireless/spectools/files/spectools-2009.02.1-udev-rules.patch b/net-wireless/spectools/files/spectools-2009.02.1-udev-rules.patch
new file mode 100644
index 000000000000..712f92838b95
--- /dev/null
+++ b/net-wireless/spectools/files/spectools-2009.02.1-udev-rules.patch
@@ -0,0 +1,32 @@
+diff -Nuar --exclude '*~' --exclude others-menu spectools-2009-02-R1.orig/99-wispy.rules spectools-2009-02-R1/99-wispy.rules
+--- spectools-2009-02-R1.orig/99-wispy.rules 2007-05-19 09:49:21.000000000 -0700
++++ spectools-2009-02-R1/99-wispy.rules 2009-03-05 18:10:22.984352068 -0800
+@@ -1,4 +1,10 @@
+-# Two vid/pid pairs for Wispy1 USB dongle
+-ATTRS{idVendor}=="1781", ATTRS{idProduct}=="083e", MODE="0660", GROUP="plugdev"
++# Wispy1 rev a
+ ATTRS{idVendor}=="04b4", ATTRS{idProduct}=="0bad", MODE="0660", GROUP="plugdev"
++# Wispy1 rev b
++ATTRS{idVendor}=="1781", ATTRS{idProduct}=="083e", MODE="0660", GROUP="plugdev"
++# WiSpy 2.4x
+ ATTRS{idVendor}=="1781", ATTRS{idProduct}=="083f", MODE="0660", GROUP="plugdev"
++# WiSpy DBx
++ATTRS{idVendor}=="1dd5", ATTRS{idProduct}=="5000", MODE="0660", GROUP="plugdev"
++
++# vim: ft=udevrules:
+diff -Nuar --exclude '*~' --exclude others-menu spectools-2009-02-R1.orig/pkg-hildon/etc/udev/rules.d/99-wispy.rules spectools-2009-02-R1/pkg-hildon/etc/udev/rules.d/99-wispy.rules
+--- spectools-2009-02-R1.orig/pkg-hildon/etc/udev/rules.d/99-wispy.rules 2007-12-21 23:05:49.000000000 -0800
++++ spectools-2009-02-R1/pkg-hildon/etc/udev/rules.d/99-wispy.rules 2009-03-05 18:10:19.800286330 -0800
+@@ -1,4 +1,10 @@
+-# Two vid/pid pairs for Wispy1 USB dongle
+-ATTRS{idVendor}=="1781", ATTRS{idProduct}=="083e", MODE="0660", OWNER="user"
++# Wispy1 rev a
+ ATTRS{idVendor}=="04b4", ATTRS{idProduct}=="0bad", MODE="0660", OWNER="user"
++# Wispy1 rev b
++ATTRS{idVendor}=="1781", ATTRS{idProduct}=="083e", MODE="0660", OWNER="user"
++# WiSpy 2.4x
+ ATTRS{idVendor}=="1781", ATTRS{idProduct}=="083f", MODE="0660", OWNER="user"
++# WiSpy DBx
++ATTRS{idVendor}=="1dd5", ATTRS{idProduct}=="5000", MODE="0660", OWNER="user"
++
++# vim: ft=udevrules:
diff --git a/net-wireless/spectools/metadata.xml b/net-wireless/spectools/metadata.xml
index 59c8cc99fd07..e267ef3d3dc9 100644
--- a/net-wireless/spectools/metadata.xml
+++ b/net-wireless/spectools/metadata.xml
@@ -10,9 +10,14 @@
<email>steev@gentoo.org</email>
<name>Steev Klimaszewski</name>
<description>Proxy-maintainer, CC him on bugs</description>
-</maintainer>
+ </maintainer>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ <description>Maintainer, has 1st gen WiSpy hardware for testing</description>
+ </maintainer>
<use>
- <flag name="debug">Build the raw output client for spectools. This is only needed for developing spectools.</flag>
+ <flag name="debug">Build the raw output client for spectools.</flag>
<flag name="ncurses">Build the ncurses based client for spectools</flag>
<flag name="gtk">Build the gtk-2 based client for spectools</flag>
</use>
diff --git a/net-wireless/spectools/spectools-2006.03.1.ebuild b/net-wireless/spectools/spectools-2006.03.1.ebuild
new file mode 100644
index 000000000000..f27e51dd4aff
--- /dev/null
+++ b/net-wireless/spectools/spectools-2006.03.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/spectools/spectools-2006.03.1.ebuild,v 1.1 2012/02/19 22:27:11 robbat2 Exp $
+
+MY_PN=wispy-tools
+MY_PV=${PV/\./-}
+MY_PV=${MY_PV/./-R}
+MY_P="${MY_PN}-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Tools for the MetaGeek Wi-Spy spectrum analyzer"
+HOMEPAGE="http://www.kismetwireless.net/wispy.shtml"
+SRC_URI="http://www.kismetwireless.net/code/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="debug gtk ncurses"
+
+DEPEND="=virtual/libusb-0*
+ ncurses? ( sys-libs/ncurses )
+ gtk? ( || ( =x11-libs/gtk+-1.2* =x11-libs/gtk+-2* ) )"
+
+src_compile() {
+ econf || die "econf failed"
+
+ emake wispy_log || die "emake wispy_log failed"
+
+ if use debug; then
+ emake wispy_raw || die "emake wispy_raw failed"
+ fi
+
+ if use ncurses; then
+ emake wispy_curses || die "emake wispy_curses failed"
+ fi
+
+ if use gtk; then
+ emake wispy_gtk || die "emake wispy_gtk failed"
+ fi
+}
+
+src_install() {
+ dobin wispy_log
+ use debug && dobin wispy_raw
+ use ncurses && dobin wispy_curses
+ use gtk && dobin wispy_gtk
+
+ dodoc README
+}
diff --git a/net-wireless/spectools/spectools-2006.09.1.ebuild b/net-wireless/spectools/spectools-2006.09.1.ebuild
new file mode 100644
index 000000000000..edad9cc20970
--- /dev/null
+++ b/net-wireless/spectools/spectools-2006.09.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/spectools/spectools-2006.09.1.ebuild,v 1.1 2012/02/19 22:27:11 robbat2 Exp $
+
+MY_PN=wispy-tools
+MY_PV=${PV/\./-}
+MY_PV=${MY_PV/./-R}
+MY_P="${MY_PN}-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Tools for the MetaGeek Wi-Spy spectrum analyzer"
+HOMEPAGE="http://www.kismetwireless.net/wispy.shtml"
+SRC_URI="http://www.kismetwireless.net/code/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug gtk ncurses"
+
+DEPEND="=virtual/libusb-0*
+ ncurses? ( sys-libs/ncurses )
+ gtk? ( =x11-libs/gtk+-2* )"
+
+src_compile() {
+ econf $(use_with gtk gtk-version 2) || die "econf failed"
+
+ emake wispy_log || die "emake wispy_log failed"
+
+ if use debug; then
+ emake wispy_raw || die "emake wispy_raw failed"
+ fi
+
+ if use ncurses; then
+ emake wispy_curses || die "emake wispy_curses failed"
+ fi
+
+ if use gtk; then
+ emake wispy_gtk || die "emake wispy_gtk failed"
+ fi
+}
+
+src_install() {
+ dobin wispy_log
+ use debug && dobin wispy_raw
+ use ncurses && dobin wispy_curses
+ use gtk && dobin wispy_gtk
+
+ dodoc README
+}
diff --git a/net-wireless/spectools/spectools-2009.02.1.ebuild b/net-wireless/spectools/spectools-2009.02.1.ebuild
new file mode 100644
index 000000000000..38b3f66108c5
--- /dev/null
+++ b/net-wireless/spectools/spectools-2009.02.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/spectools/spectools-2009.02.1.ebuild,v 1.1 2012/02/19 22:27:11 robbat2 Exp $
+
+inherit eutils
+
+MY_PN=${PN}
+MY_PV=${PV/\./-}
+MY_PV=${MY_PV/./-R}
+MY_P="${MY_PN}-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Tools for the MetaGeek Wi-Spy spectrum analyzer"
+HOMEPAGE="http://www.kismetwireless.net/spectools/"
+SRC_URI="http://www.kismetwireless.net/code/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug gtk ncurses"
+
+DEPEND="=virtual/libusb-0*
+ ncurses? ( sys-libs/ncurses )
+ gtk? ( =x11-libs/gtk+-2* )"
+# Maemo: Add hildon and bbus
+RDEPEND="${DEPEND}
+ >=sys-fs/udev-114"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/spectools-2009.02.1-udev-rules.patch
+ epatch "${FILESDIR}"/spectools-2009.02.1-libusb-compat.patch
+}
+
+src_compile() {
+ econf $(use_with gtk gtk-version 2) || die "econf failed"
+
+ emake depend || die "emake depend failed"
+
+ emake spectool_{raw,net} \
+ || die "emake spectool_{raw,net} failed"
+
+ if use ncurses; then
+ emake spectool_curses \
+ || die "emake spectool_curses failed"
+ fi
+
+ if use gtk; then
+ emake spectool_gtk \
+ || die "emake spectool_gtk failed"
+ fi
+
+ #if use maemo; then
+ # emake spectool_hildon usbcontrol \
+ # || die "emake spectool_hildon usbcontrol failed"
+ #fi
+}
+
+src_install() {
+ dobin spectool_raw spectool_net
+ use ncurses && dobin spectool_curses
+ use gtk && dobin spectool_gtk
+ dodoc README
+
+ insinto /etc/udev/rules.d/
+ doins 99-wispy.rules
+
+ #if use maemo; then
+ # dobin spectool_hildon
+ # dosbin usbcontrol
+ #fi
+}
diff --git a/net-wireless/spectools/spectools-2011.08.1-r1.ebuild b/net-wireless/spectools/spectools-2011.08.1-r1.ebuild
new file mode 100644
index 000000000000..e754c3dc3e0b
--- /dev/null
+++ b/net-wireless/spectools/spectools-2011.08.1-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/spectools/spectools-2011.08.1-r1.ebuild,v 1.1 2012/02/19 22:27:11 robbat2 Exp $
+
+EAPI=4
+
+inherit toolchain-funcs eutils
+
+MY_PN=${PN}
+MY_PV=${PV/\./-}
+MY_PV=${MY_PV/./-R}
+MY_P="${MY_PN}-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="IEEE 802.11 wireless LAN sniffer for MetaGeek Wi-Spy spectrum analyzer hardware"
+HOMEPAGE="http://www.kismetwireless.net/spectools/"
+
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="https://www.kismetwireless.net/code/svn/tools/spectools"
+ inherit subversion
+ KEYWORDS=""
+else
+ SRC_URI="http://www.kismetwireless.net/code/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ncurses gtk"
+
+DEPEND="${RDEPEND}"
+RDEPEND="virtual/libusb:0
+ ncurses? ( sys-libs/ncurses )
+ gtk? ( =x11-libs/gtk+-2* )"
+# Upstream has still not migrated to the libusb-1 line.
+# Maemo: Add hildon and bbus
+
+# Please note that upstream removed the --with-gtk-version option
+# and GTK is now automagical. GTK1 support was also removed.
+src_compile() {
+ emake depend
+
+ emake spectool_net spectool_raw
+
+ if use ncurses; then
+ emake spectool_curses
+ fi
+
+ if use gtk; then
+ emake spectool_gtk
+ fi
+
+ #if use maemo; then
+ # emake spectool_hildon usbcontrol \
+ # || die "emake spectool_hildon usbcontrol failed"
+ #fi
+}
+
+src_install() {
+ dobin spectool_net spectool_raw
+ use ncurses && dobin spectool_curses
+ use gtk && dobin spectool_gtk
+
+ dodir /$(get_libdir)/udev/rules.d/
+ insinto /$(get_libdir)/udev/rules.d/
+ doins 99-wispy.rules
+ dodoc README
+
+ #if use maemo; then
+ # dobin spectool_hildon
+ # dosbin usbcontrol
+ #fi
+}