summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2010-01-16 13:08:59 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2010-01-16 13:08:59 +0000
commite89a7e7da06f86ae79e0b2ee81e947edd7bdd4e0 (patch)
treea2b4233456921a89840bfb94b1bfa52a9b9b2e2f /net-wireless
parentInitial commit of treesize application. Fixes bug #269236 (diff)
downloadgentoo-2-e89a7e7da06f86ae79e0b2ee81e947edd7bdd4e0.tar.gz
gentoo-2-e89a7e7da06f86ae79e0b2ee81e947edd7bdd4e0.tar.bz2
gentoo-2-e89a7e7da06f86ae79e0b2ee81e947edd7bdd4e0.zip
Bumping to 0.7.0
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/hostapd/ChangeLog9
-rw-r--r--net-wireless/hostapd/files/hostapd-0.7.0-fix_linking.patch39
-rw-r--r--net-wireless/hostapd/hostapd-0.7.0.ebuild194
-rw-r--r--net-wireless/hostapd/metadata.xml1
4 files changed, 242 insertions, 1 deletions
diff --git a/net-wireless/hostapd/ChangeLog b/net-wireless/hostapd/ChangeLog
index 7ce1fb62def7..2220b19a9b93 100644
--- a/net-wireless/hostapd/ChangeLog
+++ b/net-wireless/hostapd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-wireless/hostapd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.104 2010/01/14 14:36:18 gurligebis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.105 2010/01/16 13:08:58 gurligebis Exp $
+
+*hostapd-0.7.0 (16 Jan 2010)
+
+ 16 Jan 2010; Bjarke Istrup Pedersen <gurligebis@gentoo.org>
+ +hostapd-0.7.0.ebuild, +files/hostapd-0.7.0-fix_linking.patch,
+ metadata.xml:
+ Bumping to 0.7.0
*hostapd-0.6.10 (14 Jan 2010)
diff --git a/net-wireless/hostapd/files/hostapd-0.7.0-fix_linking.patch b/net-wireless/hostapd/files/hostapd-0.7.0-fix_linking.patch
new file mode 100644
index 000000000000..89c3f6fe3180
--- /dev/null
+++ b/net-wireless/hostapd/files/hostapd-0.7.0-fix_linking.patch
@@ -0,0 +1,39 @@
+From: Jouni Malinen <j@w1.fi>
+Date: Sat, 16 Jan 2010 08:38:53 +0000 (+0200)
+Subject: Fix linking of nt_password_hash
+X-Git-Url: http://hostap.epitest.fi/gitweb/gitweb.cgi?p=hostap.git;a=commitdiff_plain;h=73b217570c2dabcf409a19e746c6a929f88a5781
+
+Fix linking of nt_password_hash
+
+Need to use conditional linking of some crypto functionality and add
+couple of additional object files. [Bug 343]
+---
+
+diff --git a/hostapd/Makefile b/hostapd/Makefile
+index d94ceb9..6594df0 100644
+--- a/hostapd/Makefile
++++ b/hostapd/Makefile
+@@ -749,11 +749,22 @@ endif
+ hostapd_cli: $(OBJS_c)
+ $(CC) $(LDFLAGS) -o hostapd_cli $(OBJS_c) $(LIBS_c)
+
+-NOBJS = nt_password_hash.o ../src/crypto/ms_funcs.o $(SHA1OBJS) ../src/crypto/rc4.o ../src/crypto/md5.o
++NOBJS = nt_password_hash.o ../src/crypto/ms_funcs.o $(SHA1OBJS) ../src/crypto/md5.o
++ifdef NEED_RC4
++ifdef CONFIG_INTERNAL_RC4
++NOBJS += ../src/crypto/rc4.o
++endif
++endif
+ ifdef CONFIG_INTERNAL_MD5
+ NOBJS += ../src/crypto/md5-internal.o
+ endif
+ NOBJS += ../src/crypto/crypto_openssl.o ../src/utils/os_$(CONFIG_OS).o
++NOBJS += ../src/utils/wpa_debug.o
++NOBJS += ../src/utils/wpabuf.o
++ifdef CONFIG_WPA_TRACE
++NOBJS += ../src/utils/trace.o
++LIBS_n += -lbfd
++endif
+ ifdef TLS_FUNCS
+ LIBS_n += -lcrypto
+ endif
diff --git a/net-wireless/hostapd/hostapd-0.7.0.ebuild b/net-wireless/hostapd/hostapd-0.7.0.ebuild
new file mode 100644
index 000000000000..a3028a8117c7
--- /dev/null
+++ b/net-wireless/hostapd/hostapd-0.7.0.ebuild
@@ -0,0 +1,194 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.7.0.ebuild,v 1.1 2010/01/16 13:08:58 gurligebis Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="IEEE 802.11 wireless LAN Host AP daemon"
+HOMEPAGE="http://hostap.epitest.fi"
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug ipv6 logwatch madwifi +ssl +wps"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ >=dev-libs/libnl-1.1
+ madwifi? ( ||
+ ( >net-wireless/madwifi-ng-tools-0.9.3
+ net-wireless/madwifi-old ) )"
+RDEPEND="${RDEPEND}"
+
+S="${S}/hostapd"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix_linking.patch"
+ sed -i -e "s:/etc/hostapd:/etc/hostapd/hostapd:g" \
+ "${S}/hostapd.conf"
+}
+
+src_configure() {
+ local CONFIG="${S}/.config"
+
+ # toolchain setup
+ echo "CC = $(tc-getCC)" > ${CONFIG}
+
+ # EAP authentication methods
+ echo "CONFIG_EAP=y" >> ${CONFIG}
+ echo "CONFIG_EAP_MD5=y" >> ${CONFIG}
+
+ if use ssl; then
+ # SSL authentication methods
+ echo "CONFIG_EAP_TLS=y" >> ${CONFIG}
+ echo "CONFIG_EAP_TTLS=y" >> ${CONFIG}
+ echo "CONFIG_EAP_MSCHAPV2=y" >> ${CONFIG}
+ echo "CONFIG_EAP_PEAP=y" >> ${CONFIG}
+ fi
+
+ if use wps; then
+ # Enable Wi-Fi Protected Setup
+ echo "CONFIG_WPS=y" >> ${CONFIG}
+ echo "CONFIG_WPS_UPNP=y" >> ${CONFIG}
+ einfo "Enabling Wi-Fi Protected Setup support"
+ fi
+
+ echo "CONFIG_EAP_GTC=y" >> ${CONFIG}
+ echo "CONFIG_EAP_SIM=y" >> ${CONFIG}
+ echo "CONFIG_EAP_AKA=y" >> ${CONFIG}
+ echo "CONFIG_EAP_PAX=y" >> ${CONFIG}
+ echo "CONFIG_EAP_PSK=y" >> ${CONFIG}
+ echo "CONFIG_EAP_SAKE=y" >> ${CONFIG}
+ echo "CONFIG_EAP_GPSK=y" >> ${CONFIG}
+ echo "CONFIG_EAP_GPSK_SHA256=y" >> ${CONFIG}
+
+ einfo "Enabling drivers: "
+
+ # drivers
+ echo "CONFIG_DRIVER_HOSTAP=y" >> ${CONFIG}
+ einfo " HostAP driver enabled"
+ echo "CONFIG_DRIVER_WIRED=y" >> ${CONFIG}
+ einfo " Wired driver enabled"
+ echo "CONFIG_DRIVER_PRISM54=y" >> ${CONFIG}
+ einfo " Prism54 driver enabled"
+ echo "CONFIG_DRIVER_NONE=y" >> ${CONFIG}
+ einfo " None driver enabled"
+
+ if use madwifi; then
+ # Add include path for madwifi-driver headers
+ einfo " Madwifi driver enabled"
+ echo "CFLAGS += -I/usr/include/madwifi" >> ${CONFIG}
+ echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
+ else
+ einfo " Madwifi driver disabled"
+ fi
+
+ einfo " nl80211 driver enabled"
+ echo "CONFIG_DRIVER_NL80211=y" >> ${CONFIG}
+ echo "CFLAGS += -I/usr/include/netlink" >> ${CONFIG}
+ echo "LIBS += -L/usr/lib" >> ${CONFIG}
+
+ # misc
+ echo "CONFIG_PKCS12=y" >> ${CONFIG}
+ echo "CONFIG_RADIUS_SERVER=y" >> ${CONFIG}
+ echo "CONFIG_IAPP=y" >> ${CONFIG}
+ echo "CONFIG_IEEE80211R=y" >> ${CONFIG}
+ echo "CONFIG_IEEE80211W=y" >> ${CONFIG}
+ echo "CONFIG_IEEE80211N=y" >> ${CONFIG}
+ echo "CONFIG_PEERKEY=y" >> ${CONFIG}
+ echo "CONFIG_RSN_PREAUTH=y" >> ${CONFIG}
+
+ if use ipv6; then
+ # IPv6 support
+ echo "CONFIG_IPV6=y" >> ${CONFIG}
+ fi
+
+ if ! use debug; then
+ echo "CONFIG_NO_STDOUT_DEBUG=y" >> ${CONFIG}
+ fi
+
+ # TODO: Add support for BSD drivers
+
+ default_src_configure
+}
+
+src_compile() {
+ default_src_compile
+
+ #emake || die "emake failed"
+
+ if use ssl; then
+ emake nt_password_hash || die "emake nt_password_hash failed"
+ emake hlr_auc_gw || die "emake hlr_auc_gw failed"
+ fi
+}
+
+src_install() {
+ insinto /etc/hostapd
+ doins hostapd.conf hostapd.accept hostapd.deny \
+ hostapd.eap_user hostapd.radius_clients hostapd.sim_db hostapd.wpa_psk
+
+ dosbin hostapd
+ dobin hostapd_cli
+
+ use ssl && dobin nt_password_hash
+ use ssl && dobin hlr_auc_gw
+
+ newinitd "${FILESDIR}"/${PN}-init.d hostapd
+ newconfd "${FILESDIR}"/${PN}-conf.d hostapd
+
+ doman hostapd.8 hostapd_cli.1
+
+ dodoc ChangeLog README
+ if use wps; then
+ dodoc README-WPS
+ fi
+
+ docinto examples
+ dodoc wired.conf
+
+ if use logwatch; then
+ insinto /etc/log.d/conf/services/
+ doins logwatch/hostapd.conf
+
+ exeinto /etc/log.d/scripts/services/
+ doexe logwatch/hostapd
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "In order to use ${PN} you need to set up your wireless card"
+ einfo "for master mode in /etc/conf.d/net and then start"
+ einfo "/etc/init.d/hostapd."
+ einfo
+ einfo "Example configuration:"
+ einfo
+ einfo "config_wlan0=( \"192.168.1.1/24\" )"
+ einfo "channel_wlan0=\"6\""
+ einfo "essid_wlan0=\"test\""
+ einfo "mode_wlan0=\"master\""
+ einfo
+ if use madwifi; then
+ einfo "This package compiles against the headers installed by"
+ einfo "madwifi-old, madwifi-ng or madwifi-ng-tools."
+ einfo "You should remerge ${PN} after upgrading these packages."
+ einfo
+ einfo "Since you are using the madwifi-ng driver, you should disable or"
+ einfo "comment out wme_enabled from hostapd.conf, since it will"
+ einfo "cause problems otherwise (see bug #260377"
+ fi
+ #if [ -e "${KV_DIR}"/net/mac80211 ]; then
+ # einfo "This package now compiles against the headers installed by"
+ # einfo "the kernel source for the mac80211 driver. You should "
+ # einfo "re-emerge ${PN} after upgrading your kernel source."
+ #fi
+
+ if use wps; then
+ einfo "You have enabled Wi-Fi Protected Setup support, please"
+ einfo "read the README-WPS file in /usr/share/doc/${P}"
+ einfo "for info on how to use WPS"
+ fi
+}
diff --git a/net-wireless/hostapd/metadata.xml b/net-wireless/hostapd/metadata.xml
index 604fe6fffc2e..fa5567a9bda8 100644
--- a/net-wireless/hostapd/metadata.xml
+++ b/net-wireless/hostapd/metadata.xml
@@ -12,6 +12,7 @@
RADIUS Authentication client, RADIUS Accounting client
</longdescription>
<use>
+ <flag name='debug'>Enables debuggin</flag>
<flag name='logwatch'>Install support files for
<pkg>sys-app/logwatch</pkg></flag>
<flag name='madwifi'>Add support for madwifi (Atheros chipset)</flag>