summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-06-11 07:54:56 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-06-11 07:54:56 +0000
commitef8b9c72b0602f10de54d1b3d81985f246453697 (patch)
tree57f9128e91f5d0bba5757c15711c49a5b8c3848f /net-wireless
parentFixing bug 21050 (diff)
downloadgentoo-2-ef8b9c72b0602f10de54d1b3d81985f246453697.tar.gz
gentoo-2-ef8b9c72b0602f10de54d1b3d81985f246453697.tar.bz2
gentoo-2-ef8b9c72b0602f10de54d1b3d81985f246453697.zip
Fixing bug 21050
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/hostap/ChangeLog7
-rw-r--r--net-wireless/hostap/Manifest4
-rw-r--r--net-wireless/hostap/files/digest-hostap-0.0.3-r11
-rw-r--r--net-wireless/hostap/hostap-0.0.3-r1.ebuild160
4 files changed, 169 insertions, 3 deletions
diff --git a/net-wireless/hostap/ChangeLog b/net-wireless/hostap/ChangeLog
index 676bff4f269f..f2800f64e03a 100644
--- a/net-wireless/hostap/ChangeLog
+++ b/net-wireless/hostap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/hostap
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap/ChangeLog,v 1.15 2003/05/24 04:48:39 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap/ChangeLog,v 1.16 2003/06/11 07:54:48 phosphan Exp $
+
+*hostap-0.0.3-r1 (11 Jun 2003)
+
+ 11 Jun 2003; Patrick Kursawe <phosphan@gentoo.org> hostap-0.0.3-r1.ebuild:
+ Fixed(?) bug 21050, finally. Did not install all built drivers.
*hostap-0.0.3 (24 May 2003)
diff --git a/net-wireless/hostap/Manifest b/net-wireless/hostap/Manifest
index e079c537cca8..01d86e78531c 100644
--- a/net-wireless/hostap/Manifest
+++ b/net-wireless/hostap/Manifest
@@ -2,8 +2,8 @@ MD5 0cccc8dc56ab904fd60590fd9a5066ac hostap-0.0.2-r1.ebuild 4289
MD5 1792c1d78c928fa0e303eb5c36860bf3 hostap-0.0.1.ebuild 4295
MD5 e39e12c78112afb3d4dd0dfa135ae609 hostap-0.0.3.ebuild 4285
MD5 9a707000b69439cec58c9bee73c84583 hostap-0.0.2.ebuild 4295
-MD5 f809c07b593ba4c09680c008118eb330 ChangeLog 2745
-MD5 ed1b95e5835e935d540fecdf39ecc371 hostap-0.0.3-r1.ebuild 4275
+MD5 40d5119af1d56c6d0dec4762f697948f ChangeLog 2746
+MD5 68a07cde123ae0e27be35f6b52617b29 hostap-0.0.3-r1.ebuild 4279
MD5 f4a8c5996d013e8a161bf699bb7a2f83 files/digest-hostap-0.0.2-r1 64
MD5 a524f036540821632837b56cc92ba5db files/digest-hostap-0.0.3-r1 64
MD5 423cd360c12fa0a6530fb01f334a0bd6 files/digest-hostap-0.0.1 354
diff --git a/net-wireless/hostap/files/digest-hostap-0.0.3-r1 b/net-wireless/hostap/files/digest-hostap-0.0.3-r1
new file mode 100644
index 000000000000..fedfe67d9227
--- /dev/null
+++ b/net-wireless/hostap/files/digest-hostap-0.0.3-r1
@@ -0,0 +1 @@
+MD5 014d9efc7aec470e953eda811bdc6416 hostap-0.0.3.tar.gz 266376
diff --git a/net-wireless/hostap/hostap-0.0.3-r1.ebuild b/net-wireless/hostap/hostap-0.0.3-r1.ebuild
new file mode 100644
index 000000000000..40dde4a78f73
--- /dev/null
+++ b/net-wireless/hostap/hostap-0.0.3-r1.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap/hostap-0.0.3-r1.ebuild,v 1.1 2003/06/11 07:54:48 phosphan Exp $
+
+inherit eutils
+
+DESCRIPTION="HostAP wireless drivers"
+HOMEPAGE="http://hostap.epitest.fi/"
+
+MY_PCMCIA="pcmcia-cs-3.2.1"
+PATCH_3_2_2="${MY_PCMCIA}-3.2.2.diff.gz"
+PATCH_3_2_3="${MY_PCMCIA}-3.2.3.diff.gz"
+PATCH_3_2_4="${MY_PCMCIA}-3.2.4.diff.gz"
+
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz
+ pcmcia? ( mirror://sourceforge/pcmcia-cs/${MY_PCMCIA}.tar.gz )
+ pcmcia? ( mirror://gentoo/${PATCH_3_2_2} )
+ pcmcia? ( mirror://gentoo/${PATCH_3_2_3} )
+ pcmcia? ( mirror://gentoo/${PATCH_3_2_4} )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="pcmcia"
+
+DEPEND=">=net-wireless/wireless-tools-25
+ pcmcia? ( >=sys-apps/pcmcia-cs-3.2.1* )"
+
+LIB_PATH="/lib/modules/${KV}"
+
+if [ x"${HOSTAP_DRIVERS}" = x ]; then
+ CUSTOM="no"
+else
+ CUSTOM="yes"
+fi
+
+src_unpack() {
+ check_KV
+ unpack ${P}.tar.gz
+
+ if [ -n "`use pcmcia`" ]; then
+ unpack ${MY_PCMCIA}.tar.gz
+ cd ${WORKDIR}/${MY_PCMCIA}
+ if [ -z "`has_version =sys-apps/pcmcia-cs-3.2.4*`" ]; then
+ epatch ${DISTDIR}/${PATCH_3_2_4}
+ elif [ -z "`has_version =sys-apps/pcmcia-cs-3.2.3*`" ]; then
+ epatch ${DISTDIR}/${PATCH_3_2_3}
+ elif [ -z "`has_version =sys-apps/pcmcia-cs-3.2.2*`" ]; then
+ epatch ${DISTDIR}/${PATCH_3_2_2}
+ fi
+ fi
+
+
+ cd ${S}
+ mv Makefile ${T}
+ sed -e "s:gcc:${CC}:" \
+ -e "s:-O2:${CFLAGS}:" \
+ -e "s:\$(EXTRA_CFLAGS):\$(EXTRA_CFLAGS) -DPRISM2_HOSTAPD:" \
+ ${T}/Makefile > Makefile
+
+ if [ -n "`use pcmcia`" ] || [[ "${HOSTAP_DRIVERS}" == *pccard* ]]; then
+ mv Makefile ${T}
+ sed -e "s:^PCMCIA_PATH=:PCMCIA_PATH=${WORKDIR}/${MY_PCMCIA}:" \
+ ${T}/Makefile > Makefile
+ fi
+
+ cd ${S}/hostapd
+ mv Makefile ${T}
+ sed -e "s:gcc:${CC}:" \
+ -e "s:-O2:${CFLAGS}:" \
+ ${T}/Makefile > Makefile
+}
+
+src_compile() {
+ #
+ # This ebuild now uses a system similar to the alsa ebuild.
+ # By default, it will install the pci and plx drivers, and
+ # the pcmcia drivers if pcmcia is in your use variables. To
+ # specify exactly which drivers to build, do something like
+ #
+ # HOSTAP_DRIVERS="pci pccard" emerge hostap
+ #
+ # Available options are pci, plx, and pccard.
+ #
+ # If you experience problems compiling the hostap_pci module,
+ # try disabling CONFIG_MODVERSION from your kernel.
+ #
+
+ if [ "${CUSTOM}" == yes ]; then
+ einfo "Building the folowing drivers: ${HOSTAP_DRIVERS}"
+ emake ${HOSTAP_DRIVERS} hostap crypt || die
+ else
+ if [ -n "`use pcmcia`" ]; then
+ einfo "Building the folowing drivers: pci plx pccard"
+ emake pci plx pccard || die
+ else
+ einfo "Building the folowing drivers: pci plx"
+ emake pci plx || die
+ fi
+ fi
+
+ cd ${S}/hostapd
+ emake || die
+}
+
+src_install() {
+ dodir ${LIB_PATH}/net
+ cp ${S}/driver/modules/{hostap.o,hostap_crypt.o,hostap_crypt_wep.o}\
+ ${D}${LIB_PATH}/net/
+
+ if [ "${CUSTOM}" == "no" ]; then
+
+ if [ -n "`use pcmcia`" ]; then
+ dodir ${LIB_PATH}/pcmcia
+ dodir /etc/pcmcia
+ cp ${S}/driver/modules/hostap_cs.o ${D}/${LIB_PATH}/pcmcia/
+ cp ${S}/driver/etc/hostap_cs.conf ${D}/etc/pcmcia/
+ if [ -r /etc/pcmcia/prism2.conf ]; then
+ einfo "You may need to edit or remove /etc/pcmcia/prism2.conf"
+ einfo "This is usually a result of conflicts with the"
+ einfo "linux-wlan-ng drivers."
+ fi
+ fi
+ for driver in pci plx; do
+ cp ${S}/driver/modules/hostap_${driver}.o\
+ ${D}${LIB_PATH}/net/;
+ done
+ elif [ "${CUSTOM}" == "yes" ]; then
+ if [[ "${HOSTAP_DRIVERS}" = *pccard* ]]; then
+ dodir ${LIB_PATH}/pcmcia
+ dodir /etc/pcmcia
+ cp ${S}/driver/modules/hostap_cs.o ${D}/${LIB_PATH}/pcmcia/
+ cp ${S}/driver/etc/hostap_cs.conf ${D}/etc/pcmcia/
+ if [ -r /etc/pcmcia/prism2.conf ]; then
+ einfo "You may need to edit or remove /etc/pcmcia/prism2.conf"
+ einfo "This is usually a result of conflicts with the"
+ einfo "linux-wlan-ng drivers."
+ fi
+ fi
+
+ if [[ "${HOSTAP_DRIVERS}" = *pci* ]]; then
+ cp ${S}/driver/modules/hostap_pci.o\
+ ${D}${LIB_PATH}/net/
+ fi
+
+ if [[ "${HOSTAP_DRIVERS}" = *plx* ]]; then
+ cp ${S}/driver/modules/hostap_plx.o\
+ ${D}${LIB_PATH}/net/
+ fi
+
+ fi
+
+ dodoc FAQ README README.prism2 ChangeLog
+
+ dosbin hostapd/hostapd
+}
+pkg_postinst(){
+ /sbin/depmod -a
+}